設定を指定する

Google Web Designer の設定を指定するには、上部にあるメニューで [編集] > [設定] を選択します。各設定にアクセスするには、左側のタブをクリックします。

[デフォルトにリセット] をクリックすると、一連の各設定をデフォルトに戻すことができます。

全般の設定

全般

設定 説明

最後に使用したドキュメントで開く

Google Web Designer の起動時に初期画面のダイアログをスキップして、最後に使用したドキュメントを開くには、このチェックボックスをオンにします。

選択ツール オプションを保存して毎起動時に適用 Google Web Designer を再起動するたびに選択ツール オプションがリセットされないようにするには、このチェックボックスをオンにします。

マイ テンプレート

設定 説明

場所

[参照します ] アイコンをクリックして、パソコン上でカスタム テンプレート ファイルを保存する場所を選択します。マウント済みのドライブ(パソコンのファイル システムからアクセスできるドライブ)上にあるフォルダを選択する必要があります。

このパスを変更した場合、既存のカスタム テンプレートは [マイ テンプレート] の [テンプレート ギャラリー] に表示されなくなります。新たに選択した場所にカスタム テンプレート ファイルを手動で移動すれば、そうしたテンプレートが再びギャラリーに表示されます。

デフォルトパスにリセットします

[場所をデフォルトにリセットします Refresh icon] アイコンをクリックすると、場所が元のパスに変更されます。

[新しいファイル] ダイアログのデフォルト

設定 説明

広告タイプ

新しいドキュメントで使用するデフォルトの広告タイプを選択します。

環境

新しいドキュメントで使用するデフォルトの広告環境を選択します。デフォルトの広告タイプに応じて、該当するオプションのみが表示されます。

デザインビューの設定

デザインビューの設定では、新しいドキュメントの [表示] メニューでデフォルトで選択する項目を指定します。ここで設定する内容の一部は、現在の設定にも影響する場合があります(下記を参照)。

デザインビュー

設定 説明

アウトライン

ドキュメント ワークスペース内の要素のアウトラインについての設定を選択します。

  • ラベル - 選択中の要素以外のすべての要素に、破線の枠線と、要素のタイプと ID のラベルが表示されます。
  • アウトラインのみ - 選択中の要素以外のすべての要素に、破線の枠線が表示されます。
  • オフ - 未選択の要素に枠線やラベルは表示されません。
この設定は Web Designer 全体にわたって適用されます。新しいドキュメントや使用しているドキュメントの設定が変更されるほか、[表示] メニューで行った選択にも反映されます。

ルーラーを表示

水平と垂直のルーラーをデフォルトで表示するには、このチェックボックスをオンにします。

この設定ではデフォルトを指定します。新しいドキュメントや明示的にルーラーの設定をしなかったドキュメントの設定は変更されますが、個別のドキュメントで [表示] メニューで行った選択内容は変更されません。

スナップとグリッド

設定 説明

スナップ

同じ水平線または垂直線に沿ってオブジェクトを配置するには、このチェックボックスをオンにします。スナップ先の要素を以下から選択します。

  • グリッドにスナップ - 3D グリッド上の線にスナップされます。
  • オブジェクトにスナップ - ステージ上のオブジェクトの端、角、中心にスナップされます。
  • スナップ位置揃え - 選択したオブジェクトは他のオブジェクトと一列に揃えてスナップされます。
  • ガイドにスナップ - 定規ガイドにスナップされます。
この設定は Web Designer 全体にわたって適用されます。新しいドキュメントや使用しているドキュメントの設定が変更されるほか、[表示] メニューで行った選択にも反映されます。

3D グリッド

そのビューとほぼ並行な平面のグリッドを表示するには、このチェックボックスをオンにします。

この設定ではデフォルトを指定します。新しいドキュメントや明示的に 3D グリッドの設定をしなかったドキュメントの設定は変更されますが、個別のドキュメントで [表示] メニューで行った選択内容は変更されません。

  • グリッドサイズ - グリッド線の間隔を 10~1,000 ピクセルの間で指定します。デフォルトは 50 ピクセルです。指定したグリッドサイズは、3D グリッドが表示されるすべてのドキュメントで使用されます。

アウトライナー

設定 説明

DOM 順で要素を並べ替え

DOM(ドキュメント オブジェクト モデル)に一致するようにアウトライナー内の要素の表示順序を変更するには、このチェックボックスをオンにします。チェックボックスをオフにすると、詳細モードのタイムライン内のレイヤと同じ順序で要素が表示されます。

ガイド

設定 説明

ガイドの色を設定します。

コードビューの設定

コードビューの設定では、コードビューの動作や外観を指定します。

設定 説明

色テーマ

コードビューのワークスペースや構文の強調表示に使用する色テーマを選択します。各テーマをプレビューできます。

書式設定オプション

コードの書式設定オプションは、ファイルを開いたとき、またはデザインビューで変更してコードビューに切り替えたときに有効になります。これらの設定は、上述の [設定] ダイアログのコードサンプルでプレビューできます。

設定 説明

丸かっこ内でパディング

括弧内のテキストをスペースで埋めるには、このチェックボックスをオンにします。

ファイルの最後で改行する

ファイルの末尾に改行文字を含めるには、このチェックボックスをオンにします。

CSS セレクタを改行で区切る

同じ CSS ルールに複数のセレクタが指定されている場合に、CSS セレクタを改行文字で区切るには、このチェックボックスをオンにします。

CSS ルールを改行で区切る

CSS ルールを改行文字で区切るには、このチェックボックスをオンにします。

インデント サイズ

1 つのインデントで使用するスペースまたはタブの数を設定します。

波かっこのスタイル

JavaScript での波かっこの記述形式を選択します。

  • [折りたたむ] - 波かっこはインラインに置かれます。
  • [展開する] - 波かっこはそれぞれ独立した行に置かれます。
  • [展開を終了する] - 閉じかっこのみ独立した行に置かれます。

スクリプトとスタイルタグのインデント

<script> タグと <style> タグ内でインデントを開始する方法を選択します。

  • [標準] - コードのインデントは、囲みタグの 1 段下のレベルから始まります。
  • [維持] - コードのインデントは、囲みタグと同じレベルから開始します。
  • [分離] - コードはインデントなしで開始します。

属性の行を折り返すスタイル

HTML タグの属性の行を折り返す方法を選択します。

  • [自動] - 属性が 1 行の長さを超える場合は、自動的に行を折り返します。
  • [強制] - 各属性はそれぞれ新しい行に置かれます。

行を折り返す

指定された文字数を超える行を折り返すには、このチェックボックスをオンにします。

エディタ オプション

コードビュー エディタのオプションは、保存時にすぐに反映されます。

設定 説明

キーマップ

各テキスト エディタに関連付けられている機能を使用するためのキーマップを選択します。

  • デフォルト
  • Emacs
  • Sublime
  • Vim

末尾のスペースを表示

行の末尾のスペースを表示するには、このチェックボックスをオンにします。

選択したテキストとの一致をハイライト表示

カーソルの位置や選択範囲に基づいて、一致するコードを強調表示するには、このチェックボックスをオンにします。

インデント

新しい行に自動的にインデントを適用するには、このチェックボックスをオンにします。

閉じかっこの自動入力

左かっこを入力したときに自動的に右かっこを追加するには、このチェックボックスをオンにします。

閉じタグの自動入力

HTML の開始タグを入力したときに自動的に閉じタグを追加するには、このチェックボックスをオンにします。

オートコンプリート オートコンプリートの候補が自動的に表示されるようにするには、このチェックボックスをオンにします。

タブにスペースを使用

新しいタブをスペースに変換するには、このチェックボックスをオンにします。

ミニマップの表示 ドキュメントの縮小図を表示するには、このチェックボックスをオンにします。

環境

設定 説明
ズーム率を保存 Google Web Designer を起動するたびにコードビューのズームレベルがリセットされないようにするには、このチェックボックスをオンにします。

詳細設定

詳細設定はアプリケーション全体に影響します。場合によっては(下記を参照)、Google Web Designer を再起動した後に変更が有効になります。

ロギング

設定 説明

詳細ロギングを有効にする

パソコン上の以下の場所に詳細なログを生成するには、このチェックボックスをオンにします。

  • Windows: C:\Users\<username>\AppData\Local\Google\Google Web Designer\logs
  • Mac: /Users/<username>/Library/Application Support/Google/Web Designer/logs
  • Linux: ~/.local/share/google-web-designer/logs/

問題をトラブルシューティングするときにのみ、この設定を一時的にオンにします。

この設定への変更は、Google Web Designer を再起動した後に有効になります。

アプリのズーム

設定 説明

デフォルトのズームをオーバーライドする

モニター用に Google Web Designer が自動的に検出する設定とは異なるズームレベルを設定するには、このチェックボックスをオンにします。

  • ズーム率: 70%~200% の間でパーセンテージを入力します。

この設定への変更は、Google Web Designer を再起動した後に有効になります。

この情報は役に立ちましたか?
改善できる点がありましたらお聞かせください。