Search
Clear search
Close search
Google apps
Main menu

Set your preferences

Configure your preferences for Google Web Designer by selecting Edit > Preferences from the top menu. Access each set of preferences by clicking the tab on the left.

You can restore each set of preferences to its defaults by clicking Reset to defaults.

General preferences

General

Setting Description

Launch with recent open document

Check this box to skip the welcome dialog when you launch Google Web Designer and start with your most recently opened document.

My Templates

Setting Description

Location

Click the folder icon  to browse your computer and select where custom template files should be saved. The folder must be on a mounted drive (i.e., accessible through your computer's file system).

If you change this path, existing custom templates will no longer appear in the Template Gallery under "My Templates". You can manually move custom template files to the new location to restore them to the gallery.

Reset to default path

Click the reset icon  to change the location to the original path.

New file dialog defaults

Setting Description

Ad type

Select the default ad type for new documents.

Environment

Select the default ad environment for new documents. Only appropriate options for your default ad type will be listed.

Design view preferences

Design view preferences set your default selections in the View menu for new documents. In some cases (noted below), these preferences also affect your current settings.

Design view

Setting Description

Outline

Select your preference for outlines for elements on stage:

  • Label - Display a dashed border and a label with the element type and ID for every element that's not the selected element.
  • Outlines only - Display a dashed border around every element that's not the selected element.
  • Off - Display no outlines or labels for unselected elements.
This preference is universal across Web Designer: it changes the settings for new and open documents, and also reflects selections made in the View menu.

Show rulers

Check this box to make the horizontal and vertical rulers visible by default.

This preference is a default: it changes the settings for new documents and documents in which a ruler preference wasn't explicitly set, but doesn't override selections made in the View menu for individual documents.

Snap and grid

Setting Description

Snap

Check this box to align objects along the same horizontal or vertical lines. Select the elements you want to snap to:

  • Snap to grid - Snap to the 3D grid lines.
  • Snap to objects - Snap to the edges, corners, and centerpoints of objects on the stage.
  • Snap align - Snap the selected object into alignment with other objects.
This preference is universal across Web Designer: it changes the settings for new and open documents, and also reflects selections made in the View menu.

3D grid

Check this box to display the grid for the plane that's nearest to parallel to your view.

This preference is a default: it changes the settings for new documents and documents in which a 3D grid preference wasn't explicitly set, but doesn't override selections made in the View menu for individual documents.

  • Grid size - Specify the spacing between grid lines, between 10 and 1000 pixels. The default is 50 pixels. The specified grid size is used for all documents with a visible 3D grid.

Code view preferences

Code view preferences control the behavior and appearance of Code view.

Theme and environment

Setting Description

Color theme

Select your preferred color theme for the Code view workspace and syntax highlighting. You can preview each theme.

Key map

Select a key map to use the functionality associated with that text editor.

  • Default
  • Emacs
  • Sublime
  • Vim

Editor options

Setting Description

Show trailing spaces

Check this box to make spaces at the end of a line visible.

Highlight selection matches

Check this box to highlight matching code based on your cursor or selection.

Indentation

Check this box to automatically indent new lines.

Auto close brackets

Check this box to automatically add a closing bracket when you type an opening bracket.

Auto close tags

Check this box to automatically add a closing tag when you type an opening HTML tag.

Use spaces for tabs

Check this box to convert new tabs into spaces.

Advanced preferences

Advanced preferences affect the entire application. In some cases (noted below), changes take effect only after you restart Google Web Designer.

Preview

Setting Description

Preview ads over HTTP

Check this box to preview documents over HTTP, using a local server. Otherwise, previews opened in your browser will use the file protocol (file://) instead.

Changes to this preference take effect immediately upon saving.

Logging

Setting Description

Enable verbose logging

Check this box to generate detailed logs in the following location on your computer:

  • Windows: C:\Users\<username>\AppData\Local\Google\Google Web Designer\logs
  • Mac: /Users/<username>/Library/Application Support/Google/Web Designer/logs
  • Linux: ~/.local/share/google-web-designer/logs/
Turn on this setting only temporarily to troubleshoot an issue.

Changes to this preference take effect after restarting Google Web Designer.

Application zoom

Setting Description

Override default zoom

Check this box to set a zoom level different than the one Google Web Designer automatically detects for your monitor.

  • Zoom percentage: Enter a percentage between 70% and 200%.

Changes to this preference take effect after restarting Google Web Designer.

Was this article helpful?
How can we improve it?