Requirements to use the Nest app

The Nest app lets you set up, control, and see the status of your Nest products. To be able to use the Nest app, your phone, tablet, wearable, TV, or computer needs to meet some minimum requirements.

You can install the Nest app on a number of Android and Apple products, and you can also manage your Nest home using a web browser on a Windows or Mac computer.

Whichever device you’re using, it’s always a good idea to keep it up-to-date for the latest security and bug fixes.

Important: Using the Nest app on an older product that doesn’t meet the requirements may cause compatibility issues. If you do have any problems with the Nest app, check that your device software is up to date.

The tables below outline the minimum requirements to install and use the Nest app on different types of devices.

Android phones and tablets

Android TV

Additional Bluetooth LE requirement for Android phones and tablets

A few functions of the Nest app require Bluetooth Low Energy (BLE), which first appeared in Bluetooth 4.0.

Many Android phones and tablets include BLE. Chances are, if you bought your device within the last few years, it has BLE. The only way to be sure, though, is to check the technical specifications on your phone or tablet manufacturer’s website, to see if your device uses Bluetooth 4.0 or later.

You can use the Nest app on a device without BLE. Many of the app’s features will work without BLE. But if you want to use the following features, your device needs to have BLE.

  • Google Nest Protect
    • 2nd gen Nest Protect needs BLE for App Silence and Safety Checkup with the app. If you want to use App Silence and Safety Checkup on an Android device, you also need to have Android 5.0 or newer.
    • 1st gen Nest Protect does not have or need BLE.
  • Google Nest Thermostat: BLE is not needed (applies to all thermostats).

  • Google Nest Cam

 

Was this helpful?
How can we improve it?