/wearos/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
7/10/19
Delay in Google fit heart rate results 1 Recommended Answer 5 Replies 20 Upvotes
1 Recommended Answer
$0 Recommended Answers
I have a ticwatch C2 which has a heart rate sensor, it has been working perfectly with Google fit.

Until the last update of Google fit app on the watch, it started to delay the heart rate results a few hours until I could see them, for example; when I take a reading at 1 o'clock, it doesn't show me the result until 5 o'clock.

Meanwhile it doesn't appear on the watch, it does show on phone's fit app.

I tried uninstalling the updates, the data, cached data, I even did a factory reset. Yet it didn't work.

The problem is with the watch Google fit app latest update, is anyone experiencing this? How can I fix it? Or should I wait till the next fit update?
All Replies (5)
7/15/19
I have the exact same problem on my Fossil Sport. Hopefully it just needs an update...
marked this as an answer
Helpful?
7/19/19
Same exact one on Ticwatch E + xiaomi mi A2 or even on a nexus 6 both with android pie . Heart rate is not showing via the fit tile or app on the watch, but is recorded in the fit app on phone . Than after some hours is also synced to the watch . I can see all my hr recordings of yesterday on the watch, when I started digging for the problem . Today I just tried 5 times, they're all present on the phone's fit app , but not on the watch . This problem started since about 2 weeks , and it's not due to tiles because the first week of tiles I was using the hr one around 10 times a day and was working great , both from tiles and directly from the button on the watch s fit app . I remember I could also get the list of the hr recordings in real time without wating many hours . How I wish wear os would simply work , they update and fix something and break 2 new things . This is incredible for a closed source os , they can't get it to work bug free , and people are migrating to other better ecosystems
Last edited 7/19/19
marked this as an answer
Helpful?
7/20/19
Can confirm same issue on the new to watch pro LTE
marked this as an answer
Helpful?
8/7/19
Yep, for the last few months, heart rate results don't show up on the watch, just in the fit app on my phone.  Very annoying and not very useful.  At least my Ticwatch has it's Mobvoi heart rate app and that shows.  Unfortunately that can only be seen if I launch that app separately from fit.  Since I don't use that app for fitness that too is not very useful. Google, please fix this so that the heart rate shows up on both (or at least provide an option for one or the other).
marked this as an answer
Helpful?
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/wearos/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/wearos/profile/0?hl=en