/wearos/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
2/23/18
Android wear app says connected, notifications come, but watch says disconnected, cant get internet 0 Recommended Answers 175 Replies 391 Upvotes
1 Recommended Answer
$0 Recommended Answers
Last edited 12/6/19
I am having some issue with Android Wear and my Huawei Watch.  I am unsure when it started.  I first noticed the issues a few weeks ago.

I have bluetooth connection to my watch SORT OF.
The app on my phone says I am connected to the watch.
I receive and can reply to notifications on the watch.
I can track my position on the watch using the phone as the source for location tracking.
Watchmaker will send new watch faces.
I can control music.
I can ring the phone using phone locator

HOWEVER
When I look at bluetooth connectivity ON the watch it says it is disconnected from the phone.
Google assistant on the watch cannot connect to the internet through the phone (I keep wifi off to save battery life)
Nest on the watch cannot connect to the servers
Weather on the watch cannot connect to the internet
The phone battery level information on my watchface does not update and is therefore incorrect.

This problem can be temporarily corrected by disconnecting the bluetooth connection to the watch in the android wear app on the phone, force closing the android wear app on the phone, clearing the cache data, reconnecting the bluetooth connection in the android wear app.  ALL STEPS MUST BE DONE.   This helps for a short period, but the problem recurs in a few short hours.  This must be done a few times a day.

My phone is a OnePlus 3T, running Android 8.0.0, and the December 1, 2017 security patch.
My android wear app version is 2.9.0.185084575
The android wear version on my Huawei Watch (version 1)  is 2.9.0.185193291
On my watch the google play services version is 11.9.75
The OS version is 7.1.1, with the october 5, 2017 security patch.


Is there some setting I have messed up that is causing this problem?  Is there a fix in the road?  I enjoy using google assistant, the weather, nest and other internet based services on my watch that seem to be not working when this connection issue occurs (several times a day).
All Replies (175)
2/23/18
Hey Jerry,

If you haven't already, I'd suggest that you try the following to completely reset Android Wear. There's unfortunately no guarantee that this will work for you, but it does seem to have helped a number of users with similar issues:

  1. On your watch, go to Settings > System > Disconnect & reset.
  2. On your phone, go to Settings > Bluetooth and Forget the pairing with your watch.
  3. Go to Settings > Apps > Android Wear > Storage > Clear data.
  4. Go to Settings > Apps > Google Play Services > Storage > Manage space > Clear all data.
  5. Reboot.
  6. Once both the watch and phone have rebooted, follow these instructions to reconnect:
    https://support.google.com/androidwear/answer/6056630
Please let me know how it goes,
John
marked this as an answer
Helpful?
-
2/23/18
I will give this a try and see if it corrects the problem.  I have already once factory reset the watch and it didn't help, but I do not recall if I cleared all of the app data before reconnecting.

I'll let you know.
Jerry
marked this as an answer
Helpful?
2/23/18
Yeah, sometimes you need to clear the app data on the phone to make sure it really resets things for a fresh start. Hopefully that will work for you. 

*fingers crossed*
marked this as an answer
Helpful?
-
2/26/18
Unfortunately this appears to not have worked.  It seemed to for a day, maybe 2 (I didn't check or use the assistant or watch my watch battery Saturday on the watch).  It is again "disconnected" on the watch, receiving notifications, calls, music controls etc... but not sharing phone info, internet access, etc....

Other ideas?
marked this as an answer
Helpful?
2/27/18
Hey Jerry,

Sorry to hear that didn't work out.

When the issue occurs, is your phone connected to the internet via Wi-Fi, mobile data, or either? Do you use any VPN, ad-blocking, or firewall software on your phone? Are any data- or battery-saver modes active?

Thanks,
John
marked this as an answer
Helpful?
3/2/18
I have the same issue as well. Phone is connected to WiFi or not the watch shows Bluetooth disconnected.
marked this as an answer
Helpful?
-
3/2/18
User, 
Sorry to hear that.  Try what John told me to try in the first response.  My results have been mixed but yours may be better.

John, 
So my watch still does the disconnect and not communicate thing but it is intermittent now.  It is still the same thing, not completely disconnected, still getting notifications and what not just not phone info or shared internet, but it doesn't need the cache wipe to get reconnected. It just at some point, usually within an hour reconnects.  It doesn't do it often (though I may not notice all the times it does it as again only a handfull of features are missing when it does.).   It is better.  Still not always right but it is better.

I have been to determine over the past could of days if it seems like it could be connected to any particular use/app/anything. I have found nothing yet. I don't use any VPN, ad-blocker or the like and my battery saver setting is set to off/never turn on automatically.  I am stumped as to the cause.
marked this as an answer
Helpful?
3/2/18
I did try the reset option the other day. Bluetooth showed connected for a day and then changed back to disconnected. I do receive notifications but google Assistant and weather update on the watch doesn't work. It solely depends on the WiFi. No WiFi means no network connection on the watch.
marked this as an answer
Helpful?
3/2/18
I'm afraid I'm kind of out of troubleshooting ideas on this one. I'd recommend making liberal use of the Menu > Help & Feedback > Send feedback option in the Android Wear app whenever you notice this issue occurring so it can be reported directly to the Android Wear team.
marked this as an answer
Helpful?
6 days
@Yigal
Yes, tried resetting app and watch multiple times. Also resettet bluetooth, google and playstore. Disabled battery optimisation for all apps
marked this as an answer
Helpful?
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/wearos/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/wearos/profile/0?hl=en