/wearos/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
1/6/18
Download pending Play Store - Android wear 0 Recommended Answers 80 Replies 555 Upvotes
1 Recommended Answer
$0 Recommended Answers
Last edited 5/28/18
Tried to clear cache and data on Play store app, tried to download app connected to BT and wifi. Only a device reset solves the problem but after few days it comes back. Is there a fix coming?
All Replies (80)
1/10/18
Hi Dario,

What watch and phone are you using? Is it a single app that seems to get stuck in the "download pending" app or does it happen for any and every app you attempt to install (or update?)?

Thanks,
John
marked this as an answer
Helpful?
-
1/10/18
Hallo,
I'm on a Huawei watch 2 - Xperia X (Android 7.1.1)
Every app I try to download/update, it get stucked. 
TY.
Last edited 1/10/18
marked this as an answer
Helpful?
1/11/18
Hey Dario,

Could you try going to Settings > Apps > System Apps > Google Play Store > App info > Clear data to see if that helps clear a stuck download and get you going again? If not, you might try the Settings > Apps > System Apps > Google Play Store > Remove Upgrades option to revert the app to an older version to see if that helps. 

These are steps that might be performed as a part of the factory reset but may be able to work around the issue without having to take that drastic step. Please do let me know what you find out!

Cheers,
John
marked this as an answer
Helpful?
-
1/11/18
Hi,
I've tried both suggestions on the watch but they didn't solve the problem. Even at oldest version of the Play Store, app downloads and updates still stay stucked.
marked this as an answer
Helpful?
1/11/18
Try disabling Bluetooth on the watch (forcing it to connect to Wi-Fi) and see if that has any impact.
marked this as an answer
Helpful?
-
1/11/18
Unfortunately it doesn't work.
marked this as an answer
Helpful?
1/12/18
About the only other thing I can think to try would be to reset the watch again but only reinstall your apps/faces very slowly - maybe one per day so you can track if/when the issue reoccurs.
marked this as an answer
Helpful?
-
1/12/18
I guess I'll be waiting for a fix. I hope the dev team is working on it. 
Thanks a lot for your support.
marked this as an answer
Helpful?
1/12/18
Please be sure to use the Menu > Help & feedback > Send feedback option within the Android Wear app on your phone to report this issue to Google. That should capture some logs that might help to diagnose the problem.
marked this as an answer
Helpful?
11/27/19
I suggest you to clear Google Play Store's app cache, it probably would solve the problem! Just follow these instructions: 
 
  1. Open your device's Settings app .
  2. Tap Apps & notifications  See all apps.
  3. Scroll down and tap Google Play Store .
  4. Tap Storage  Clear Cache.
  5. Next, tap Clear data. Click Here For More Details
marked this as an answer
Helpful?
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/wearos/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/wearos/profile/0?hl=en