/pixelphone/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
Do Not Disturb with Android 11 on Pixel 3A does not ring for contacts 7 Recommended Answers 66 Replies 98 Upvotes
1 Recommended Answer
$0 Recommended Answers
1 Relevant Answer
$0 Relevant Answers
I have a Pixel 3A, just upgraded to Android 11.  I have Do Not Disturb set to allow interruptions from Contacts.  The phone does not ring when called from a contact, it rings fine when DND is off.  It worked perfectly for version 10, ringing for contacts.  I have been on with the support chatline and they checked all my settings with me no improvements.  Any ideas?
Relevant Answer Relevant Answers (0)
All Replies (66)
Relevant Answer
Can you please try if it works in safe mode?
marked this as an answer
Most relevant based on info available
-
Relevant Answer
No it does not work in safe mode.  The final suggestion they made was a factory reset but I am old school and don't want to "reformat the hard drive and reinstall all the apps".
marked this as an answer
Most relevant based on info available
Relevant Answer
Try resetting app preferences under settings > system > advanced > reset options.
marked this as an answer
Most relevant based on info available
-
Relevant Answer
I did do app preferences reset.
marked this as an answer
Most relevant based on info available
Relevant Answer
Then the only thing left to try would be a factory reset as suggested I'm afraid.
marked this as an answer
Most relevant based on info available
-
Relevant Answer
I guess I was also looking to see if anyone else had experienced this.
marked this as an answer
Most relevant based on info available
Relevant Answer
Feel free to wait and see if someone else that might have experienced the issue replies.
marked this as an answer
Most relevant based on info available
-
Relevant Answer
Ok, so I did a factory reset.  Issue with DND & contacts still remains, no change.  I did notice and should have mentioned it before because it also was the same before was that when I go into the phone ringtone settings, there is no sound when I change ringtones, if DND is on.  If DND is off, i hear the ringtones.  It appears as the DND control cannot activate the ringer?  I'm sure there must be a setting or override for that?  Any idea?  I saw another post about not hearing ringtones but didn't see the solution.
marked this as an answer
Most relevant based on info available
Relevant Answer
I am also experiencing this on my Pixel 4 XL
marked this as an answer
Most relevant based on info available
Relevant Answer
Same on google pixel 4.. after undated latest Android version... Is there anyway to change your older version
marked this as an answer
Most relevant based on info available
-
Relevant Answer
Salim - can you weigh in on the latest comments?
marked this as an answer
Most relevant based on info available
Relevant Answer
Same problem on my Pixel 3. DND will not allow starred contacts to ring through, but turn off DND and the phone rings correctly
marked this as an answer
Most relevant based on info available
Relevant Answer
Hi Tom, can you please check if the solution in the post below solves your issue?
marked this as an answer
Most relevant based on info available
Relevant Answer
I tried that solution and still didn't see to work. Before Android 11, I had DND on and it allowed starred contacts to message and call and it would vibrate only for them but now nothing is vibrating on DND... bad update. HELP!
marked this as an answer
Most relevant based on info available
-
Relevant Answer
I've been going round and round with device-support@google.com, lots of factory resets, etc.  No improvement.  Anyone have any luck with this?
marked this as an answer
Most relevant based on info available
-
Relevant Answer
Here is the latest from them (I had resent the bug report and asked for bug ID):

Thank you for writing back to Google support.
Thank you for sharing the bug report. Apologies for the run around. I'd like to inform you that we cannot share the bug ID since it is an internal source. I'd like to inform you that this bug report has been already shared to our concerned team. Our engineering team is working on this and will definitely fix this issue in the future updates. 
Please be assured that the issue will be taken care leaving no stones unturned
marked this as an answer
Most relevant based on info available
Relevant Answer
I'm having the same problem after updating to Android 11 yesterday on a Google Pixel 3a XL.
marked this as an answer
Most relevant based on info available
Relevant Answer
I have the same issue on a pixel 3xl. I get on screen notification of incoming calls but no ring.

Safe mode makes no difference.

I did a factory reset with all the normal issues this causes but no change to this bug
marked this as an answer
Most relevant based on info available
Relevant Answer
Oh wow. I am having the same issue with my Pixel 2 since the upgrade. Google, this is an issue that needs to be fixed.
marked this as an answer
Most relevant based on info available
Relevant Answer
Pixel 3a xl

Same issue.  DND worked perfectly prior to Android 11 update.  Now, it does not allow starred contacts to ring through.
marked this as an answer
Most relevant based on info available
Relevant Answer
Hi Google, 

Please give a high priority to solve this issue!

This can become a life threatening situation for vulnerable people, as many users would have their phone in do-not-disturb mode while keeping incoming calls enabled for specific vulnerable contacts (children, elderly, disabled) this must be solved asap.
marked this as an answer
Most relevant based on info available
Relevant Answer
I'm having the same issue- since updating to Android 11 on my Pixel 2XL, notifications from my starred contacts don't come through on Do Not Disturb (calls or texts). This is a serious problem!
marked this as an answer
Most relevant based on info available
Relevant Answer
I am having this exact issue on Pixel 4a. I got it recently and only have had Android 11 so am unsure of what this model did on Android 10 but all prior phones with DnD worked fine allowing starred contact exceptions. Agreed this is a serious bug as the functionality allowed for only priority contacts/situations to break DnD. None of the solutions listed have fixed this situation.
marked this as an answer
Most relevant based on info available
Relevant Answer
The simplest solution would be simply to allow us to roll back to Android 10. The broken DND settings are not even the only bug in Android 11, media player notifications seem to be broken as well. Allowing rolling back to Android 10 without having to re-install everything (just like rolling forward to Android 11 did not require any re-installing) should have been the simplest solution.
marked this as an answer
Most relevant based on info available
Relevant Answer
Similar issue with app exceptions not working on my Pixel 4a. Notification happens but no vibration or sound, despite the app being set to allow interrupt.
marked this as an answer
Most relevant based on info available
Relevant Answer
I had repeat callers turned on before but had it turned off to test something and that did indeed affect it in unexpected ways but not exactly like you suggested.

With repeat callers turned on it ringed but the screen did not turn on and if I turned the screen on, the ringing stopped and I had to go search for the phone app to answer.
When I then turned repeat callers back off again, the screen did go on but it didn't ring.
I ended up setting it to allow all callers, but still blocking e-mail notifications, etc. And now the phone turns on and rings as it should be. Just got to hope I don't get spam calls during working hours.
marked this as an answer
Most relevant based on info available
Relevant Answer
Just open the Phone app info, go to Notifications > Incoming Calls > Advanced > Override Do Not Disturb.
For some reason Android 11 blocked the phone app notifications while DND is active, so you have to add it as exception.
marked this as an answer
Most relevant based on info available
Relevant Answer

Thanks. I now get sound only from Starred Contacts. However, the screen still comes on when I get a call from non-starred contacts. Is there any way to prevent this, do you know?
marked this as an answer
Most relevant based on info available
Relevant Answer
To get the sound and the screen to come on, you need both workarounds. The one Titusz Rónai posted above, and to 'Allow Repeat Callers'.
marked this as an answer
Most relevant based on info available
Relevant Answer
Same issue with Pixel 3A / Android 11

The solution that Titusz Rónai posted doesn't work for me. 

Only the workaround using "Repeat callers" works, which is not a good enough solution.
marked this as an answer
Most relevant based on info available
Relevant Answer
Same issue and same results as previously stated. Pixel 3 / Android 11. The workaround did work.
marked this as an answer
Most relevant based on info available
Relevant Answer
Would like to add that it also affects Text Messages as well from starred contacts. Not sure allowing repeat callers will fix that.
marked this as an answer
Most relevant based on info available
Relevant Answer
Titusz Rónai 

I tried all of these recommendations and nothing worked. Well, I haven't tried the repeat callers setting yet because I was hoping I could get it to work without it. 
I've attached all of my settings. Am I missing something?
It's only allowing me to attach 3 screenshots..

marked this as an answer
Most relevant based on info available
Relevant Answer
Titusz Rónai

Here is the last screenshot
marked this as an answer
Most relevant based on info available
Relevant Answer
I found this conversation posted this morning after being fed up with the "No Ring Tone" issue since the 11 update, and I missed the call from my elderly mother on the floor with a broken ankle. This issue needs to be resolved immediately.
marked this as an answer
Most relevant based on info available
Relevant Answer
Franks workaround worked for me. If you are having the same problem this very well might work for you too
marked this as an answer
Most relevant based on info available
Relevant Answer
Hi. The repeat caller workaround has solved for regular calls but it does not solve for WhatsAppp messages or calls from started contacts, which used to work in android 10 under DND. On pixel 3 and 5.
marked this as an answer
Most relevant based on info available
Relevant Answer
With over 100 people chiming in on this defect, is there any need to initiate 1:1 support as @Salim and @Lilybell2 recommend?
marked this as an answer
Most relevant based on info available
Relevant Answer
My wife and I purchased the pixel 5 s. Mine works fine. Wife's has the same issues. Same settings as mine...reset app settings and nothing.  

I also was testing the ringers out, with do not disturb, the phone would not play it, as soon as I turned off do not disturb , it played... So is it possible a different setting affecting it?
marked this as an answer
Most relevant based on info available
Relevant Answer
Any informational update regarding to this issue?
marked this as an answer
Most relevant based on info available
Relevant Answer
This is happening for me as well. Set do not disturb and then add app exceptions for WhatsApp, and nothing comes through with vibration. Very frustrating for those trying to cut down the notification noise in general from so many apps.
marked this as an answer
Most relevant based on info available
Relevant Answer
Not fixed yet, I've got no sound or vibration for messages, Pixel 3a XL, January 2021 patch
marked this as an answer
Most relevant based on info available
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/pixelphone/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/pixelphone/profile/0?hl=en