/pixelphone/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
After updating to Android 10, Wi-Fi hotspot feature has no internet connectivity.
0
Yesterday, after updating to Android 10, everything went smoothly but my devices, when connected, show no internet access.  So far I've tried a Windows 10 laptop and another phone.  I have done a Network Setting Reset on my phone, but it did not help.  Any other ideas I could try?  This is the same across bluetooth, usb tether, and WiFi using Android 10 OS.  If I use pdanet's functionality it works, but my carrier kicks me off after about 20 minutes.  I confirmed with my provider I have tethering and hotspot on my account (AT&T).
Latest Update Latest Updates (0)
Relevant Answer Relevant Answers (0)
All Replies (77)
Relevant Answer
For me, I can turn on the hotspot without a hotspot plan.
marked this as an answer
Relevant Answer
for me, I keep losing wifi on my saved connection, ever since Android 10 update.
marked this as an answer
Relevant Answer
Hi Justin,
 
The WiFi hotspot functionality works fine with my Pixel 3 XL on Q for me.
 
Please try fully powering off and restarting
 
Also, restarting the phone into Safe Mode where all 3rd-party apps are disabled would also be worth a try. .
 
- Mike
marked this as an answer
Relevant Answer
This didn't seem to work, though I hadn't thought of it - I forced the radio on with data in safe mode and it still wouldn't connect.  Thanks for the suggestion!  I'll try factory resetting and go from there.
marked this as an answer
Relevant Answer
Chatted with Google support yesterday and the steps they walked me through seem to have solved my problem: no wifi disconnects since I did this (and it did not involve factory reset, whew!):

Go to settings > System > Advance > Reset options > Reset WiFi, Bluetooth and mobile network.
... If Pixel on Google Fi and no SIM card, uncheck the box to clear SIMs.

Go to settings > Apps and notifications > See all apps > Settings > Force stop.

Go to settings > Apps and notifications > See all apps > Settings > Storage > Clear storage.

Go to settings > Apps and notifications > See all apps > Settings > Three vertical dots on the top right corner > Uninstall updates.
--- skip if no three dots (I skipped this cuz no three dots)

Restart the device for the settings to be applied and check if the WiFi stays connected.
marked this as an answer
Relevant Answer
You mean to go into the applications and notifications menu and click one by one forcing stop, clearing storage and uninstalling update?
That seems to be really time consuming for me. I've got a whole lot of applications installed (as most people, I presume).
marked this as an answer
Relevant Answer
Same here on pixel 1 xl. WiFi tethering stopped to work after updating to stable Android 10. Other devices connect to WiFi hotspot fine, although they got no internet connection. Tried to reset network settings, no effect.
marked this as an answer
Relevant Answer
In the past I had to use the tether_dun_required to 0 via ADB; in this Android 10 this does not work any more;
marked this as an answer
Relevant Answer
Yep. same here.  I can connect to the hotspot but there is no internet through it.
marked this as an answer
Relevant Answer
Did factory resetting work for fixing this?
marked this as an answer
Relevant Answer
I have following issues after Android 10 update.
1. WiFi detects access points but it's not connecting to saved networks. I tried to clear the saved ones and tried connecting as a fresh device. Still no luck.
2. Next one is WiFi hotspot tethering. Switched on the hotspot. My laptop doesn't even detect my pixel hotspot. I've been using this for recent years without any issue until the 10 update.
Currently I'm using USB tethering to connect to my laptop. This is frustrating 😒
marked this as an answer
Relevant Answer
@li Gardner.   Her post instructions worked on my Pixel 3xl
marked this as an answer
Relevant Answer
So I tried Li Gardner's tips and it didnt work. Then Factory Reset, nothing changed. I dont know what to do because my wife's phone has no issues whatsoever
marked this as an answer
Relevant Answer
Same here, I had this issue with Android 8 and 9, 

I found that these steps helped before but not on Android 10 :( any ideas?

ANDROID 8/9 Fix:

1 - Put your phone in debugging mode

Under Setting -> system -> about phone, tap repeatedly on Build Number, until the prompt asks if you want to enable developer mode

2 - Enable USB debugging on your phone

Under Setting -> system -> Developer options  turn on USB Debugging

3 - plug your phone into USB, there may be a popup to allow remote debugging, allow this. 

4 - Download the Android SDK - I highly recommend you get the official ones from Android, but I've zipped the exact ones I used and put them on my server here : sargunar.com/platform-tools.zip

5 - Unzip the platform tools (either from Android - recommended - or me above)

6 - Open a command window, and browse to the folder where you have the files.

7 - Type the following and press the  [Enter] key

adb shell
 
This starts the Android shell (terminal where commands can be typed), which can work on your phone.
Once in the shell, type this:

settings put global tether_dun_required 0
 
Press return.  To confirm it worked, type this and press return:
 
settings get global tether_dun_required
 
It should print out a zero.
 
Then type either quit or exit
 
And that's it
marked this as an answer
Relevant Answer
Same problem, and this worked for me - much simpler. Just remove security, connect, then add security again.  But maybe the change to 5GHz did it; I'll never know. Details follow:

Settings, Network, wifi hotspot, Hotspot, security, none. Also I changed it to 5GHz instead of 2.4, reboot. On the laptop taskbar, wifi, rightclick that connection, forget. Turn wife off, turn it on again (from taskbar, not devmgr). It finds the hotspot it has the open shield, and connects to it.

But this is not secure, so on the phone I go to settings, hotspot, security, WPA2-personal, and type a password. On laptop I don't need to forget the network, I just connect to it, it asks for the password, I type it, and voila!

I don't yet know whether this survives a powercycle, reboot, etc. I just wanted to share with you that this worked for me. My handset is Pixel 3a XL, t-mobile; laptop is Macbook Pro vintage 2015, bootcamp, windows 10, updated yesterday.
marked this as an answer
Relevant Answer
Do not connected to any mobile WiFi and hosport to my puxal very silver phone 
Plllssss soul this my problem 
Thanks and regard 

Rajendra n solanki
marked this as an answer
Relevant Answer
Hi, can anyone confirm if what's the new static IP address of the hotspot server? Previously on Oreo's and below it's 192.168.43.1, but I feel like it's not the same already.
 
Thanks!
marked this as an answer
Relevant Answer
Same issue since android 10 can't even use my phone to hotspot at 5.0 GHz !! 2.4 just keeps disconnecting.
marked this as an answer
Relevant Answer
Same problem for the 1st Generation Pixel. Hope somebody would fix this bug ASAP....
marked this as an answer
Relevant Answer
Same issue on a Pixel (1st gen) - ONLY did reset of Wifi, Bluetooth and Mobile Network under settings, system, advanced, Reset Options and that had it working again.  NEGATIVE on this is you lose ALL saved mobile network passwords
marked this as an answer
Relevant Answer
Hi Justin,
When you say this is the 'same across bluetooth', do you mean your bluetooth has also stopped functioning after upgrading to Android 10? So it seems as if the radio itself that supports bluetooth and WiFi are not working. Is this a correct understanding?
Thanks.
marked this as an answer
Relevant Answer
Mine can turn on the hotspot, but it didn't visible to other devices
marked this as an answer
Relevant Answer
When turning on usb tethering. It got black screen
marked this as an answer
Relevant Answer
My problem after the Android 10 update was that internet access through my phone via Bluetooth tethering was broken. Previous to the update, I had a device that would frequently use Bluetooth tethering with my phone in order to access the web (I use Tasker to turn on internet access in Settings for me, since Android doesn't normally keep that on after inactivity). After the update, it would still connect via Bluetooth, and Tasker still turned on the option in Settings, but the device couldn't reach the internet. For those technically-inclined, ping's and traceroute's would get responses from the gateway (the phone) but nothing further.

After trying the steps provided by Li Gardner, the connectivity issues were resolved. It was a bummer to have to re-add all my WiFi networks, but it was nice to get it to work.
marked this as an answer
Relevant Answer
Same here, plus using Huawei Mate 20 Pro, after updating to Android 10 there are 2 issues:
1- The wifi hotspot, its working but when connected to it there are No Internet through it.
2- The Bluetooth connectivity seems like its not stable, the connection keeps doping with my Galaxy watch.
Tried everything that I know to solve it without any luck.
marked this as an answer
Relevant Answer
Same here on Pixel 3 just purchased. Called AT&t; they reset my IMEI number, but no luck.
marked this as an answer
Relevant Answer
Hi everyone! I had the same issue with my OnePlus 6 after updating to Android 10. I fixed it by adding ",DUN" to "APN type" under the "Edit access point" tab. Hope this helps :)
marked this as an answer
Relevant Answer
factory reset did fix the issue for me (I wasted my time trying everything else before).

Worst of all, Samsung did download a new update without my consent and I was simply unable to reject it !

The problem came back immediately.

I will try to stay away from Samsung smartphones in the future, it seems like they are trying to push their broken tech very aggressively.

One UI version 2.5
Android version 10
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/pixelphone/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Removed from Updates
Marked as Recommended Answer
Marked as Update
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
Known Issue
Fixed
Marked Fixed
Unmarked Fixed
Unable to mark fixed
Unable to unmark fixed
/profile/0
false
Search
Clear search
Close search
Google apps
Main menu
Search Help Center
true
1634144
false