Notifikasi

Di pusat bantuan ini, Anda dapat menemukan konten untuk Merchant Center Next dan pengalaman Merchant Center klasik. Cari logo di bagian atas setiap artikel guna memastikan Anda menggunakan artikel untuk versi Merchant Center yang berlaku untuk Anda. 

Pemecahan Masalah Modul Keikutsertaan Survei

Ikon khusus untuk artikel Merchant Center Next

Artikel ini menjelaskan beberapa error umum yang mungkin Anda temui saat menerapkan modul keikutsertaan survei.

Pada halaman ini


Modul keikutsertaan tidak terlihat

Jika modul keikutsertaan tidak terlihat pada halaman konfirmasi pesanan Anda, carilah sumber masalah yang mungkin berikut:

Masalah

Diagnosis

Sumber kode HTML tidak berisi kode modul keikutsertaan

Lihat sumber HTML pada browser Anda dan pastikan hanya ada satu instance dari blok kode modul keikutsertaan yang muncul di halaman.

Posisi modul keikutsertaan berada di luar area layar atau terhalang oleh elemen lain

Modul mungkin di-render di luar area yang dapat dilihat. Coba scroll.

Browser Anda tidak didukung

Browser Anda harus mendukung HTML 5. Update browser Anda ke versi terbaru.

Integrasi platform e-commerce

Beberapa platform e-commerce mungkin memiliki masalah kompatibilitas. Hubungi penyedia e-commerce Anda untuk memahami opsi penerapan.

Halaman konfirmasi berada di domain berbeda

Jika proses checkout Anda menggunakan pemroses pihak ketiga, pemroses tersebut harus mengalihkan kembali ke halaman konfirmasi di domain Anda.

Kode modul keikutsertaan ditambahkan ke Google Tag Manager

Google Tag Manager saat ini tidak dapat digunakan untuk integrasi kode keikutsertaan.


Terjadi error JavaScript di halaman

Tabel berikut berisi sumber masalah umum pada modul keikutsertaan JavaScript:

Masalah

Diagnosis

Nilai placeholder

Ganti placeholder dengan nilai dinamis khusus situs Anda.

Parameter yang diperlukan tidak ada

Ketika menerapkan kode modul keikutsertaan, parameter berikut wajib ada:

  • merchant_id
  • order_id
  • email
  • delivery_country
  • estimated_delivery_date

DOCTYPE harus HTML 5

Pastikan halaman konfirmasi pesanan Anda menggunakan HTML5 DOCTYPE:

<!DOCTYPE html>

estimated_delivery_date tidak valid

Tanggal harus dalam format YYYY-MM-DD, di mana YYYY adalah tahun dengan 4 digit, MM adalah bulan dengan 2 digit, dan DD adalah hari dengan 2 digit. Nilai harus berupa string dan harus diapit oleh tanda kutip. Misalnya, "2016-09-13".

opt_in_style tidak valid

Nilai parameter opt_in_style dapat diisi dengan salah satu string berikut:

  • "CENTER_DIALOG"
  • "BOTTOM_RIGHT_DIALOG"
  • "BOTTOM_LEFT_DIALOG"
  • "TOP_RIGHT_DIALOG"
  • "TOP_LEFT_DIALOG"
  • "BOTTOM_TRAY"

Situs tidak menggunakan HTTPS

Semua halaman konfirmasi harus menggunakan HTTPS.

URL situs tidak cocok

Kode modul keikutsertaan harus diterapkan pada URL situs yang sama dengan URL yang diverifikasi dan diklaim di Merchant Center. Masalah ini biasanya menghasilkan kode error 404 JavaScript.


Survei tidak diterima

Masalah

Diagnosis

Alamat email salah

Pastikan Anda memasukkan alamat email dalam format yang benar ke dalam modul. Jika tidak, email survei tidak akan dikirim dengan benar.

Kode negara salah

Pastikan Anda memasukkan kode negara yang benar ke dalam modul keikutsertaan. Nilai ini harus dalam format ISO 3166-1 alpha-2. Jika Anda memasukkan kode negara yang salah, error tidak akan terjadi, tetapi survei tidak akan dikirim.

Waktu yang terlewat tidak cukup

Pastikan tanggal ESTIMATED_DELIVERY_DATE untuk pesanan sudah lewat. Pelanggan yang ikut serta dalam survei menerima email yang meminta mereka menilai pengalamannya dalam waktu beberapa hari setelah estimasi tanggal pengiriman yang Anda cantumkan untuk pesanan tersebut dalam modul keikutsertaan survei.

Selain itu, informasi yang ditampilkan dalam grafik Merchant Center dapat tertunda hingga satu minggu.

Apakah ini membantu?

Bagaimana cara meningkatkannya?
Telusuri
Hapus penelusuran
Tutup penelusuran
Menu utama
5343731216049773605
true
Pusat Bantuan Penelusuran
true
true
true
true
true
71525
false
false