/maps/community?hl=en
/maps/community?hl=en
4/27/10
Original Poster
tymchn

Google Navigation stuck at Searching for GPS... Samsung GT i5700

Always include:

Device:
Carrier:
Country / Language:
OS / Browser / build number (if applicable):

2010-04-27
Samsung GT i5700 O2 UK English, UK Eclair I understand Motorola Droid/Milestone users have had a similar problem, but has anyone experienced this on the Samsung i5700?

2010-04-27
I picked it up on 3 UK PAYG just recently with the I570EXXJC1 baseband and 2.1-update1 firmware preinstalled. There is very little branding from 3 so I'm not sure if that's the problem. I have tried the usual hard reset to wipe all installed apps off, and combinations of resets with and without removing the battery to no avail. I have tried with the original version of maps and updating from the Market.

2010-04-27
It does not appear to be a hardware problem as maps and GPS Status happily get a lock (as many as 10 satellites at a time). For some reason it is only the navigation function that struggles. Although ironically it does update the screen with my position and the marked route turns from red to blue... all while searching for GPS :P The only indicator missing is on the top status bar, the arrow icon remains gray. I have tried this inside and outside, at home and at work.
Community content may not be verified or up-to-date. Learn more.
Recommended Answer
Was this answer helpful?
How can we improve it?
All Replies (119)
Jay H. Lee
4/27/10
Jay H. Lee
Hi tymchn,

  Are you outside? Do you have a data connection so that the phone can use aGPS to acquire a GPS satellite lock quicker? Have you tried on a clear day (clouds can sometimes interfere with GPS signal strenght) How long have you waited for a GPS signal?

Jay
Wilderbeast
4/27/10
Wilderbeast
I have the same phone on 3 network, and have the same problem
I take it that firmare 2.1 is the android O/S version.
You name it I have tried it , but I cannot get rid of the "searching for GPS"
Russthegreat
4/27/10
Russthegreat
I have the same issue on a Samsung GT-I5700 running I570EXXJC1.

The map seems to follow the route OK.
jt-adrian
4/29/10
jt-adrian
I have the same problem with i570EXXJD1, map follows the route etc & other GPS applications have no problem acquiring location - Google Maps, MyTracks etc.

Leaving the phone outside on a clear day for 3 hours did no good. Similarly on the dashboard for 1.5hrs though granted whilst moving. jlee, yes have a data connection, have also tried turning off get location using wireless networks.

Adrian
jt-adrian
5/4/10
jt-adrian
No change with I5700XXJD4, with only Google Maps update installed.
113 MORE
otto__
11/10/10
otto__
I have the same phone with android 2.1 and the same problem: can't get location based on gps, not even with google maps. After system reset gps works for a few hours then it stopps. After uninstalling advanced task killer the gps worked for about 2 hours.
GOOGLE, PLEASE FIX PROBLEM
 
This question is locked and replying has been disabled. Still have questions? Ask the Help Community.

Badges

Some community members might have badges that indicate their identity or level of participation in a community.

 
Expert - Google Employee — Googler guides and community managers
 
Expert - Community Specialist — Google partners who share their expertise
 
Expert - Gold — Trusted members who are knowledgeable and active contributors
 
Expert - Platinum — Seasoned members who contribute beyond providing help through mentoring, creating content, and more
 
Expert - Alumni — Past members who are no longer active, but were previously recognized for their helpfulness
 
Expert - Silver — New members who are developing their product knowledge
Community content may not be verified or up-to-date. Learn more.

Levels

Member levels indicate a user's level of participation in a forum. The greater the participation, the higher the level. Everyone starts at level 1 and can rise to level 10. These activities can increase your level in a forum:

  • Post an answer.
  • Having your answer selected as the best answer.
  • Having your post rated as helpful.
  • Vote up a post.
  • Correctly mark a topic or post as abuse.

Having a post marked and removed as abuse will slow a user's advance in levels.

View profile in forum?

To view this member's profile, you need to leave the current Help page.

Report abuse in forum?

This comment originated in the Google Product Forum. To report abuse, you need to leave the current Help page.

Reply in forum?

This comment originated in the Google Product Forum. To reply, you need to leave the current Help page.