Requisitos del nivel de API de destino para aplicaciones de Google Play

A partir del 1 de noviembre del 2022, si tu aplicación no está orientada al nivel 30 de la API o a uno posterior, los usuarios nuevos que tengan versiones más recientes del SO Android no la podrán encontrar ni descargar en Google Play. Puedes solicitar una prórroga si necesitas más tiempo para actualizar la aplicación. Consulta los mensajes de la bandeja de entrada de Play Console para ver los enlaces a cada uno de los formularios de prórroga de tu aplicación.

Cada nueva versión de Android introduce cambios que mejoran la experiencia de usuario, la seguridad y el rendimiento en general de la plataforma Android. Cada aplicación especifica una targetSdkVersion (también denominada "nivel de API de destino") en el archivo de manifiesto. El nivel de API de destino indica cómo se tiene que ejecutar tu aplicación en las diferentes versiones de Android.

Si orientas tu aplicación a un nivel reciente de API, los usuarios se beneficiarán de mejoras de seguridad, privacidad y rendimiento. Esto no impide que tu aplicación se ejecute en versiones anteriores de Android (desde la minSdkVersion especificada).

Para ofrecer a los usuarios de Android y Google Play una experiencia segura, Google Play requiere que todas las aplicaciones cumplan los requisitos del nivel de API de destino que se indican más abajo.

Definiciones

Aplicación nueva Aplicación que aún no se ha publicado en Google Play (es decir, una aplicación nueva).
Aplicación disponible Aplicación que está publicada en Google Play.
Actualización de la aplicación Una nueva versión que vas a enviar a revisión para reemplazar la aplicación disponible.
 

Requisitos de actualización de la aplicación

Versión del SO Android (nivel de API)

¿Cuándo se requiere que los envíos de aplicaciones se orienten a este nivel de API?
Aplicación nueva Actualización de la aplicación*

Android 13 (nivel 33 de la API)

1 de agosto del 2023

1 de noviembre del 2023

Android 12 (nivel 31 de la API)

1 de agosto del 2022

1 de noviembre del 2022

* Con la finalidad de facilitar la transición a los desarrolladores, les damos más tiempo para actualizar sus aplicaciones disponibles.

Nota: Si necesitas ayuda técnica sobre cómo cambiar el nivel de API de destino de tu aplicación para cumplir estos requisitos, consulta la guía de migración.

Requisitos de las aplicaciones para Wear OS

Versión del SO Android

¿Cuándo se requiere que las aplicaciones para Wear OS estén orientadas a este nivel de API?
Aplicación nueva Actualizaciones de la aplicación*

Android 11 (nivel 30 de la API)

1 de agosto del 2022

1 de noviembre del 2022

* Con la finalidad de facilitar la transición a los desarrolladores, les damos más tiempo para actualizar sus aplicaciones disponibles.

 

Requisitos de descubribilidad de las aplicaciones

Las aplicaciones disponibles deben orientarse al nivel 30 de la API o uno posterior no más tarde del 1 de noviembre del 2022. De lo contrario, dejarán de ser descubribles para todos los usuarios de Google Play cuyos dispositivos tengan versiones del SO Android más recientes que el nivel de API de destino de las aplicaciones, ya que, en ese caso, las aplicaciones no cumplirán el estándar de seguridad y calidad que los usuarios esperan de las versiones más recientes del SO Android. 

Si necesitas más tiempo para actualizar tu aplicación y orientarla al nivel 31 de la API o a uno posterior, puedes pedir una prórroga para que todos los usuarios de Google Play puedan verla hasta el 1 de mayo del 2023. Consulta los mensajes de la bandeja de entrada de Play Console para ver los enlaces a cada uno de los formularios de prórroga de tu aplicación.

Nota: Las aplicaciones para Wear OS están exentas de cumplir los requisitos de descubribilidad.

Qué hacer para cumplir los requisitos 

Aplicaciones nuevas

Al publicar una nueva aplicación, debes orientarla al nivel 31 de la API o uno posterior.

Aplicaciones disponibles

Si tu aplicación disponible se orienta al nivel 30 de la API o uno posterior, cumple la política. 

Si tu aplicación se orienta a un nivel de la API inferior a 30, dejará de ser descubrible para todos los usuarios de Google Play cuyos dispositivos tengan versiones del SO Android más recientes que el nivel de API de destino de tu aplicación, ya que, en ese caso, la aplicación no cumplirá el estándar de seguridad y calidad que los usuarios esperan de las versiones más recientes del SO Android. 

  • Si tienes previsto actualizar la aplicación y orientarla al nivel 31 de la API o uno posterior, puedes solicitar una prórroga para que se siga distribuyendo a todos los usuarios de Google Play hasta el 1 de mayo del 2023. Los desarrolladores cuyas aplicaciones se vean afectadas recibirán un mensaje en la bandeja de entrada de Play Console con un enlace al formulario de solicitud de prórroga.

Al actualizar la aplicación, debes orientarla al nivel 31 de la API o uno posterior.

  • Si quieres enviar una actualización de la aplicación, pero necesitas más tiempo para orientarla al nivel 31 de la API o uno posterior, puedes solicitar una excepción hasta el 1 de diciembre del 2022 a través de nuestro formulario de asistencia. Después de esa fecha, ya no podrás enviar actualizaciones de la aplicación que estén orientadas a niveles de API anteriores.

Preguntas frecuentes

Todas las aplicaciones

¿Puedo enviar una aplicación que no esté orientada al nivel 31 de la API o uno posterior después del 1 de noviembre del 2022? Si no, ¿cómo se solicita una excepción temporal?

Después del 1 de noviembre del 2022, nuestra política exigirá que los envíos de aplicaciones se orienten al nivel 31 de la API o uno posterior. Si quieres enviar una actualización de la aplicación, pero necesitas más tiempo para orientarla al nivel 31 de la API o uno posterior, puedes solicitar una excepción hasta el 1 de diciembre del 2022 a través de nuestro formulario de asistencia. Después de esa fecha, ya no podrás enviar actualizaciones de la aplicación que estén orientadas a niveles de API anteriores.

Aplicaciones orientadas al nivel 29 de la API o uno anterior

Tengo una aplicación publicada en Google Play Store orientada al nivel 29 de la API o uno anterior y no tengo previsto actualizarla. ¿Qué opciones tengo?

Si quieres seguir ofreciendo esta aplicación a los usuarios actuales, no tienes que hacer nada. Sin embargo, la distribución de tu aplicación se reducirá a partir del 1 de noviembre, ya que se orienta a un nivel de API más antiguo. Solo estará disponible para dispositivos con el nivel 29 de la API o uno anterior. 

Si quieres que todos los usuarios de Google Play puedan ver tu aplicación, tendrás que actualizarla a un nivel de la API más reciente. Puedes actualizarla en cualquier momento. Si tienes previsto actualizar tu aplicación a una API de destino más reciente y necesitas más tiempo, puedes solicitar una prórroga para que se siga distribuyendo a todos los usuarios de Google Play hasta el 1 de mayo del 2023. Tu aplicación debe cumplir el requisito del nivel de API de destino no más tarde del 1 de mayo del 2023. De lo contrario, dejará de ser descubrible para todos los usuarios de Google Play cuyos dispositivos tengan versiones del SO Android más recientes que el nivel de la API de destino de tu aplicación.

Si quieres que tu aplicación deje de distribuirse entre los usuarios nuevos, aunque tengan dispositivos antiguos, puedes anular la publicación de tu aplicación.

¿Dónde está el formulario de prórroga para que mi aplicación se siga distribuyendo entre todos los usuarios de Google Play hasta el 1 de mayo del 2023?

Los desarrolladores cuyas aplicaciones no cumplan la política serán los únicos que reciban un mensaje en la bandeja de entrada de Play Console con un formulario de prórroga. El asunto del mensaje será "Cambios en la política de nivel de API de destino que afectarán a la disponibilidad de tu aplicación en Google Play a partir del 1 de noviembre del 2022".

Tengo aplicaciones que no quiero que sigan publicadas en Google Play. ¿Qué puedo hacer? 

Consulta este artículo del Centro de Ayuda para obtener instrucciones sobre cómo dejar de publicar tu aplicación. 

¿Se verán afectados los usuarios que ya hayan descargado mi aplicación anteriormente? 

Los usuarios que hayan descargado previamente la aplicación desde Google Play no se verán afectados y podrán seguir encontrándola, descargándola y usándola en cualquier versión del SO Android compatible con tu aplicación.

¿Este cambio afectará a las descargas de aplicaciones?  

Es posible que afecte a los niveles de descarga de tu aplicación si los usuarios nuevos que utilizan dispositivos con versiones más recientes del SO Android no pueden encontrarla ni descargarla desde Google Play.

¿Qué ocurrirá si un usuario que tiene un dispositivo con una versión más reciente abre un enlace profundo a la página de la tienda de aplicaciones, pero la aplicación se orienta al nivel 29 de la API o uno anterior?

Google Play informará al usuario de que no puede descargar la aplicación en su dispositivo. 
¿Te ha resultado útil esta información?
¿Cómo podemos mejorar esta página?

¿Necesitas más ayuda?

Inicia sesión si quieres ver otras opciones de asistencia para solucionar tu problema.

Búsqueda
Borrar búsqueda
Cerrar búsqueda
Aplicaciones de Google
Menú principal
Buscar en el Centro de ayuda
false
false
true
92637
false
false