Usar un SDK de terceros en una aplicación

Una vez integrados en tu aplicación, los SDK de terceros pueden influir de forma significativa en la compatibilidad, el rendimiento, la protección, la seguridad y la calidad de la aplicación.

Cambios relacionados con los SDK de terceros

Para ayudarte a garantizar que cualquier software de terceros que utilice tu aplicación cumpla las Políticas del Programa para Desarrolladores de Google Play y mejore la experiencia de usuario, Google Play empezará a señalar los problemas conocidos de SDKs populares en Play Console.

Para averiguar qué SDK utiliza tu aplicación, usamos el archivo de dependencias incluido en ella. Este archivo contiene una lista de todas las bibliotecas con versión de las que depende la aplicación. Las aplicaciones que usan el Android App Bundle proporcionan el archivo de dependencias de forma predeterminada. Las aplicaciones creadas antes de agosto del 2021 publicadas con archivos APK incluyen el archivo de dependencias a partir de la versión 4.0 del complemento de Android para Gradle.

Información sobre problemas con el SDK de terceros de tu aplicación

Si procede, los problemas de las versiones del SDK que utiliza tu aplicación se detallan en Play Console, en la parte superior de la página Producción o en la página Información general de la versión.

Si tu aplicación usa una versión del SDK que pueda provocar que la aplicación incumpla las Políticas del Programa para Desarrolladores de Google Play, es posible que se rechacen las nuevas versiones de la aplicación que utilicen esa versión del SDK. En función del tipo de infracción, se te indicará que compruebes que el uso del SDK cumple nuestras políticas de datos de usuario, que cambies a otra versión recomendada por el proveedor del SDK o que elimines el SDK.

Si tu aplicación utiliza una versión del SDK obsoleta o que tenga problemas graves, recibirás una advertencia en la que se te podría solicitar que tomes medidas. Por ejemplo, si el proveedor del SDK nos informa de que la versión del SDK que utiliza tu aplicación está obsoleta, podrás publicar tu aplicación. Sin embargo, no podrás publicar otra versión de tu aplicación con una versión obsoleta del SDK, sino que tendrás que usar la versión actualizada del SDK. Si el proveedor del SDK nos informa de que la versión del SDK que utiliza tu aplicación tiene problemas graves, verás una advertencia en la que se indicará el tipo de problema tal y como lo describa el proveedor del SDK.

Si tienes alguna pregunta sobre una versión del SDK obsoleta o que tenga problemas graves, te recomendamos que te pongas en contacto con el proveedor del SDK.

¿Te ha resultado útil esta información?
¿Cómo podemos mejorar esta página?

¿Necesitas más ayuda?

Inicia sesión si quieres ver otras opciones de asistencia para solucionar tu problema.

Búsqueda
Borrar búsqueda
Cerrar búsqueda
Aplicaciones de Google
Menú principal
Buscar en el Centro de ayuda
true
92637
false
false