Supported browsers and mobile systems

Supported browsers

Smart campaigns are supported in the current and prior major release of Chrome, Firefox, Internet Explorer and Safari. Download the latest version of one of the browsers below to access Smart campaigns:

If downloading the most recent browser from the list above doesn't fix your problem, you may also need to update your browser preferences to allow cookies and JavaScript.

Smart campaigns aren't tested on Opera, so some features may not work correctly.

Supported mobile app systems

Was this helpful?
How can we improve it?

Need more help?

Sign in for additional support options to quickly solve your issue