Search
Clear search
Close search
Google apps
Main menu

In November, the Portfolio's feature in Google Finance will no longer be available. Learn more

System requirements for charts

To use Google Finance charts, you must have Adobe Flash Player 7.0+ installed (for best performance, though, we recommend using Flash Player 9 or higher). If you don't have Adobe Flash Player plug-in installed on your computer, you can download it from the Adobe website. Additionally, your system must meet the following requirements:

  • Microsoft Windows 2000 or higher: IE 6.0+, Firefox 1.0+, Opera 8.0+
  • Mac OS: Firefox 1.0+, Safari 2.0+
  • Linux: Firefox 1.0.4
Was this article helpful?
How can we improve it?