Use Google Slides and Drawings with a screen reader

Blind and visually impaired users can use Google Slides and Google Drawings with a screen reader. In this article, we'll cover how to do the following with your screen reader:

  • Navigate menus
  • Edit text
  • Edit shapes
  • Insert tables, lists, images, and drawings
  • Navigate the presentation editor
  • Share with others
  • Chat with collaborators in real-time

Get started

When you first open a Google drawing or presentation, your screen reader will read the document title and information about the layout on the slide or canvas as it’s loading. When loading completes, you’ll be viewing your drawing or presentation with the first slide in focus.

  • If you’re using ChromeVox, you don’t need to explicitly enable screen reader support.
  • If you’re using NVDA or VoiceOver, you can enable support for the screen reader by pressing the Alt + Shift + ~ keys.
  • If you’re using JAWS, you'll need to perform the following configuration steps after opening a document:
    • Set key echoing to no echoing.
    • Set the Virtual Cursor to off.
    • Disable both "Auto Forms Mode" and "Forms Mode Off when New Page Loads."
    • Once you're finished and the focus has returned to the slide, press Alt + Shift + ~ to enable screen reader support. You should now hear the slide being spoken to you.

Keyboard shortcuts and help overlay

  • To bring up the keyboard shortcut help overlay, press Ctrl + /. The screen reader will read the shortcuts to you.
  • To explore specific shortcuts within a section, press Ctrl + Alt + Up (Ctrl + Cmd + Up on Mac) and Ctrl + Alt + Down (Ctrl + Cmd + Down on Mac).
  • To advance to the next shortcut heading with ChromeVox, press Ctrl + Alt + N + H (Ctrl + Cmd + N + H on Mac).
  • To move to the previous heading with ChromeVox, press Ctrl + Alt + P + H (Ctrl + Cmd + P + H on Mac).
  • To dismiss the help overlay, press Escape.

Mac users: Ctrl with the Command key (⌘ or 'Apple' key) and Alt with the Option key, except where listed otherwise.

See the full list of drawings or presentations keyboard shortcuts.

Navigate menus

To activate the application menus, press Alt + Shift + F. This will activate the File menu. Use the right and left arrows to navigate to other top-level application menus, including Edit, View, Insert, Format, Arrange, Table, and Help.

Once you locate the application menu you want to explore, use the up and down arrow keys to read the menu items. If you’ve landed on a menu item with a sub-menu, you can enter the sub-menu with the right arrow. Press Enter to select a menu item. After you select a menu item, you'll no longer hear spoken feedback from your screen reader.

Pressing the Escape key when a menu is expanded will close the menu bar. Pressing Escape again will remove focus from the menu bar and return you to the top-level toolbar, allowing you to navigate to different Google applications and your Google Docs “Options” menu. Pressing Escape here location will take you back to the main document area.

You’ll hear spoken feedback for any action you take to help you figure out which menu or menu item you’ve selected.

Edit text

When you type a selection into a text box, you’ll hear spoken feedback for the characters as you type them. For example, if you press the A key, you’ll hear A. When you delete characters, you’ll hear spoken feedback about the character you’ve deleted. For example, if you delete the letter A from a word, you’ll hear A. If you delete a selection, you’ll hear “section deleted.”

To select text, hold the Shift key and use the right and left arrows. You can press Shift + Ctrl + Left arrow to select to the beginning of the line. When you select text, you’ll hear the text of the selection, followed by “selection.” For example, when you select the sentence, “The brown spotted dog ran across the yard,” you’ll hear “The brown spotted dog ran across the yard. Selected.”

Copy and paste

You can use the keyboard shortcuts Ctrl + C to copy a selection and Ctrl + X to cut a selection. When you locate where you’d like to paste your selection, use the keyboard shortcut Ctrl + V to paste the selection. You will hear voice feedback when you successfully paste your selection.

Check spelling

You can use the keyboard shortcuts Ctrl + ; (next) and Ctrl + [ (previous) to navigate any misspellings in the drawing or presentation text. You’ll hear the misspelled word when you trigger this shortcut.

Format text

  • Fonts: Go to the application menu by pressing Alt + F (Ctrl + Option + F on Mac) and tab to the toolbar. Use the left and right arrows to move to different tools in the toolbar. When you reach the fonts menu, press the down arrow key to open the drop-down menu. Press Enter to apply the font to selected text, or to start typing with that font. You’ll hear “font” followed by the name of that font.
  • Font size: Go to the application menu by pressing Alt + F (Ctrl + Option + F on Mac) and tab to the toolbar. Use the left and right arrows to move to different tools in the toolbar. When you reach the font size menu, press the down arrow to open the drop-down menu. Press Enter to apply the font size to selected text, or to start typing with that font size. You’ll hear the font size followed by “points.”
  • Bold: Press Ctrl +B to apply bold formatting. You’ll hear “bold” in combination with “unchecked” or ”checked.”
  • Italic: Press Ctrl + I to apply italic formatting. You’ll hear “italic” in combination with “unchecked” or ”checked.”
  • Underline: Press Ctrl + U to apply underline formatting. You’ll hear “underline” in combination with “unchecked” or ”checked.”

Edit shapes

To insert a shape into your drawing or presentation, go to the application menu and go to the Insert menu. Use the down arrow to select Shapes, and the right arrow to choose between different types of shapes. You’ll hear the shape you’ve selected and can click Enter to insert it into your presentation.

When you have a shape selected on your canvas, press Tab to select the next shape, or Shift + Tab to select the previous shape. To duplicate a shape, select Ctrl +D. You can use the arrow keys to move and nudge a selected shape, and you will hear spoken feedback for these actions. Use arrows on a selected shape to move it pointwise, and use Shift + arrows to nudge the shape. The screen reader will also read the fill and line color of shapes in your document. To add text to a shape, press Enter, and to remove focus from the shape and return to the slide, press Escape.

Insert tables, lists, images, and drawings

Insert, edit, or delete a table

To insert a table into your drawing or presentation, go to the application menu by pressing Alt + F (Ctrl + Option + F on Mac) and press the right arrow until you get to the Table menu. Press the down arrow until you reach the “Insert table” menu item, and press the right arrow to open the sub-menu. Press the arrows to find the dimensions of the table you want to insert. You’ll hear “number of rows x number of columns.” If you press Enter, you’ll hear “number of rows by number of columns” followed by “table inserted.”

To edit your table, make sure that the table is in focus and that your cursor is in a cell. To do this, press Tab to move focus into the table, and press Enter to have focus in a cell. To insert a column or row into a table, use the same keyboard shortcuts to navigate to the Table menu. Then, select from the following options:

  • Insert row above
  • Insert row below
  • Insert column left
  • Insert column right

When you press Enter to select an option, you’ll hear “column inserted” or “row inserted.” To delete a column or row, follow the same instructions. Menu options will read “delete” instead of “insert.” When you select an option from the Table menu, you’ll hear “column deleted” or “row deleted.”

To delete a table, locate a cell in the table. Then, press Ctrl + Shift + \ to activate the context menu, and select “Delete table” from the menu. Alternatively, you can select “Delete table” from the Table application menu. You’ll hear “table deleted” when you complete this action.

Insert or delete numbered and bulleted lists

Using the keyboard shortcut Ctrl + Shift + 7 will create a new numbered list, and Ctrl + Shift + 8 will create a new bulleted list. When you create a list or insert a list item, you’ll hear the glyph type (bullet, arrow, etc.) and number that you just inserted. When you delete a list item, you’ll hear “bullet removed.” When you delete a full list, you’ll hear “section deleted.”

Insert or delete images or drawings

You can use Ctrl + Alt + I (Ctrl + Option + I on Mac) to open the Insert menu and use the down arrow to select Image. Options in the image insert dialog box will be spoken, and you can navigate these options with arrow keys and tabs. To delete an image in your slide or drawing, select the image and press Delete. You will hear “selection deleted.”

Navigate the presentation editor

By default, focus will remain within the slide or canvas when you are editing a presentation, however when you choose to access revision history, animations, speaker notes, or jump to the film strip, you will be taken to a different pane within the presentation editor. Your screen reader will help you navigate each of these panes. To exit a pane and return to the canvas, press Ctrl + Alt + C (Ctrl + Cmd + C on Mac)

Film Strip

To the left of your canvas, there is a film strip which shows your slides. To move focus to the film strip, click Ctrl + Alt + F (Ctrl + Cmd + F on Mac). Once you are in the film strip, you can navigate your slides using the up and down arrows.

You can also change the order of your slides by moving them up or down in the film strip. Select a slide and use Ctrl + Up or Ctrl + Down to move it up or down in the presentation. Hold down the Shift key to select multiple slides and use Ctrl + the arrows to move multiple slides up or down in the presentation.

Animations pane

To add animations to a slide, activate the animations pane by clicking Ctrl + Alt + B (Ctrl + Cmd + B on Mac). Here your screen reader will read through options to add animations to shapes and objects, or to add transitions to your slides.

Speaker Notes panel

To add speaker notes to your presentation, click Ctrl + Alt + S (Ctrl + Cmd + S on Mac) to jump to the speaker notes panel. Here you can enter your notes hear feedback as you add content. .

Revision History

To access your revision history, click Ctrl + Alt + G (Ctrl + Cmd + G on Mac). This will open the revision history pane, where you can use the up and down arrow to navigate your revisions. Your screen reader will read the timestamps of each revision. To choose a revision and revert to that version of your drawing or presentation, press Enter.

Share with others

To share a drawing or presentation, activate the application menu with the keyboard shortcut Alt + Shift + F. Select the "Share" menu item, and press Enter. You'll be placed in the sharing dialog, where you can tab through the elements to see who the collaborators are, change their access levels and visibility options, and add more collaborators. When you're finished, press the Share & save button.

Chat with collaborators in real-time

If you're working with collaborators in your drawing or presentation, you can press Shift + Esc to enter the chat pane to chat with them in real time.