Use Google Docs with a screen reader

Before you can use a screen reader with Google Docs, you’ll first need to configure your screen reader. Here’s how to do that for the four screen readers that Google Docs supports — JAWS, NVDA, ChromeVox, and VoiceOver.

JAWS

Before using JAWS with Google Docs, you’ll need to change a few of its settings. To do that, you need to interact with JAWS via keyboard commands, most of which involve pressing the “JAWS” key and then some other combination of keys. By default, the JAWS key is your keyboard’s “Insert” key. When performing the following configuration steps, make sure you can hear audio from your computer.

  1. Set key echoing to no echoing — press JAWS + 2 until you hear “None.”
  2. Set the Virtual Cursor to off — press JAWS + Z until you hear “Use virtual PC cursor off.” Then press JAWS + Z + Z until you hear “the virtual cursor will be turned off for all applications.”
  3. Disable both "Auto Forms Mode" and "Forms Mode Off when New Page Loads" — Ensure that the screen reader’s focus is on the top toolbar, and then press JAWS + V. In the settings window that opens, search for “Forms Options” and uncheck both “Auto Forms Mode” and “Forms Mode Off when New Page Loads.” Then press OK.
    If you’re using Firefox, you will need to tab through from the address bar through the Docs toolbar controls until you hear application mode announced. At that point, you can hit “Escape” to return to the content of your Google document and activate screen reader support.
  4. Once you're finished and the screen reader’s focus has returned to the document, press Ctrl + Alt + Z on a PC to enable screen reader support. You should now hear the document being spoken to you.
Because Google Docs isn’t a typical website, some JAWS navigation shortcuts will not work. Use Docs-specific shortcuts instead when editing the contents of a document.

NVDA

Before using NVDA with Google Docs, you’ll need to change a few of its settings. To do that, you need to interact with NVDA via keyboard commands, most of which involve pressing the “NVDA” key and then some other combination of keys. By default, NVDA will allow you to use the “Caps Lock” or “Insert” key as the NVDA key.

  1. Press NVDA + Ctrl + K to bring up the Keyboard Settings window, then disable “Speak typed characters” and “Speak typed words.”
  2. Open a document.
  3. Enable screen reader support by pressing Ctrl + Alt + Z on a PC. You should hear “Screen reader support enabled.”
Because Google Docs isn’t a typical website, some NVDA navigation shortcuts will not work. Use Docs-specific shortcuts instead when editing the contents of a document.

ChromeVox

Before using ChromeVox with Google Docs, you won’t need to change any of its settings, but it might be a good idea to check out the ChromeVox user guide so that you understand the basics.

As with other screen readers, you interact with ChromeVox via keyboard commands, including a special “ChromeVox key”:

  • On Windows, the ChromeVox key is Control + Alt.
  • On a Mac, the ChromeVox key is ⌘ + Ctrl.
  • On Chrome OS, the ChromeVox key is Search + Shift.

You may also want to check out ChromeVox’s full list of shortcuts.

Because Google Docs isn’t a typical website, some ChromeVox navigation shortcuts will not work. Use Docs-specific shortcuts instead when editing the contents of a document.

VoiceOver with Chrome

If you’d like to use Apple’s VoiceOver screen reader with Google Docs, use Google Chrome as your browser. Chrome performs better with VoiceOver than Safari and Firefox do.

To configure VoiceOver, follow these steps:

  1. Open a document.
  2. Once you’ve enabled "Automatically speak the webpage" in VoiceOver, VoiceOver will begin reading the page. Hit Escape to return the screen reader’s focus to the document’s editable area.
  3. Hit Ctrl + Option + Shift + Down Arrow to interact with the editable text. If the screen reader’s focus ever shifts away from the editable document text (if, for example, a dialog window appears), redo this step to return the focus to the document text.
  4. Enable screen reader support by using the ⌘ + Option + Z shortcut. You should then hear “Screen reader support enabled.”

VoiceOver shortcuts conflict with Google Docs application menu shortcuts. To navigate to the application menus, first use the pass-through key combination Ctrl + Opt + Tab, then type the menu shortcut, such as Ctrl + Option + F for the File menu.

Also, because Google Docs isn't a typical website, some VoiceOver navigation shortcuts don't work when editing the contents of a document. Use Docs-specific shortcuts instead when editing the contents of a document.

Keyboard shortcut help overlay

If you ever forget a key combination, simply press Ctrl + / to bring up the keyboard shortcut help overlay. The screen reader will read the shortcuts to you. If you’re using ChromeVox you can move between shortcut headings by pressing Ctrl + Alt + N + H to move to the next heading or Ctrl + Alt + P + H to move to the previous heading. To explore the specific shortcuts in a section, press Ctrl + Alt + Up arrow and Ctrl + Alt + Down arrow. Pressing Escape will dismiss the help overlay.

These instructions are written with keyboard instructions for PC users. If you're working on a Mac, use the Command (Apple) key wherever the Control key is listed.

You can also visit the full list of documents keyboard shortcuts.

Navigate the menus

Application menus

The application menus offer the greatest variety of commands and is worth exploring carefully.

To activate the application menu, press Alt + Shift + F. This will specifically activate the File menu at the top of the application. Use the right arrow key to navigate to other top-level application menus, including Edit, View, Insert, Format, Tools, Table, and Help.

Once you locate the application menu you want to explore, use the up and down arrow keys to read the menu items. If you’re over a menu item with a sub-menu, you can enter the sub-menu with the right arrow key. Press Enter to select a menu item and execute a command.

Pressing the Escape key when a menu is expanded will close the menu bar. Pressing Escape again will get your focus out of the menu bar and into the top-level bar that allows you to navigate to different Google applications and your Google Docs “Options” menu. Pressing Escape from this location will take you back to the main document area.

You’ll hear spoken feedback for any action you take to help you figure out which menu or menu item you’ve selected.

Context menu

To activate the context menu in a document, you can use the context menu key on your keyboard if you have one or press Ctrl + Shift + X. Once the context menu is active, you’ll hear the menu items spoken to you as you move up and down the menu using the arrow keys. The items available on the context menu differ depending on what you’ve selected. To select a menu item and execute a command, press Enter.

Edit text in a document

Text editing

When you type a selection into your document, you’ll hear spoken feedback for the characters as you type them. For example, if you press the “A” key, you’ll hear “A.”

When you delete characters, you’ll hear spoken feedback about the character you’ve deleted. For example, if you delete the letter “A” from a word, you’ll hear “A.” If you delete a selection, you’ll hear “section deleted.”

To select text, hold the Shift key and use the right and left arrow keys. You can press Shift + Ctrl + Left arrow to select the entire word to the left.

When you select text, you’ll hear the text of the selection, followed by “selection.” For example, when you select the sentence, “The brown spotted dog ran across the yard,” you’ll hear “The brown spotted dog ran across the yard. Selected.”

Copy and paste

You can use the keyboard shortcut Ctrl + C to copy a selection and Ctrl + X to cut a selection. When you locate where you’d like to paste your selection, use the keyboard shortcut Ctrl + V to paste the selection. You won't hear any voice feedback for these actions.

Spell check

You can use the keyboard shortcut Ctrl + ' to navigate to the next misspelling in the document and Ctrl + ; to navigate to the previous misspelling. You’ll hear the misspelled word when you trigger this shortcut. To correct the misspelling, open the context menu by pressing Ctrl +Shift+ \. From the context menu, select the correctly spelled suggestion, and press Enter.

Format text in a document

Applying headings and paragraph styles

Enter the application menu by pressing Alt + Shift + F and locate the “Format” menu with the right arrow key. Select “Paragraph Styles” from the menu, and navigate to the style you want to apply to your text with the arrow keys. When you have a style selected, you’ll hear the style name followed by “checked" or "unchecked" to indicate when you've changed a style setting. Press Enter to apply that style. You’ll hear the style name.

Applying text styles

  • Fonts

    Enter the application menu by pressing Alt + Shift + F and tab to the toolbar. Use the left and right arrow keys to move to different tools in the toolbar. When you reach the fonts menu, press the down arrow key to open the drop-down menu. Press Enter to apply the font to selected text, or to start typing with that font. You’ll hear “font” followed by the name of that font.

  • Font size

    Enter the application menu by pressing Alt + Shift + F and tab to the toolbar. Use the left and right arrow keys to move to different tools in the toolbar. When you reach the font size menu, press the down arrow key to open the drop-down menu. Press Enter to apply the font size to selected text, or to start typing with that font size. You’ll hear the font size followed by “points.”

  • Bold

    Press Ctrl +B to apply bold formatting. You’ll hear “bold” in combination with “unchecked” or ”checked.”

  • Italic

    Use Ctrl + I to apply italic formatting. You’ll hear “italic” in combination with “unchecked” or ”checked.”

  • Underline

    Use Ctrl + U to apply underline formatting. You’ll hear “underline” in combination with “unchecked” or ”checked.”

Insert tables, lists, images, and drawings into your document

Insert, edit and delete a table

To insert a table into your document, enter the application menu by pressing Alt + Shift + F and press the right arrow until you get to the Table menu. Press the down arrow until you reach the “Insert table” menu item, and press the right arrow key to open the sub-menu. Press the arrow keys to find the dimensions of the table you want to insert. You’ll hear “number of rows x number of columns.” If you press Enter, you’ll hear “number of rows by number of columns” followed by “table inserted.”

To insert a column or row into a table, use the same keyboard shortcuts to navigate to the Table menu. Then, select from the following options:

  • Insert row above
  • Insert row below
  • Insert column left
  • Insert column right

When you press Enter to select an option, you’ll hear “column inserted” or “row inserted.” To delete a column or row, follow the same instructions. Menu options will read “delete” instead of “insert.” When you select an option from the Table menu, you’ll hear “column deleted” or “row deleted.”

To delete a table, locate a cell in the table. Then, press Ctrl + Shift + X to activate the context menu, and select “Delete table” from the menu. Alternatively, you can select “Delete table” from the Table application menu. You’ll hear “table deleted” when you complete this action.

Insert numbered and bulleted lists

Using the keyboard shortcut Ctrl + Shift+ 7 will create a new numbered list, and Ctrl +Shift + 8 will create a new bulleted list. When you create a list or insert a list item, you’ll hear the glyph type and number that you just inserted. When you delete a list item, you’ll hear “bullet removed.” When you delete a full list, you’ll hear “section deleted with X items.”

Insert images or drawings

At this time, it’s not possible to insert images or drawings into a document using a screen reader.

Page setup, paragraph formatting, and headers and footers

Set page orientation, paper size, and margins

Press Alt + Shift + F to activate the File menu, and press the down arrow key until you reach the “Page setup” option. Press Enter, then navigate through the different options for a form element with the Tab key. When you’re finished adjusting your page settings, locate the “OK” button and press Enter.

Set text alignment

The following keyboard shortcuts will help you set text alignment in your document:

  • Ctrl +Shift + L to set left alignment. You’ll hear “left aligned.”
  • Ctrl + Shift + E to set center alignment. You’ll hear “center aligned.”
  • Ctrl + Shift + R to set right alignment. You’ll hear “right aligned.”
  • Ctrl + Shift + J to justify alignment. You’ll hear “justified.”

Paragraph spacing and indents

When you’re editing the text in the document, you can use the Tab key to indent text. To reverse an indent, press Shift + Tab. Here’s what you’ll hear when you indent a paragraph, list or list item:

  • For a paragraph indent, you’ll hear “paragraph indented” or “paragraph unindented.”
  • For a first line indent, you’ll hear “first line indented” or “first line unindented.”
  • For a single list item indent, you’ll hear “list item indented to level X.”
  • When multiple list items are indented, you’ll hear “List items indented” or “List items unindented.”
  • When a full list is indented, you’ll hear “list indented” or “list unindented.”

Insert and edit headers and footers

Use the following keyboard shortcuts to work with headers and footers:

  • Press Alt + Ctrl + O + H to open the header section. You’ll hear “header” followed by the header’s contents. Pressing Esc will take you back to the main document, and you’ll hear “entering document.”
  • Press Alt + Ctrl + O + F to open the footer section. You’ll hear “footer” followed by the footer’s contents. Pressing Esc will take you back to the main document, and you’ll hear “entering document.”

Insert and edit a footnote

Place your cursor where you’d like to insert a footnote in your document. Activate the application menu with the keyboard shortcut Alt + Shift + F. Use your right arrow key to navigate to the Insert menu, then use the down arrow key to locate the “Footnote” menu item. Press Enter to insert a footnote where your cursor is placed in the document. You’ll hear “footnote inserted” and your cursor will be placed in the footnote area. Press Esc from the footnote editing area will take you back to the main document area, and you’ll hear “entering document.”

To navigate into the footnote area to edit a footnote, first locate the footnote in your document. When your cursor is next to the footnote, press Alt+ Ctrl + E + F to enter the footnote editing area. You’ll hear “footnote” followed by the footnote number and its contents. Press Esc to go back to the main document area. You’ll hear “entering document.”

Share a document with someone

To share a document, activate the application menu with the keyboard shortcut Alt + Shift + F. Select the "Share" menu item, and press Enter. You'll be placed in the sharing dialog, where you can tab through the elements to see who the collaborators are, change their permissions, and add more collaborators. When you're finished, press the "Share & save" button.

Chat with collaborators in real-time

If you're working with collaborators in your document, you can press Shift + Esc to enter the chat pane to chat with them in real time.