See the history of changes made to a file

If you want to see all of the changes you and others have made to a document, spreadsheet, presentation, or drawing, you can check the revision history. You can view and revert to earlier versions of the file and see which person made specific edits.

See revision history for a file

  1. Open a document, spreadsheet, presentation, or drawing.
  2. Click the File menu > See revision history.
  3. Click a timestamp in the panel on the right to see a previous version of the file. You'll also see the people who edited the file below the timestamp, and the edits that each person made are shown in the color that appears next to their name.
  4. In the top right, use the arrows to scroll through the list of changes.
    • Note: Text that has been added will be highlighted in a different color. Text that has been deleted will be shown with a strikethrough.
  5. To revert to the version you're currently viewing, click Restore this revision.
  6. To return to the current version of your document, click the X in the upper right corner of the "Revision history" panel.

Reverting to a previous version of a document doesn't eliminate any versions, but it moves this previous version to the top of your revision history.

View your edits in more detail

Revisions are grouped into short time periods to make it easier for you to see the slight differences between previous document versions. If you want more information, click Show more detailed revisions in the lower right corner of the revision history panel.

See new changes in a file

If you are working on a document with other people, you can see what new changes have been added by your collaborators when you open the file.

  1. Open a document.
  2. If there are new changes, click the New changes button to the right the "Help" menu. You can also click the File menu > See new changes.
  3. In the top right, use the arrows to scroll through the list of changes.
    • Note: Added text is highlighted. Deleted text has a strikethrough.
  4. To copy any of the added text, select the text, right-click it, and choose Copy. To go back to the current document, click the X in the top left.

To see the revision history while viewing the new changes, click See full history in the top right.

Note: At the moment, this feature is not available for spreadsheets or presentations.

Unable to see a previous version of your file?

The revisions for your file may occasionally be merged to save storage space. This can happen due to the age of the file or the large size of certain revisions. Learn more about this process.

Note: Revision history is only available for users with access to edit the file. Users who have only "view" or "comment" access aren't able to see the history of changes.

Matt is a Docs & Drive expert and author of this help page. Leave him feedback below about the page.

Was this article helpful?