Edit presentations with a screen reader

Once you've turned on screen reader support for Google Docs editors on the web, you can start editing presentations.

When you open a presentation in Google Slides, the first slide of your presentation is in focus.

The presentation editor includes the slide canvas, revision history, animations, speaker notes, and film strip.

  • Slide canvas: To get to the slide canvas from any other area, press Ctrl + Alt + Shift + c (Windows, Chrome OS) or ⌘ + Option + Shift + c (Mac).
  • Film strip: The presentation editor contains a film strip listing all slides in the presentation. To move focus to the film strip, press Ctrl + Alt + Shift + f (Windows, Chrome OS) or ⌘ + Option + Shift + f (Mac). Once you're in the film strip, move between slides using the up and down arrows.
  • Animations pane: To add animations to a slide, open the animations pane by pressing Ctrl + Alt + Shift + b (Windows, Chrome OS) or ⌘ + Option + Shift + b (Mac). Your screen reader announces options to add animations to shapes and objects, or to add transitions to your slides.
  • Speaker notes: To move to the speaker notes, press Ctrl + Alt + Shift + s (Windows, Chrome OS) or Ctrl + ⌘ + Shift + s (Mac). As you type speaker notes, you'll hear screen reader feedback.

To go to the next shape in a slide, press Tab. To go to the previous shape, press Shift + Tab.

To select text, hold Shift and use the arrow keys. When you select text, you'll hear the text followed by "selected."

Search the menus

To do things quickly in Slides, you can search the menus. Press Alt + / (Windows, Chrome OS) or Option + / (Mac) to start a menu search.

Once your focus is in the search box, type a command, such as "Rename" or "Insert." Press the down arrow to hear search results. For example, if you type "Insert," the options include inserting an image, a comment, and other choices. Press Enter to apply an action.

Keyboard shortcuts

Because Slides is different from a typical website, some standard screen reader shortcuts don't apply. For the best experience, use Slides shortcuts while editing your document.

If you ever forget a shortcut, you can open a list of shortcuts within Slides by pressing Ctrl + / (Windows, Chrome OS) or ⌘ + / (Mac). Along with a list of shortcuts, the dialog has a link to view all shortcuts in the Help Center. To close the dialog, press Escape.

Application menus, top-level buttons, and toolbar

To browse the application menus, start with the File menu. Press Alt + f (Chrome on Windows, Chrome OS), Alt + Shift + f (Windows), or Ctrl + Option + f (Mac). Press the right arrow to navigate to other application menus, including Edit, View, Insert, Slide, Format, Arrange, Tools, Table, and Help.

If you're using VoiceOver on Mac: To go to to the application menus, first use the pass-through key combination Ctrl + Option + Tab, then type the menu shortcut, such as Ctrl + Option + f for the File menu.

From the application menus, you can navigate to two other sets of controls:

  • Press Shift + Tab to go to the top-level buttons. These buttons are for presentation-level actions, such as renaming, starring, sharing, or moving the presentation to a different folder.
  • Press Tab to go to the toolbar. The toolbar has editing and formatting tools, such as lists and indentation.

Note: In compact mode, the top-level buttons and application menus are hidden. To turn compact mode on or off, press Ctrl + Shift + f (Windows, Chrome OS, or Mac).

Accessibility menu

If you've turned on screen reader support for the Docs editors, the application menu bar includes an Accessibility menu with shortcuts for navigating and reading your presentation.

To open the Accessibility menu, press Alt + a (Chrome on Windows, Chrome OS), Alt + Shift + a (Windows), or Ctrl + Option + a (Mac). Press the down arrow to hear options, such as Speak, Comments, Formatting, and more. Press the right arrow to open a sub-menu, and press Enter to select an option.

Help documentation

To find help documentation, open the Help menu in the application menu bar and select Slides Help. Press Tab to reach the search box, then type a search term, such as "Images," and press Enter. The help opens in a dialog where you can read or navigate to other topics. To dismiss the dialog and return to the presentation, press Escape.

You can also open the Docs editors Help Center in a new tab or window and search or browse for more information.

Editing and formatting basics

To insert something on a slide, such as a text box, image, or table, first go to the slide where you'd like to make the insertion. Press Alt + / (Windows, Chrome OS) or Option + / (Mac) to search the menus, then type "insert" to get a list of options to insert. Use the arrow keys to explore the list, and press Enter to make your selection.

To announce the text or paragraph formatting at your cursor's current location, press Ctrl + Alt + a then f (Windows, Chrome OS) or Ctrl + ⌘ + a then f (Mac).

To explore the formatting styles that you can apply within your presentation, open the Format menu in the application menu bar. You can also use Slides shortcuts to change styles.

Learn more about how to create, edit, and customize slides.

Change the layout of a slide

Slide layouts are specific formats for individual slides in your presentation, such as "Title and body" or "Title and two columns."

When you navigate through the film strip view, you'll hear layout information about each slide in the presentation. To determine or change the layout for a slide, follow these steps:

  1. In the film strip, select the slide where you want to apply the layout.
  2. Open the Slide menu in the application menu bar.
  3. Select Apply layout, then press the right arrow to hear the layout options. You'll hear "selected" for the current slide's layout, and you'll hear "not selected" for the other layout options.
  4. To select a different layout option for the current slide, press Enter.

Change the order of slides

To change the order of slides in a presentation, follow these steps:

  1. Go to the film strip: Press Ctrl + Alt + Shift + f (Windows, Chrome OS) or ⌘ + Option + Shift + f (Mac).
  2. Use the up and down arrows to move to the slide that you want to move. To select multiple slides to move, press and hold Shift as you press the arrow keys.
  3. To move the slides up or down, hold Ctrl (Windows, Chrome OS) or (Mac) and press the up or down arrow.

Spell-check a presentation

Slides automatically detects misspellings in your presentation. To go to the next misspelling, press Ctrl + apostrophe (Windows, Chrome OS) or ⌘ + apostrophe (Mac). To go to the previous misspelling, press Ctrl + semicolon (Windows, Chrome OS) or ⌘ + semicolon (Mac).

To correct a misspelling, open the context menu by pressing Ctrl + Shift + x (Windows, Chrome OS) or ⌘ + Shift + x (Mac). From the context menu, select the correctly spelled suggestion, and press Enter.

You can also use the spell-check tool. From the the Tools menu in the application menu bar, select Spelling. For each misspelling, you can either change it, ignore it, or add it to the dictionary. Learn more about spell-check and automatic corrections.

Add alternative text for an image or drawing

To add or edit alternative text (alt text), follow these steps:

  1. Select the image or drawing.
  2. Open the Format menu in the application menu bar.
  3. Select Alt text.
  4. In the Alt text dialog, enter a description for the image or drawing, then select Enter.

Present your slides in front of a group

To present your slides to a group, press Ctrl + F5 (Windows), Ctrl + Search + 5 (Chrome OS) or ⌘ + Shift + Enter (Mac).

Once you're in presentation mode, advance to the next slide by pressing the down or right arrow. To return to the previous slide, press the up arrow.

To exit presentation mode, press Escape.

An alternative to presentation mode is the HTML view. This view displays your presentation as a single webpage that you can navigate as you would a normal webpage. To switch to HTML view, press Ctrl + Alt + Shift + h (Windows or Chrome OS), or ⌘ + Option + Shift + h (Mac).

Matt is a Docs & Drive expert and author of this help page. Leave him feedback below about the page.

Was this article helpful?