Redigera kalkylark med ett skärmläsningsprogram

Du kan redigera kalkylark på datorn med ett skärmläsningsprogram.

Kontrollera först att du har aktiverat stöd för skärmläsare i Dokument.

Om du använder en Windows-dator eller Chromebook med pekskärm följer du tipsen för att använda pekskärm med ett skärmläsningsprogram.

Navigering i kalkylarket

När du öppnar ett kalkylark är ditt fokus i den första cellen. När du flyttar genom kalkylarket får du adressen och innehållet för varje cell uppläst via skärmläsaren. Om cell C4 exempelvis innehåller "New York City", hör du "New York City C4."

Använda kortkommandon

Kalkylark skiljer sig från en normal webbplats gäller inte vissa vanliga kortkommandon för skärmläsningsprogram. För att det ska fungera så smidigt som möjligt använder du Kalkylark-kortkommandon när du redigerar kalkylarket.

Om du vill öppna en lista med kortkommandon i kalkylarket trycker du på Ctrl + / (Windows, Chrome OS) eller ⌘ + / (Mac). Du kan söka efter åtgärder som move eller columns. Om du vill återgå till kalkylarket trycker du på Escape.

Utför snabba åtgärder genom att söka i menyerna

  1. Tryck på Alt + / (Windows, Chrome OS) eller Option + / (Mac).
  2. Ange ett kommando som Byt namn eller Infoga
  3. Tryck på nedåtpilen för att höra sökresultaten. Om du till exempel skriver Infoga, inkluderar alternativen att lägga till rader, kommentarer och andra alternativ. 
  4. Välj en åtgärd genom att trycka på Retur.

Använd menyerna, knapparna på toppnivå och verktygsfältet

Obs! Om det inte finns några knappar och menyer högst upp trycker du på Ctrl + Skift + f (Windows, Chrome OS eller Mac).

Så här bläddrar du i menyerna:

  1. Öppna Arkiv-menyn via webbläsarens knapp för kortkommando:
    • Windows med Chrome-webbläsare: Alt + f
    • Windows med andra webbläsare: Alt + Skift + f
    • Chrome OS: Alt + f
    • Mac: Använd först tangentkombinationen Ctrl + Option + Tab och sedan Ctrl + Option + f
  2. Tryck på högerpilen för att utforska till andra menyer inklusive Redigera, Visa, Infoga, Format, Data, Verktyg, Tillägg, Hjälp och Tillgänglighet.

Tips! Du får hjälp genom att öppna Hjälp-menyn och välja Hjälp till kalkylark. Tryck på Tabb för att öppna sökrutan, skriv en sökterm, exempelvis Formler, och tryck på Retur. Hjälpen öppnas i en ruta där du kan läsa eller navigera till andra ämnen. Om du vill återgå till kalkylarket trycker du på Escape.

Från menyerna kan du navigera till två andra verktygsuppsättningar:

  • Knapparna på toppnivå: De här knapparna är till för åtgärder på kalkylarksnivå, som att byta namn, stjärnmärka eller flytta kalkylarket till en annan mapp. Från menyerna trycker du på Skift + Tab.
  • Verktygsfält: Verktygsfältet innehåller alternativ för redigering och formatering, till exempel typsnitt och justering. Från menyerna trycker du på Tabb.

Använd menyn Tillgänglighet för att läsa eller navigera i kalkylarket

  1. Öppna Tillgänglighet-menyn via kortkommandot för din webbläsare:
    • Windows med Chrome-webbläsare: Alt + a
    • Windows med andra webbläsare: Alt + Shift + a
    • Chrome OS: Alt + a
    • Mac: Använd först tangentkombinationen Ctrl + Option + Tab och sedan Ctrl + Option + a
  2. Tryck på nedåtpilen för att höra alternativ som Tala, Öppna intervall med mera.
  3. Tryck på högerpilen för att öppna en undermeny och tryck sedan på nedåtpilen för att utforska alternativ på undermenyn.
  4. Tryck på Retur för att välja ett alternativ.

Grunder om redigering och formatering

Om du vill redigera innehållet i en cell trycker du på Retur på cellen som är i fokus. Gör ändringarna och tryck sedan på Retur för att tillämpa dem eller Escape för att avbryta.

Hör cellformatering och innehåll

När du flyttar genom kalkylarket hör du relevanta meddelanden om innehållet i cellerna. Skärmläsaren anger till exempel när en cell innehåller länkar, anteckningar, datavalidering eller filtrering.

  • Länkar: Om du vill följa en länk trycker du på Alt + Retur (Windows) eller Option + Enter (Mac).
  • Anteckningar: Om du vill lägga till eller redigera en anteckning om cellen i fokus trycker du på Skift + F2 (Windows, Mac) eller Skift + Search + 2 (Chrome OS). Skriv in din anteckning i fönstret som visas och tryck sedan på Escape. Om du vill ta bort en anteckning raderar du all text i anteckningen.
  • Datavalidering: Du hör om en cell har ogiltigt innehåll som ett resultat av datavalidering.
  • Filtrering: Om du flyttar från ett ofiltrerat cellområde till ett filtrerat område hör du att du har öppnat en filtrerad region.

Använda Tala-menyn

Du kan använda Tala-menyn för att få information om formateringen för den markerade cellen eller för att höra innehållet för raden eller kolumnen. Du kan även ställa in kalkylarket på att alltid läsa upp formatering.

  1. Öppna Tillgänglighet-menyn via kortkommandot för din webbläsare:
    • Windows med Chrome-webbläsare: Alt + a
    • Windows med andra webbläsare: Alt + Shift + a 
    • Chrome OS: Alt + a
    • Mac: Använd först tangentkombinationen Ctrl + Option + Tab och sedan Ctrl + Option + a
  2. Välj Tala.
  3. Navigera i menyn med nedåtpilen och välj ett alternativ genom att trycka på Retur.

Ändra cellformatering

Du kan ändra formatering för en hel cell eller för valda delar av en cell.

  • Om du vill ändra formateringen för en hel cell markerar du cellen. 
  • Om du vill ändra en viss del (exempelvis markera ett ord i fetstil) trycker du på Retur. Håll sedan Skift nedtryckt och använd piltangenterna för att välja den del du vill ändra. 

Utforska formateringsmallar

  1. Öppna Format-menyn via webbläsarens knapp för kortkommando:
    • Windows med Chrome-webbläsare: Alt + o
    • Windows med andra webbläsare: Alt + Skift + o  
    • Chrome OS: Alt + o
    • Mac: Använd först tangentkombinationen Ctrl + Option + Tab och sedan Ctrl + Option + a 
  2. Tryck på nedåtpilen för att höra alternativ och välj genom att trycka på Retur.
  3. Om du vill rensa formateringen för den valda cellen trycker du på Ctrl + \ (Windows) eller ⌘ + \ (Mac).

Läs mer om redigering och formatering av celler.

Duplicera, kopiera eller byta namn på ett arbetsblad

På kalkylarksmenyn kan du göra flera olika åtgärder på det aktiva arbetsbladet, exempelvis duplicera, kopiera eller byta namn. 
  1. Tryck på Alt + Skift + s (Windows) eller Option + Shift + s (Mac).
  2. Tryck på nedåtpilen för att navigera genom alternativen och tryck på Retur för att välja.

Arbeta med flera arbetsblad i ett kalkylark

  1. Tryck på Alt + Skift + k (Windows, Chrome OS) eller Option + Shift + k (Mac).
  2. Navigera på listan med upp- och nedåtpilarna.
  3. Tryck på Retur för att flytta ett arbetsblad. 

Välj och arbeta inom ett cellintervall

  1. Gå till den första cell som du vill inkludera i intervallet.
  2. Håll Skift nedtryckt och använd piltangenterna för att välja cellintervall.

När du har valt ett intervall kan du använda följande kortkommandon för att flytta fokus inom intervallet:

  • Retur: Flytta från toppen till botten.
  • Skift + Retur: Flytta från botten till toppen.
  • Tabb: Flytta från vänster till höger.
  • Skift + Tabb: Flytta från höger till vänster.

Om du vill redigera en cell utan att avmarkera ditt intervall trycker du på F2 (Windows, Mac) eller Search + 2 (Chrome OS).

Lägg till, radera eller flytta kolumner och rader

Välj rader eller kolumner

  1. Välj en cell på raden eller kolumnen som du vill markera.
  2. Välj en rad genom att trycka på Skift + blanksteg. Välj en kolumn genom att trycka på Ctrl + blanksteg.
  3. Om du vill välja fler rader eller kolumner trycker du på Skift och piltangenterna.

Lägg till rader eller kolumner

  1. Välj en cell där du vill lägga till den nya raden eller kolumnen.
    • Tips! Om du vill lägga till flera rader eller kolumner samtidigt väljer du samma antal celler som antalet rader eller kolumner du vill lägga till. Om du exempelvis vill infoga två rader högst upp, markerar du först en cell på rad 1 och 2.
  2. Öppna Infoga-menyn via webbläsarens knapp för kortkommando:
    • Windows med Chrome-webbläsare: Alt + i
    • Windows med andra webbläsare: Alt + Skift + i
    • Chrome OS: Alt + i
    • Mac: Använd först tangentkombinationen Ctrl + Option + Tab och sedan Ctrl + Option + i
  3. Välj ett av alternativen för att infoga rader eller kolumner.
  4. Om du har valt flera celler i steg 1 har Infoga-menyn alternativ för att infoga flera rader eller kolumner.

Radera rader eller kolumner

  1. Välj en eller flera celler i de rader eller kolumner som du vill ta bort. Om du väljer flera celler kan du ta bort flera rader eller kolumner samtidigt.
  2. Öppna Redigera-menyn via webbläsarens knapp för kortkommando:
    1. Windows med Chrome-webbläsare: Alt + e
    2. Windows med andra webbläsare: Alt + Skift + e 
    3. Chrome OS: Alt + e
    4. Mac: Använd först tangentkombinationen Ctrl + Option + Tab och sedan Ctrl + Option + e
  3. Välj ett av alternativen för att ta bort rader eller kolumner.

Flytta rader eller kolumner

  1. Välj en cell i raden eller kolumnen som du vill flytta.
  2. Välj en kolumn (Ctrl + blanksteg) eller rad (Skift + blanksteg) som du vill flytta. Om du vill välja flera kolumner eller rader trycker du på Skift och piltangenterna.
  3. Öppna Redigera-menyn via webbläsarens knapp för kortkommando:
    1. Windows med Chrome-webbläsare: Alt + e
    2. Windows med andra webbläsare: Alt + Skift + e 
    3. Chrome OS: Alt + e
    4. Mac: Använd först tangentkombinationen Ctrl + Option + Tab och sedan Ctrl + Option + e
  4. Välj ett av alternativen för att flytta kolumner eller rader.

Dölj, ta bort eller lås kolumner och rader

Dölj rader eller kolumner

  1. Välj en cell på den rad eller kolumn du vill dölja.
  2. Välj en kolumn (Ctrl + blanksteg) eller rad (Skift + blanksteg) som du vill dölja. Om du vill välja flera kolumner eller rader trycker du på Skift och piltangenterna.
  3. Öppna menyn genom att trycka på Ctrl + Skift + \.
  4. Tryck på nedåtpilen tills du når Dölj kolumn eller Dölj rad och tryck sedan på Retur.

Visa rader eller kolumner

  1. Markera de kolumner eller rader som omger de dolda.
  2. Öppna menyn genom att trycka på Ctrl + Skift + \.
  3. Välj Visa kolumner eller Dölj rader.

Låsa rader eller kolumner

Du kan låsa upp till tio rader eller fem kolumner på ett arbetsblad. När du låser rader och kolumner kan du behålla vissa uppgifter högst upp eller längst till vänster när du rullar igenom resten av kalkylarket.

  1. Öppna Visa-menyn via webbläsarens knapp för kortkommando:
    • Windows med Chrome-webbläsare: Alt + v
    • Windows med andra webbläsare: Alt + Skift + v  
    • Chrome OS: Alt + v
    • Mac: Använd först tangentkombinationen Ctrl + Option + Tab och sedan Ctrl + Option + v
  2. Välj Lås rader eller Lås kolumner
  3. Tryck på nedåtpilen för att höra alternativen från noll till 10 och tryck sedan på Retur för att välja.

Om du placerar fokus i ett låst område meddelar skärmläsaren att du befinner dig i låsta rader eller kolumner.

Arbeta med formler, diagram eller bilder

Lägg till eller redigera en formel

Om du vill lägga till en formel i en cell skriver du ett likhetstecken (=) följt av namnet på funktionen. Du hör en uppläsning av den formel som du skriver. Läs mer om funktioner och formler.

Om du vill ändra eller ta bort en formel trycker du på Retur för att redigera cellen. Gör sedan ändringarna. Om det finns ett fel i formeln hör du en förklaring av felet tillsammans med cellinnehållet.

Läsa formulär

Om en cellen innehåller en formel hör du formelvärdet. Det finns några olika sätt att läsa formler:

  • Alternativ 1: Tryck på Retur för att redigera en cell och läsa dess innehåll.
  • Alternativ 2: Öppna formelfältet genom att öppna en meny och sedan tabba till formelfältet. Om formelfältet är dolt öppnar du Visa-menyn och väljer Formel-fältet.
  • Alternativ 3: Ställ in ett arbetsblad på att alltid visa alla formler. Tryck på Ctrl + enkelt bakvänt citattecken (`) eller återvänd till Visa-menyn och välj Visa formler.

Hitta diagram, bilder eller ritningar

Kalkylarket kan innehålla information som inte ingår i datanätet, som inbäddade diagram, ritningar eller bilder.

Om du navigerar till en cell som täcks av diagram, bilder eller ritningar som är inbäddade hör du ett meddelande i skärmläsaren om att cellen är täckt.

När ett diagram har valts på kalkylarket läser skärmläsarfunktionen upp diagrammets namn, alternativ text och du får möjlighet att höra en sammanfattning av diagrammet.

Redigera diagram, bilder eller ritningar

  1. Öppna Tillgänglighet-menyn via kortkommandot för din webbläsare:
    • Windows med Chrome-webbläsare: Alt + a
    • Windows med andra webbläsare: Alt + Skift + a
    • Chrome OS: Alt + a
    • Mac: Använd först tangentkombinationen Ctrl + Option + Tab och sedan Ctrl + Option + a
  2. Tryck på e för Välj. Tryck sedan på nedåtpilen för att bläddra mellan objekten du kan välja som diagram, teckningar eller bilder. Tryck på Retur för att välja ett objekt.
  3. Det inbäddade objektet är nu valt. Välj nu ett alternativ:
    • Tryck på piltangenterna för att flytta objektet.
    • Tryck på Tabb för att flytta till alternativknappen och tryck sedan på Retur för att öppna alternativmenynto open the options menu. Tryck på nedåtpilen för att bläddra bland andra åtgärder som du kan tillämpa på objektet och tryck på Retur för att välja.

Läs mer om att lägga till diagram eller grafer.

Hitta svar på frågor om din kalkylarksdata

Du kan ställa frågor om data i kalkylarket. Du kan även hitta formel-, formaterings- eller diagramförslag baserat på din data.

  1. Öppna Utforska-avsnittet i kalkylarket genom att trycka på Alt + Skift + x (Windows, Chrome OS) eller Option + Shift + x (Mac).
  2. Använd tangenttryckningarna för skärmläsningsprogrammet när du vill navigera i Utforska-regionen och få rubriker som Svar, Formatering och Analys upplästa.
  3. I avsnittet Svar anger du en fråga om din data och trycker sedan på Retur. Du hittar exempelfrågor nedan. (Obs! Funktionen Svar är bara tillgänglig på engelska.)
    • Om du vill få svaret uppläst använder du skärmsläsarens tangenttryckningar för att navigera i svarskortet.
    • Välj Visa formel om du vill ta reda på vilken formel som användes för att ge ditt svar. Tryck på Retur om du vill kopiera formeln till urklipp. Du kan sedan infoga formeln i kalkylarket.

Exempelfrågor

  • ”Vem person har toppresultatet?”(då ”person” och ”resultat” finns i ditt kalkylark)
  • ”Total försäljning i september 2016” (då kolumnen ”försäljning” och ”datum” finns i ditt kalkylark)

Exempel på frågor som inte fungerar:

  • Hjälpfrågor som ”Hur använder jag fetstil på den här cellen?”
  • Webbsökningar som ”Vad är det för väder”

Läs mer om att använda rekommenderade diagram och analyser.

Visa Kalender, Keep och Tasks

Du kan använda Google Kalender, Keep och Tasks i en sidopanel när du använder Dokument, Kalkylark och Presentationer. Verktygen i sidopanelen är komprimerade som standard. Följ stegen nedan för att öppna sidopanelen och utöka något av verktygen:

  1. Öppna sidopanelen med följande kortkommandon:
    • Windows: Ctrl + Alt + . (punkt) eller Ctrl + Alt + , (kommatecken)
    • Chromebook: Alt + Skift + . (punkt) eller Alt + Skift + , (kommatecken)
    • Mac: ⌘ + Option + . (punkt) eller ⌘ + Option + , (komma)
  2. I sidopanelen trycker du på upp- eller nedpilen för att gå igenom listan över verktyg: Kalender, Keep och Tasks.
  3. Tryck på Retur för att expandera verktyget du vill använda.
  4. Du kan nu utföra följande åtgärder i sidopanelen, utan att lämna kalkylarket:
    • Kalender: Visa dagens schema, klicka på en händelse och redigera den, skapa nya händelser och hoppa till kommande händelser.
    • Keep: Skapa checklistor och göra anteckningar.
    • Tasks: Lägga till saker att göra och sätta tidsgränser.
  5. Använd följande kortkommandon om du vill återgå till kalkylarket när sidopanelen är öppen:
    • Windows: Ctrl + Alt + . (punkt) eller Ctrl + Alt + , (kommatecken)
    • Chromebook: Alt + Skift + . (punkt) eller Alt + Skift + , (kommatecken)
    • Mac: ⌘ + Option + . (punkt) eller ⌘ + Option + , (komma)
  6. Stäng sidopanelen genom att trycka på Skift + Tabb tills du kommer till Stäng och tryck sedan på Retur.

Läs mer om hur du använder Kalender, Keep och Tasks med Dokument, Kalkylark och Presentationer.

 

Var det här till hjälp?
Hur kan vi förbättra den?