スクリーン リーダーでスプレッドシートを編集する

スクリーン リーダーを使用して、パソコンでスプレッドシートを編集できます。

ドキュメントのスクリーン リーダーのサポートがオンになっていることを事前に確認してください。

タップ入力付きの Windows パソコンまたは Chromebook を使用している場合は、スクリーン リーダーでタップ入力を使用する方法をご覧ください。

スプレッドシート内を移動する

スプレッドシートを開くと、最初のセルがフォーカスされます。スプレッドシート内を移動すると、各セルの位置とコンテンツが読み上げられます。たとえば、セル C4 に「東京都」が含まれている場合、「東京都、C4」と読み上げられます。

キーボード ショートカットを使用する

Google スプレッドシートは一般的なウェブサイトとは異なるため、標準的なスクリーン リーダーのショートカットを使用できないことがあります。スプレッドシートの編集中はスプレッドシートのショートカットを使用することをおすすめします。

スプレッドシートの作業中にショートカットのリストを開くには、Ctrl+/ キー(Windows、Chrome OS)または ⌘+/ キー(Mac)を使用します。「移動」や「」などの操作を検索できます。作業していたスプレッドシートに戻るには Esc キーを押します。

メニューを検索してすばやく操作を実行する

  1. Alt+/ キー(Windows、Chrome OS)または option+/ キー(Mac)を押します。
  2. 名前を変更」や「挿入」といったコマンドを入力します。
  3. キーを押すと、検索結果がアナウンスされます。たとえば、「挿入」と入力すると、行の追加、コメントなどの項目がアナウンスされます。
  4. 操作を選択するには Enter キーを押します。

メニュー、トップレベルのボタン、ツールバーを使用する

注: 上部にボタンやメニューが表示されていない場合は、Ctrl+Shift+F キー(Windows、Chrome OS、Mac)を押します。

メニューを参照するには:

  1. お使いのブラウザのショートカット キーを使用して [ファイル] メニューを開きます。
    • Windows(Chrome ブラウザ): Alt+F
    • Windows(その他のブラウザ): Alt+Shift+F
    • Chrome OS: Alt+F
    • Mac: control+option+tab キー、control+option+F キーの順に押します。
  2. キーを押すと、[編集]、[表示]、[挿入]、[表示形式]、[データ]、[ツール]、[アドオン]、[ヘルプ]、[ユーザー補助機能] などの他のメニューに移動できます。

ヒント: ヘルプを表示するには、[ヘルプ] メニューを開き [スプレッドシートのヘルプ] を選択します。Tab キーを押して検索ボックスに移動し、「数式」などの検索キーワードを入力して Enter キーを押します。このヘルプは他のトピックに移動して閲覧することが可能なボックスに表示されます。作業していたスプレッドシートに戻るには Esc キーを押します。

メニューからは、次の 2 つのコントロール セットに移動できます。

  • トップレベルのボタン: 名前変更、スター付け、共有、別のフォルダへのスプレッドシートの移動といったスプレッドシートの操作を行うためのボタンです。いずれかのメニューで Shift+Tab キーを押します。
  • ツールバー: ツールバーには、フォントや配置といった編集と表示形式のメニュー項目が表示されます。いずれかのメニューで Tab キーを押します。

ユーザー補助機能メニューでスプレッドシートを閲覧、移動する

  1. お使いのブラウザのショートカット キーを使用して [ユーザー補助機能] メニューを開きます。
    • Windows(Chrome ブラウザ): Alt+A
    • Windows(その他のブラウザ): Alt+Shift+A
    • Chrome OS: Alt+A
    • Mac: control+option+tab キー、control+option+A キーの順に押します。
  • キーを押すと、[読み上げ]、[範囲に移動] などの項目がアナウンスされます。
  1. キーを押してサブメニューを開き、↓ キーを押してサブメニューの項目を表示します。
  2. 項目を選択するには Enter キーを押します。

編集と書式設定の基本操作

セルのコンテンツを編集するには、そのセルにフォーカスを移動して Enter キーを押します。変更する内容を入力して、その変更を確定するには Enter キーを押します。変更をキャンセルする場合は Esc キーを押します。

セルの表示形式と内容を読み上げる

スプレッドシート内を移動すると、セルのコンテンツについてアナウンスされます。たとえば、セルにリンク、メモ、データの検証、またはフィルタが含まれていることがスクリーン リーダーによってアナウンスされます。

  • リンク: リンク先に移動するには、Alt+Enter キー(Windows)または option+return キー(Mac)を押します。
  • : フォーカスしたセルに対してメモの追加や編集を行うには、Shift+F2 キー(Windows、Mac)または Shift+Search+2 キー(Chrome OS)を押します。表示されたウィンドウにメモを入力して Esc キーを押します。メモを削除するには、メモ内のテキストをすべて削除します。
  • データの入力規則: データの入力規則を適用した結果、セルに無効なコンテンツが含まれている場合、その旨がアナウンスされます。
  • フィルタリング: フィルタリングしていないセル範囲からフィルタリングしたセル範囲に移動すると、現在の位置がフィルタリング済みの領域内であることがアナウンスされます。

[読み上げ] メニューを使用する

[読み上げ] メニューを使用して、セルの表示形式に関する情報を取得したり、行または列の内容をアナウンスさせたりすることができます。表示形式を常に読み上げるようにスプレッドシートを設定することもできます。

  1. お使いのブラウザのショートカット キーを使用して [ユーザー補助機能] メニューを開きます。
    • Windows(Chrome ブラウザ): Alt+A
    • Windows(その他のブラウザ): Alt+Shift+A 
    • Chrome OS: Alt+A
    • Mac: control+option+tab キー、control+option+A キーの順に押します。
  2. [読み上げ] を選択します。
  3. キーを押してメニュー内を移動し、Enter キーを押して項目を選択します。

セルの書式設定を変更する

セル全体またはセルの一部の表示形式を変更することができます。

  • セル全体の表示形式を変更するには、セルを選択します。 
  • セルの一部の表示形式を変更するには(1 つの単語を太字にする場合など)、Enter キーを押し、Shift キーを押しながら矢印キーを使用して変更箇所を選択します。 

表示形式のスタイルを調べる

  1. お使いのブラウザのショートカット キーを使用して [表示形式] メニューを開きます。
    • Windows(Chrome ブラウザ): Alt+O
    • Windows(その他のブラウザ): Alt+Shift+O  
    • Chrome OS: Alt+O
    • Mac: control+option+tab キー、control+option+O キーの順に押します。 
  2. キーを押すと、利用できる項目がアナウンスされます。項目を選択するには Enter キーを押します。
  3. 選択したセルの表示形式をクリアするには、Ctrl+\(Windows)または ⌘+\(Mac)を押します。

詳細については、セルの編集と表示形式の設定についての記事をご覧ください

シートの複製、コピー、名前変更を行う

シートのメニューを使用すると、アクティブなシート上で複製、コピー、名前の変更などのさまざまな操作を行えます。 
  1. Alt+Shift+S キー(Windows)または option+shift+S キー(Mac)を押します。
  2. キーを押して別の項目に移動し、Enter キーを押して項目を選択します。

スプレッドシートの複数のシートで作業する

  1. Alt+Shift+K キー(Windows、Chrome OS)または option+shift+K キー(Mac)を押します。
  2. 上下矢印キーを使用してリスト内を移動します。
  3. シートに移動するには Enter キーを押します。 

セルの範囲を選択して作業する

  1. 範囲に含める最初のセルに移動します。
  2. Shift キーを押しながら、矢印キーを使用してセルの範囲を選択します。

範囲を選択したら、次のショートカットを使用して範囲内でフォーカスを移動できます。

  • Enter: 上から下に移動します。
  • Shift+Enter: 下から上に移動します。
  • Tab: 左から右に移動します。
  • Shift+Tab: 右から左に移動します。

セルの範囲を選択せずにセルを編集するには、F2 キー(Windows、Mac)または Search+2 キー(Chrome OS)を押します。

列や行を追加、削除、移動する

行または列を選択する

  1. 選択する行内または列内にあるセルに移動します。
  2. 行を選択するには Shift+Space キーを押します。列を選択するには Ctrl+Space キーを押します。
  3. 追加の行または列を選択するには、Shift キーを押しながら矢印キーを押します。

行または列を追加する

  1. 新しい行または列を追加する位置のセルを選択します。
    • ヒント: 一度に複数の行や列を追加するには、追加する行または列の数と同じ数のセルを選択します。たとえば、上部に 2 行挿入する場合は、行 1 と行 2 のセルを 1 つずつ選択します。
  2. お使いのブラウザのショートカット キーを使用して [挿入] メニューを開きます。
    • Windows(Chrome ブラウザ): Alt+I
    • Windows(その他のブラウザ): Alt+Shift+I
    • Chrome OS: Alt+I
    • Mac: control+option+tab キー、control+option+I キーの順に押します。
  3. いずれかの項目を選択して行または列を挿入します。
  4. 手順 1 で複数のセルを選択した場合、[挿入] メニューに複数の行または列を挿入する項目が表示されます。

行または列を削除する

  1. 削除する行または列内のセルを選択します。複数のセルを選択すると、一度に複数の行または列を削除できます。
  2. お使いのブラウザのショートカット キーを使用して [編集] メニューを開きます。
    • Windows(Chrome ブラウザ): Alt+E
    • Windows(その他のブラウザ): Alt+Shift+E 
    • Chrome OS: Alt+E
    • Mac: control+option+tab キー、control+option+E キーの順に押します。
  3. いずれかの項目を選択して行または列を削除します。

行または列の移動

  1. 移動する行または列内にあるセルを選択します。
  2. 移動する列(Ctrl+Space キー)または行(Shift+Space キー)を選択します。複数の列または行を選択するには、Shift キーを押しながら矢印キーを押します。
  3. お使いのブラウザのショートカット キーを使用して [編集] メニューを開きます。
    • Windows(Chrome ブラウザ): Alt+E
    • Windows(その他のブラウザ): Alt+Shift+E 
    • Chrome OS: Alt+E
    • Mac: control+option+tab キー、control+option+E キーの順に押します。
  4. メニュー項目のいずれかを選択して列または行を移動します。

列と行を非表示、再表示、固定する

行または列を非表示にする

  • 非表示にする行または列内のセルを選択します。
  • 非表示にする列(Ctrl+Space)または行(Shift+Space)を選択します。複数の列または行を選択するには、Shift キーを押しながら矢印キーを押します。
  • Ctrl+Shift+\ を押してコンテキスト メニューを開きます。
  • [列を非表示] または [行を非表示] に移動するまで ↓ キーを押し、Enter キーを押します。

行または列を再表示する

  1. 非表示になっている列または行の両脇の列または行を選択します。
  2. Ctrl+Shift+\ を押してコンテキスト メニューを開きます。
  3. [列の非表示を解除] または [行の非表示を解除] を選択します。

行または列を固定する

いずれのシートでも、最大 10 行、5 列まで固定することができます。行や列を固定すると、上部または左端のデータを表示したままでスプレッドシートの残りの部分にスクロールすることができます。

  1. お使いのブラウザのショートカット キーを使用して [表示] メニューを開きます。
    • Windows(Chrome ブラウザ): Alt+V
    • Windows(その他のブラウザ): Alt+Shift+V  
    • Chrome OS: Alt+V
    • Mac: control+option+tab キー、control+option+V キーの順に押します。
  2. [行を固定] または [列を固定] を選択します。 
  3. キーを押して 0~10 が読み上げられたら、Enter キーを押していずれかを選択します。

固定した範囲にフォーカスを移動すると、固定中の行または列に移動したことがアナウンスされます。

数式、グラフ、画像を使用する

数式を追加、編集する

セルに数式を追加するには、等号(=)に続いて関数名を入力します。入力と同時に数式が読み上げられます。詳しくは、関数と数式についての記事をご覧ください

数式を変更、削除するには、Enter キーを押してセルの編集モードに切り替え、変更内容を入力します。数式にエラーがある場合、セルのコンテンツとエラーの説明がアナウンスされます。

数式を読み上げる

セルに数式が含まれている場合、数式の値が読み上げられます。数式を読み上げる方法は次のとおりです。

  • 方法 1: Enter キーを押してセルの編集モードに切り替えると、コンテンツが読み上げられます。
  • 方法 2: いずれかのメニューを開き、Tab キーを使用して数式バーに移動します。数式バーが非表示になっている場合は、[表示] メニューを開いて [数式バー] を選択します。
  • 方法 3: すべての数式を常に表示するよう、シートを設定します。Ctrl+`バッククォート)キーを押すか、[表示] メニューに移動して [数式を表示] を選択します。

グラフ、画像、図形描画を探す

スプレッドシートには、埋め込みグラフ、図形描画、画像など、データグリッドではない情報も含めることができます。

埋め込みグラフや画像、図形描画の背面のセルに移動すると、オブジェクトが前面にあることがアナウンスされます。

スプレッドシート内のグラフを選択すると、グラフのタイトルと代替テキストがアナウンスされ、グラフの概要を読み上げるかどうかを選択することができます。

グラフ、画像、図形描画を編集する

  1. お使いのブラウザのショートカット キーを使用して [ユーザー補助機能] メニューを開きます。
    • Windows(Chrome ブラウザ): Alt+A
    • Windows(その他のブラウザ): Alt+Shift+A
    • Chrome OS: Alt+A
    • Mac: control+option+tab キー、control+option+A キーの順に押します。
  2. E キーを押して [選択] を選択し、↓ キーを押してグラフ、図形描画、画像などの選択可能なオブジェクトに移動します。Enter キーを押してオブジェクトを選択します。
  3. 埋め込みオブジェクトを選択したら、そのオブジェクトに対して次の操作を行うことができます。
    1. 矢印キーを使ってオブジェクトを移動します。
    2. Tab キーを使ってオプション ボタンに移動し、Enter キーを押してオプション メニューを開きます。 キーを使ってオブジェクトに適用可能なその他の操作項目に移動し、Enter キーを押して項目を選択します。

詳しくは、グラフについての記事をご覧ください

グラフのキーボードショートカット 

グラフを選択すると、キーボードを使用してグラフ内をすばやく移動できます。 

  • 要素のレイヤを順に切り替えることができます。グラフの各部分を選択するには、Enter キーを押します。
  • グラフ要素を切り替えるには、Tab キーを押します。
  • レベルを 1 つぶん飛び出すには、Esc キーを押します。
  • 他のレベルに移動するには、Enter キーを押します。
  • 現在いるレベルのオブジェクトを順に切り替えるには、Tab キーを押します。
  • 「Tab」と反対方向に移動するには、Shift+Tab キーを押します。

スプレッドシートのデータに関する質問の回答を見つける

スプレッドシート内のデータについて質問できます。また、データに基づいて数式、表示形式、グラフの候補も表示されます。

  1. Alt+Shift+X キー(Windows、Chrome OS)または option+shift+X キー(Mac)を押して、データ探索の領域を開きます。
  2. スクリーン リーダーのキー操作を使ってデータ探索の領域内を移動すると、[回答]、[書式設定]、[分析] などの見出しが読み上げられます。
  3. [回答] セクションにデータに関する質問を入力し、Enter キーを押します。以下のセクションで質問の例をご覧ください(: Answers の機能は英語でのみご利用いただけます)。
    • 回答を読み上げるには、スクリーン リーダーのキー操作を使って回答カード内を移動します。
    • 回答の計算に使用された数式を確認するには [数式を見る] を選択します。Enter キーを押して数式をクリップボードにコピーすると、数式をスプレッドシートに挿入できます。

質問の例

  • 「Which person has the top score?」(ハイスコアのユーザーは?)(「person」と「score」の列がスプレッドシートに含まれている必要があります)
  • 「2016 年 9 月の売上総額」(「売上」と「日付」の列がスプレッドシートに含まれている必要があります)

使用できない質問の例:

  • 機能の使い方に関する質問(例: 「このセルを太字にするには?」)
  • ウェブ検索で尋ねるような質問(例: 「What’s the weather?(今日の天気は?)」)

詳しくは、グラフや分析情報の候補を使用する方法をご覧ください。

系列またはリストを自動的に作成する
  1. 隣り合った 2 個のセルに、次のいずれかを入力します。
    • テキスト
    • 数字
    • 日付
  2. Shift++ を押して、自動入力するセルを選択します。

  3. Ctrl+Alt+ Enter キーを押します。

カレンダー、Keep、ToDo リストを表示する

ドキュメント、スプレッドシート、スライドの使用中にサイドパネルから Google カレンダー、Keep、ToDo リストを使用できます。デフォルトでは、サイドパネルのツールは折りたたまれています。サイドパネルに移動してツールの 1 つを展開するには、次の手順を行います。

  1. サイドパネルには、以下のショートカットで移動できます。
    • Windows: Ctrl+Alt+.(ピリオド)または Ctrl+Alt+,(カンマ)
    • Chromebook: Alt+Shift+.(ピリオド)または Alt+Shift+,(カンマ)
    • Mac: ⌘+option+.(ピリオド)または ⌘+option+,(カンマ)
  2. サイドパネルで上下矢印キーを押して、カレンダー、Keep、ToDo リストのツール間を移動します。
  3. Enter キーを押して、使用するツールを展開します。
  4. サイドパネルでは、スプレッドシートを開いたまま次の操作を行うことができます。
    • カレンダー: 毎日のスケジュールを表示、予定をクリックして編集、新しい予定を作成、今後の予定にジャンプできます。
    • Keep: チェックリストを作成したり、メモを取ったりできます。
    • ToDo リスト: タスクや期限を追加できます。
  5. サイドパネルが開いている状態でスプレッドシートに戻るには、次のショートカットを使用します。
    • Windows: Ctrl+Alt+.(ピリオド)または Ctrl+Alt+,(カンマ)
    • Chromebook: Alt+Shift+.(ピリオド)または Alt+Shift+,(カンマ)
    • Mac: ⌘+option+.(ピリオド)または ⌘+option+,(カンマ)
  6. サイドパネルを閉じるには、[閉じる] が表示されるまで Shift+Tab キーを押し、Enter キーを押します。

詳しくは、Google サービスの併用についての記事をご覧ください

この情報は役に立ちましたか?
改善できる点がありましたらお聞かせください。