管理 Chrome 自助服务终端应用设置

本文供 Chrome 管理员和有 Chrome 应用开发经验的开发者参考。

作为管理员,您可以使用 Google 管理控制台自行设置 Chrome 自助服务终端应用。举例来说,您可能想让应用控制自助服务终端上运行的 Chrome 版本,或在数字标牌上自动启动自助服务终端应用。

在 Chrome 设备上自动启动自助服务终端应用

如果将运行 Chrome 操作系统的设备设为自动启动自助服务终端应用,相应设备会变为单一用途设备。您可以为设备部署多个自助服务终端应用,但只能将一个应用配置为在设备开启时自动启动。举例来说,如果某些设备上的用户互动并非通过键盘或鼠标控制,您可以将这些设备配置为自动启动特定应用。

  1. 登录您的Google 管理控制台

    请使用您的管理员帐号(不是以“@gmail.com”结尾的帐号)登录。

  2. 在管理控制台首页,转到设备 接着点击 Chrome 管理
  3. 点击应用和扩展程序 接着点击 自助服务终端
  4. 要将设置应用于所有人,请将顶级单位部门保持为已选中状态。否则,请选择某个下级单位部门
  5. 自动启动应用旁边,选择您要在 Chrome 设备上自动启动的应用。
  6. 点击保存

允许自助服务终端应用控制 Chrome 版本

支持 Chrome 52 及更高版本。

您可以允许自助服务终端应用控制运行 Chrome 操作系统的设备的 Chrome 版本,以便在应用或部分应用功能与最新的 Chrome 版本不兼容时提高设备稳定性。

建议您仅在以下情形时允许自助服务终端应用控制 Chrome 版本:

  • 您的测试过程与 Chrome 操作系统每六周一次更新的标准周期不一致。
  • 存在与潜在稳定性问题相关的重大风险。

第 1 步:在自助服务终端应用的清单文件中设置操作系统版本

  1. 确定您要指定的 Chrome 操作系统版本。
    1. 前往 CrOS-OmahaProxy CSV Viewer
    2. 记下贵单位最常用设备的“chrome_version”值。
  2. 在应用的 manifest.json 文件中,将 required_platform_version 设为您记下的值。
    例如:"required_platform_version”: “8350”
  3. 如要让应用始终自动更新至最新版本,而不考虑与 Chrome 操作系统版本的兼容性,请将 always_update 设为“true”。

示例配置required_platform_version 设置为 8350,并始终允许应用自动更新。

第 2 步:允许自助服务终端应用控制 Chrome 版本

  1. 登录您的Google 管理控制台

    请使用您的管理员帐号(不是以“@gmail.com”结尾的帐号)登录。

  2. 在管理控制台首页,转到设备 接着点击 Chrome 管理
  3. 点击设置 接着点击 设备
  4. 要将设置应用于所有人,请将顶级单位部门保持为已选中状态。否则,请选择某个下级单位部门
  5. 对于自动启动的自助服务终端应用,请执行以下操作:
    1. 转到设备更新设置 接着点击 自动更新设置
    2. 自动更新菜单中选择停止自动更新
    3. 滚动到自助服务终端控制的更新
    4. 选择允许自助服务终端应用控制操作系统版本
    5. 验证应用的清单文件是否包含 required_platform_version,然后点击确定
    6. 点击保存
  6. 对于所有其他自助服务终端应用,请执行以下操作:
    1. 转到设备更新设置 接着点击 应用控制的更新
    2. 允许应用控制操作系统版本下方,点击选择应用
    3. 在 Chrome 网上应用店内搜索自助服务终端应用。
    4. 点击将操作系统版本固定至应用
    5. 点击保存进行确认。

第 3 步:检查政策是否已应用妥当

您应用任何 Chrome 政策后,用户都必须重启 Chrome 设备,相应设置才会生效。您可以检查相应设备,确保政策已应用妥当。
  1. 在受管理的 Chrome 设备上,转到 chrome://policy
  2. 点击重新加载政策
  3. 对于自动启动的自助服务终端应用,请执行以下操作:
    • 确保 AllowKioskAppControlChromeVersion 政策的“状态”已设为正常,且政策值为 true
    • 确保 DeviceAutoUpdateDisable 政策的“状态”已设为正常,且政策值为 true
  4. 对于指定的自助服务终端应用,请执行以下操作:
    • 确保 DeviceTargetVersionPrefix 政策的“状态”已设为正常
    • 确保 DeviceTargetVersionPrefix 的政策值与应用清单文件中设置的 required_platform_version 值相同。

常见情况

下表介绍了将自助服务终端应用配置为控制设备 Chrome 版本的不同情况。
情况 结果

应用的清单文件没有 required_platform_version 清单键。

每当有最新的 Chrome 操作系统版本推出时,设备都会自动更新到该版本。

应用清单文件中的 required_platform_version 设置无效。

当应用的开发者尝试加载应用时,会在 chrome://extensions 中看到错误消息。要从 Chrome 网上应用店中安装或更新应用,required_platform_version 必须是有效值。

required_platform_version 值低于设备当前的平台版本的值。

系统会安装应用,但是如果 required_platform_version 的值未更新到比当前设备操作系统版本更高的值,设备操作系统将不会更新。

注意:首次从 Chrome 网上应用店中安装某个应用时,系统会验证 required_platform_version 值,但不会与设备当前的平台版本进行比较。

required_platform_version 更新后的值低于设备当前平台版本的值。

系统不会安装应用,且客户端设备会继续运行较旧版本的应用。

相关主题

该内容对您有帮助吗?
您有什么改进建议?