适用于 Windows 的“旧版浏览器支持”扩展程序

1) 旧版浏览器支持

本文可协助管理员管理在由公司管理的 Windows 计算机上使用 Chrome 浏览器的用户。

更新信息:对于 Chrome 74 及更高版本,您可以直接使用内置于 Chrome 中的 LBS 功能。了解详情

Legacy Browser Support icon

如果贵单位想充分利用 Chrome 浏览器,但您的用户仍需要访问要求使用 Internet Explorer 的旧版网站和应用,那么您可以使用此功能轻松地在浏览器之间切换。Chrome 旧版浏览器支持扩展程序可让用户在 Chrome 和其他浏览器之间自动切换。当您的用户点击需要旧版浏览器才能打开的链接(例如需要 ActiveX 的网站)时,Chrome 会自动通过旧版浏览器打开此网址。

您可以指定要在辅助浏览器中打开哪些网址,并为单位部署此 Chrome 政策。您也可以使用单位现有的 Internet Explorer 站点列表来控制要在 Chrome 还是 Internet Explorer 中打开网址。如果您同时采用这两种方式,那么您在政策中指定的网址会优先于 Internet Explorer 站点列表。请在最新的稳定版 Chrome 上使用旧版浏览器支持 (LBS) 功能。

另外,请为您的用户安装“旧版浏览器支持”的原生主机插件。如果不安装此程序包,扩展程序将无法打开备用浏览器。如果您的用户在 IE 中点击了不需要使用旧版浏览器的链接,旧版浏览器支持功能会在 Chrome 中打开这些链接。安装此原生主机插件后,Chrome 和 IE 会根据要访问的网站或应用切换到最适合的浏览器。

此插件适用于 Internet Explorer 6、7、8、9、10 和 11。请注意,您必须关闭 Windows 中的“增强保护模式”,LBS 才能正常运作。

部署提示

  • 如果您使用的是 Chrome 浏览器 73 或更低版本,则需要使用 LBS 扩展程序。如果您使用的是 Chrome 74 或更高版本,则可以继续使用 LBS 扩展程序,也可以仅使用 Chrome 企业版捆绑包中包含的文件设置 LBS。有关详情,请参阅适用于 Windows 的“旧版浏览器支持”(集成式)
  • 您需要先安装原生主机应用,旧版浏览器支持功能才能正常运作。在此之前,用户可以选择是否安装此插件,但现在 LBS 3.0 及以上版本已改为必须安装
  • 要在旧版浏览器支持作为稳定版发布之前先测试新版本的功能,您可以设置测试计算机,对 LBS 测试版进行测试。

您也可以将 Internet Explorer 设为默认浏览器,而将 Chrome 设为备用浏览器。要了解如何完成此配置,请参阅步骤 3

步骤 1:创建 Chrome 测试群组(可选)

如果您的用户对 Chrome 不太熟悉,则可以先在早期使用者群组中测试旧版浏览器支持(推荐大部分大型单位执行此操作)。

  1. 记录您的用户通过旧版浏览器访问的应用和网站(例如要求使用 ActiveX 或 Silverlight 才能访问的应用和网站),以确定需要将哪些网站和网络应用加入旧版浏览器的白名单。

  2. 为 IE 创建主页,以显示您用户可使用 IE 访问的网站。

  3. 在您网域控制器的群组策略编辑器中,将此 IE 主页和其他需要 Internet Explorer 才能运行的网站列入白名单。

可选:您可以在 Chrome 中创建新标签页,然后在其中添加专用 Chrome 书签应用,以便用户访问需要在 IE 中打开的旧版网站和应用。

该内容对您有帮助吗?
您有什么改进建议?