データを整理するための G Suite の活用法トップ 10

職場や学校で Google アプリをもっと活用したい場合は、G Suite の無料試用にお申し込みください

グラフが表示されたタブレットや定規などのデータ分析ツール

濃い灰色の線

すべての手順を表示する | すべての手順を非表示にする

1

フォームを利用してデータ入力を自動化する 青色の線

アンケートの回答をスプレッドシートに手動で入力する代わりに、フォームを利用します。フォームでアンケートを作成し、回答を得たらすぐにスプレッドシートのファイルに送信します。スプレッドシート ファイルはアンケートにリンクされているので、新しい回答がリアルタイムで表示されます。

詳細

フォームでアンケートを作成する

アンケートを作成する手順については、フォーム スタートガイドをご覧ください。

アンケートの回答を新しいスプレッドシートに送信する

  1. フォームの [回答] タブで、その他アイコン その他 次に [回答先を選択] をクリックします。
  2. 新しいスプレッドシートを作成をクリックします。
  3. (省略可)名前を変更する場合は、新しい名前を入力します。
  4. [作成] をクリックします。

アンケートの回答を既存のスプレッドシートに送信する

  1. フォームの [回答] タブで、その他アイコン その他 次に [回答先を選択] をクリックします。
  2. [既存のスプレッドシートを選択] 次に [選択] をクリックします。
  3. スプレッドシートを選択して [選択] をクリックします。

回答先を選択

フォームからスプレッドシートを開くには、「回答をスプレッドシートに表示」アイコン スプレッドシート をクリックします。新しいウィンドウでスプレッドシートが開きます。フォームに戻るには、[フォーム] 次に [回答の概要を表示] をクリックするか、フォームのウィンドウに戻ります。

 

2

データ入力をリストで制限する 青色の線

データ入力エラーの可能性を減らすには、スプレッドシートで入力項目の選択肢を限定します。たとえば、ステータスを示す列がある場合は、「完了」、「処理中」、「未処理」などの選択肢を指定できます。指定した選択肢は、列の各セルのプルダウン リストに表示されます。

詳細
  1. Google スプレッドシートで、スプレッドシートを開きます。
  2. オプションを追加する列を選択します。
  3. [データ] > [データの入力規則] をクリックします。
  4. [条件] の横で [リストを直接指定] を選択します。
  5. 有効なオプションをカンマで区切って入力します。
  6. [セルにプルダウン リストを表示] チェックボックスがオンになっていることを確認します。
  7. [警告を表示] または [入力を拒否] を選択して、無効なオプションを入力した場合の処理を指定します。
  8. (省略可)確認メッセージを表示するには、[入力規則のヘルプテキストを表示] チェックボックスをオンにしてメッセージを入力してください。例: 有効な値を入力してください(完了 / 処理中 / 開始前)
  9. [保存] をクリックします。
  10. (省略可)選択肢を確認するには、その列の下のセルで矢印をクリックします。
On a sheet, by Criteria under Data validation, enter List of items, status choices like Done, and check the box

3

メールアドレスを検証する 青色の線

入力するデータにメールアドレスが含まれる場合は、スプレッドシートでアドレスの形式を検証することで入力エラーを減らします。

詳細
  1. Google スプレッドシートで、スプレッドシートを開きます。
  2. メールアドレスを含める列を選択します。
  3. [データ] 次に [データの入力規則] をクリックします。
  4. [条件] の横にある [テキスト] 次に [次を含む] を選択します。
  5. [次を含む] の横にあるテキスト ボックスに「@」と入力します。
  6. [警告を表示] または [入力を拒否] を選択して、無効なオプションを入力した場合の処理を指定します。
  7. (省略可)確認メッセージを表示するには、[入力規則のヘルプテキストを表示] チェックボックスをオンにしてメッセージを入力してください。例: xxx@xxx.xxx のような有効なメールアドレスを入力してください。
  8. [保存] をクリックします。
Enter Text, contains, and @ by Criteria under Data validation on a sheet

4

複数のスプレッドシートのデータを 1 つのスプレッドシートにまとめる 青色の線

データが複数のスプレッドシートに分かれている場合は、スプレッドシート間でデータの範囲をコピーできます。たとえば、ある製品の四半期ごとの販売データを、地域ごとに別々のスプレッドシートを使って追跡しているとします。四半期ごとの販売データをすべてまとめるには、各地域のスプレッドシートのデータをスプレッドシートの 1 つのファイルにコピーします。

詳細
  1. Google スプレッドシートで、スプレッドシートを開きます。
  2. 空のセルに「=IMPORTRANGE」と入力します。
  3. 以下の項目を引用符で囲み、かっこ内にカンマ区切り形式で入力します。
    • Google スプレッドシートのファイルの URL。
    • シート名(省略可)と読み込むセルの範囲。
  4. Enter キーを押します。
  5. [アクセスを許可] をクリックして、2 つのシートを紐づけます。

例:

スプレッドシート abcd123abcd123 にあるシート 1 の A1 から C10 までのセルを読み込むには、「=IMPORTRANGE("abcd123abcd123", "sheet1!A1:C10")」と入力します。

5

データを検索、更新する 青色の線

データを検索、更新するのに、時間を費やす必要はありません。スプレッドシートを使えば、テキストや数値を簡単に検索、更新できます。

詳細
  1. Google スプレッドシートでスプレッドシートを開き、[編集] 次に [検索と置換] をクリックします。

  2. [検索] に、検索するテキストまたは数値を入力します。
  3. [置換後の文字列] に、新しいデータを入力します。
  4. [検索] で、検索するシートを選択します。
  5. (省略可)検索を絞り込むには、追加のオプションを選択します。
    [大文字と小文字の区別]、[完全に一致するセルを検索]、[正規表現を使用した検索]、[数式内も検索] のオプションがあります。
  6. データの置換方法を選択します。
    • インスタンスを 1 つずつ置換するには、[検索] 次に [置換] をクリックします。
    • すべてのインスタンスを一括で置換するには、[すべて置換] をクリックします。
[ファイル] メニューに表示される [検索と置換] オプション

6

データを複数の列に分割する 青色の線

スプレッドシートでは、カンマで区切られたテキストなど、明確に定義されたデータを複数の列に分割できます。たとえば、「姓, 名」を含む 1 つの列を「姓」と「名」を含む 2 つの列に分割できます。

詳細

データを貼り付けて分割する

  1. Google スプレッドシートでスプレッドシートを開き、列に分割するデータを貼り付けます。
  2. データを貼り付けたセルの横にある書式を貼り付けアイコン 貼り付け 次に [テキストを列に分割] をクリックします。
  3. ファイルが幅固定で書式設定されている場合に区切り文字が検出されるようにするには、[自動的に検出] を選択します。

既存のデータを分割する

  1. Google スプレッドシートでファイルを開き、分割するデータが含まれている列を選択します。
  2. [データ] 次に [テキストを列に分割] をクリックします。
  3. ファイルが幅固定で書式設定されている場合に区切り文字が検出されるようにするには、[自動的に検出] を選択します。

7

行と列を入れ替える 青色の線

列のデータを行に入れ替えたり、行のデータを列に入れ替えたりする場合は、スプレッドシートの TRANSPOSE 関数を使用します。たとえば、列の見出しを行の見出しと入れ替えることができます。

詳細
  1. Google スプレッドシートで、スプレッドシートを開きます。
  2. 空のセルに「=TRANSPOSE」と入力します。
  3. かっこ内に、入れ替える行列の範囲を入力します。
  4. Enter キーを押します。

例:

列 A~E と行 1 および 2 の位置を入れ替えるには、「=TRANSPOSE(A1:E2)」と入力します。

8

重複したデータを削除する 青色の線

データの重複エラーはよくある問題であり、特にビッグデータの世界ではコストがかかる原因となり、見逃しやすくなります。スプレッドシートを使って不要な重複データを削除します。同じ値を含むセルは、値の大文字と小文字の区別、書式、数式が異なっていても、重複しているとみなされます。

詳細
  1. Google スプレッドシートで、スプレッドシートを開きます。
  2. 削除したい重複データが含まれるデータ範囲を選択します。
  3. [データ] 次に [重複を削除] をクリックします。
  4. 対象の列を指定し、データにヘッダーがあるかどうかを選択します。
  5. [重複を削除] をクリックします。
  6. ステータス ウィンドウで [OK] をクリックします。
On a sheet, click Data, then Remove duplicates. Select cells, then click Remove duplicates

9

余分なスペースを削除する青色の線

データをコピーして貼り付けるときは、余分なスペースが誤って入ってしまうことがあります。余分なスペースがあると、データ文字列を検索するときに問題が生じる可能性があります。データの先頭または末尾にある余分なスペース、データ内の余分なスペースは、スプレッドシートで削除します。

詳細
  1. Google スプレッドシートで、スプレッドシートを開きます。
  2. 削除したい余分な空白が含まれるデータ範囲を選択します。
  3. [データ] 次に [空白文字を削除] をクリックします。
    ノーブレーク スペースは削除されません。

10

キーボード ショートカットでデータをすばやく整理する 青色の線

マウスの代わりにキーボード ショートカットを使えば、すばやく作業できます。たとえば、行や列の選択、グループ化、非表示化、セル内のデータの書式設定を簡単に行うことができます。

詳細

スプレッドシート

この情報は役に立ちましたか?
改善できる点がありましたらお聞かせください。