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Visualizzare gli errori di provisioning automatico

Quando configuri il provisioning automatico per le app basate su SAML, potresti visualizzare questi errori:

Di seguito è indicato come eseguire il debug e risolvere questi errori.

Nota: se non riesci a risolvere l'errore seguendo i passaggi descritti qui, rivolgiti all'assistenza.

Errori in fase di configurazione

Errore di codice di autorizzazione

Questo errore viene visualizzato quando non è stato possibile cambiare il codice di autorizzazione con un token di aggiornamento. Ciò può verificarsi se il codice di autorizzazione era errato o se si attende troppo a lungo tra l'autorizzazione e il fare clic su Salva modifiche. L'errore dovrebbe risolversi riautorizzando e salvando le modifiche.

Messaggio di errore Risoluzione
Non è stato possibile generare il token di autorizzazione. Prova a ripetere l'autorizzazione e salva di nuovo le modifiche.

Errore di pagina non aggiornata

Gli errori di pagina non aggiornata si verificano quando la pagina del browser non è stata aggiornata e la configurazione è cambiata al di fuori della sessione del browser (in un'altra finestra del browser o da un altro utente). Di seguito sono elencati gli errori che potresti visualizzare:

Messaggio di errore Risoluzione
La pagina non è aggiornata. Configurazione del provisioning già esistente. Aggiorna la pagina per eseguire l'override della configurazione esistente.
La pagina non è aggiornata. Configurazione del provisioning non esistente. Aggiorna la pagina per eseguire l'override della configurazione esistente.
La pagina non è aggiornata. Impossibile attivare una configurazione del provisioning non completata. Aggiorna la pagina per eseguire l'override della configurazione esistente.
La pagina non è aggiornata. Impossibile eliminare una configurazione del provisioning non completata. Aggiorna la pagina per eseguire l'override della configurazione esistente.

 

Errore di pagina temporaneo

Questi errori sono transitori e in genere si risolvono quando aggiorni la pagina o ritenti l'azione dopo qualche tempo. 

Messaggio di errore Risoluzione
Impossibile recuperare la configurazione del provisioning  Aggiorna la pagina. 
Impossibile recuperare la preconfigurazione del provisioning Aggiorna la pagina. 
Impossibile recuperare lo stato del provisioning Aggiorna la pagina.
Attivazione del provisioning non riuscita Riprova ad attivare il provisioning.
Errore durante l'eliminazione della configurazione del provisioning Riprova a eliminare la configurazione.
Impossibile creare la configurazione del provisioning Crea di nuovo la configurazione del provisioning e salva le modifiche.
Impossibile aggiornare la configurazione del provisioning Aggiorna di nuovo la configurazione del provisioning e salva le modifiche.
Impossibile recuperare gli attributi personalizzati Riprova a salvare gli attributi personalizzati.
Impossibile aggiornare la mappatura degli attributi Aggiorna di nuovo la mappatura degli attributi.
Impossibile aggiornare le impostazioni di gruppo per il provisioning automatico Aggiorna di nuovo le impostazioni di gruppo.
Impossibile aggiornare la configurazione del deprovisioning Aggiorna di nuovo la configurazione del deprovisioning.
Configurazione eliminata. Non è stato possibile revocare l'accesso al client API.

Quando elimini la configurazione, revochiamo le autorizzazioni che consentono all'applicazione di accedere ai tuoi dati su Google.

Se questa operazione non riesce per qualche motivo, revoca manualmente l'accesso accedendo a "Gestisci accesso client API" nella sezione Sicurezza.

Se hai eliminato la configurazione e prevedi di impostarla di nuovo, non dovrai eseguire nessuna operazione. 

Errore durante l'aggiornamento della configurazione del provisioning Aggiorna la pagina. 
Autenticazione non riuscita Le credenziali di autenticazione (ad esempio il token di connessione) fornite nella configurazione non sono corrette. Inserisci le credenziali corrette.
L'URL dell'endpoint SCIM fornito non è valido L'endpoint di destinazione fornito non è valido. Inserisci l'URL corretto.
Errore durante l'attivazione del provisioning Sposta il dispositivo di scorrimento Provisioning automatico su Attivo
Errore durante l'eliminazione della configurazione del provisioning
  1. Fai clic su Provisioning automatico per aprire le impostazioni.
  2. In Elimina configurazione, fai clic su Elimina
Impossibile recuperare attributi dal provider Internet di destinazione
  1. Fai clic su Provisioning automatico per aprire le impostazioni.
  2. In Mappatura attributi, fai clic su Modifica.
  3. Modifica le mappature del fornitore di servizi in base alle necessità.
Impossibile recuperare schema risorsa target Verifica l'URL dell'endpoint fornito durante la configurazione del provisioning automatico e riprova a mappare gli attributi di Cloud Directory agli attributi dell'applicazione di destinazione.

Errori di runtime del provisioning automatico

Gli errori di runtime del provisioning automatico possono verificarsi a causa di problemi di accesso, autorizzazione o configurazione dell'API.

Errori di servizi interni di Google

Codice errore Descrizione e risoluzione
17003
17006
17008

Descrizione: 

Impossibile eseguire l'autenticazione con i servizi interni di Google.

Motivo

Le autorizzazioni sono state revocate da questo ID del client di provisioning degli utenti:

910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

Risoluzione: 

Assicurati che l'ID disponga delle autorizzazioni necessarie per i seguenti ambiti:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

Nella Console di amministrazione, utilizza "Gestisci accesso client API" in Sicurezza > Impostazioni avanzate per verificare che l'ID client disponga di questi ambiti o per aggiungere tali ambiti all'ID client.

17007

Descrizione:

Impossibile concedere l'accesso alle app che supportano il provisioning automatico utilizzando l'autorità di delega a livello di dominio.

Impossibile concedere l'autorità di delega a livello di dominio al servizio di provisioning automatico. Questa impostazione è fondamentale per consentire al servizio di provisioning automatico di leggere la directory Google.

Motivi:

Motivo 1: le autorizzazioni sono state revocate dall'ID client di provisioning degli utenti.

Risoluzioni:

Nella Console di amministrazione, utilizza "Gestisci accesso client API" in Sicurezza > Impostazioni avanzate per aggiungere i seguenti ID client e ambiti:

ID client:
910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

Ambiti:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

Un'altra soluzione consiste nell'eliminare l'app in questione per poi aggiungerla di nuovo.

Motivo 2: errori di sistema imprevisti

Risoluzione

Nella maggior parte dei casi, questo errore si risolve automaticamente. Tuttavia, se il problema persiste dopo alcune ore, aggiungi l'ID client e gli ambiti oppure elimina e aggiungi di nuovo l'app, come illustrato per il motivo precedente.

Errori del token di autorizzazione

Codice errore Descrizione e motivo Risoluzione
17010

Le credenziali non sono sufficienti per effettuare chiamate verso l'endpoint SCIM.

Causa: il token di autenticazione è stato revocato.

Prova a ripetere l'autorizzazione facendo clic su Provisioning automatico per aprire le impostazioni e selezionando Autorizza di nuovo.
17013

Si è verificato un errore durante il recupero del token dal tuo provider di servizi.

Causa: il token di autenticazione è stato revocato.

Se l'errore non si risolve automaticamente in breve tempo, prova a ripetere l'autorizzazione facendo clic su Provisioning automatico per aprire le Impostazioni e selezionando Autorizza di nuovo.

Errori del token di accesso

Codice errore Descrizione e motivo Risoluzione
17002
17011

Impossibile generare un token di accesso.

Motivo: al momento, alcuni servizi interni di Google non sono disponibili.

Questo errore dovrebbe risolversi automaticamente in breve tempo.
17009 L'accesso alla generazione di token dal token di aggiornamento non è riuscito. Prova a ripetere l'autorizzazione facendo clic su Provisioning automatico per aprire le impostazioni e selezionando Autorizza di nuovo.

Errori generali

Codice errore Descrizione e motivo Risoluzione
1200x

Errore interno

Questo errore dovrebbe risolversi automaticamente in breve tempo.
25001 Backend/servizio Google momentaneamente non disponibile. Configura di nuovo il provisioning automatico.
25002

Backend/Servizio Google momentaneamente non disponibile. 

Causa: l'applicazione non è installata per il cliente.

Installa l'applicazione, quindi configura di nuovo il provisioning automatico.
25005 Backend/servizio Google momentaneamente non disponibile. Questo errore dovrebbe risolversi automaticamente in breve tempo.
25016 Backend/servizio Google momentaneamente non disponibile. Configura di nuovo il provisioning automatico.
50001 Errore interno Questo errore dovrebbe risolversi automaticamente in breve tempo.
50003 Errore interno Questo errore dovrebbe risolversi automaticamente in breve tempo.
50005 È presente un gruppo eliminato nei filtri gruppo configurati. Rimuovi il gruppo eliminato dalla configurazione dell'ambito di provisioning.
50006 Errore interno Questo errore dovrebbe risolversi automaticamente in breve tempo. 

Errori a livello di risorsa

Se nella sezione Provisioning automatico nella pagina delle impostazioni dell'app SAML viene visualizzata la voce Errori, fai clic su Scarica elenco. Nel file scaricato sono elencate le azioni di creazione, eliminazione o aggiornamento non riuscite, ognuna corredata da un codice di errore e una descrizione.

Questi errori interessano solo le risorse specificate nel file. 

Codice errore Descrizione errore Risoluzione
45003

La richiesta di aggiornamento, creazione o eliminazione della risorsa non è stata accettata dalla tua applicazione basata su SCIM. Consulta i dettagli dell'errore nel file degli errori scaricato.

Possibili cause:

  1. Limite licenze superato: hai licenze per creare solo 5 utenti nella tua applicazione basata su SCIM e hai attivato il provisioning automatico per 6 utenti.
  2. Valore troppo a lungo: il valore, ad esempio l'ID email, è troppo lungo e non è accettabile per l'applicazione basata su SCIM.
  3. Devi disporre di almeno un diritto, uno dei quali deve essere l'ID profilo.
  4. Il nome utente è già esistente. Deve essere univoco in tutta l'organizzazione.
  5. Risorsa (utente) non trovata sul lato fornitore di servizi (SP).
  6. Valore ID utente SCIM non valido.
Correggi l'errore e riprova dopo avere salvato le modifiche.
45004

Si è verificato un errore tra il fornitore di servizi e Google come provider di identità. Il testo dell'errore è "Errore interno - Quota superata".

Possibili cause:

  • Un'interruzione che interessa il fornitore di servizi.
  • Il server del fornitore di servizi non è attivo.
Contatta il fornitore di servizi
45005 L'endpoint SCIM che hai configurato non è raggiungibile. Controlla l'endpoint SCIM che hai indicato nella Console di amministrazione. Correggi l'errore e riprova dopo avere salvato le modifiche.
45006

La richiesta di aggiornamento, creazione o eliminazione della risorsa non è stata formulata correttamente o non è stata accettata dall'applicazione basata su SCIM. Consulta i dettagli dell'errore nel file degli errori scaricato.

Possibile causa:

  1. Valore troppo lungo
  2. Licenze insufficienti
  3. Licenza non valida
  4. Valore diritto non esistente
Correggi l'errore e riprova dopo avere salvato le modifiche.
45016

La richiesta di aggiornamento, creazione o eliminazione della risorsa non è stata accettata dalla tua applicazione basata su SCIM perché non hai compilato un campo obbligatorio. Consulta i dettagli dell'errore nel file degli errori scaricato.

Correggi l'errore e riprova dopo avere salvato le modifiche.

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