/youtube/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
No YT-preview on Twitter (Card validator: No metatags found) 2 Recommended Answers 89 Replies 137 Upvotes
1 Recommended Answer
$0 Recommended Answers
1 Relevant Answer
$0 Relevant Answers
When I try to post links to recent Youtube video's on my Twitter, I won't get any preview-window of the video showing on my tweet. Instead, it just shows the youtube link as text which is very ugly.

When I put my link in the Twitter Card validator,  it says no metatags are found. And I cant find any information anywhere to know what is the problem and what I can do to solve this.

It's really annoying and it limits me in way of sharing my YouTube videos.

For example: This video does not give any twitter preview. 
Relevant Answer Relevant Answers (0)
All Replies (89)
Relevant Answer
addition: I know the setting for allowing embedding has to be checked, which is the case for me. but still it does not work.
marked this as an answer
Relevant Answer
Been facing the same problem for the past two days. My videos also have embedding allowed. Does anyone know how to solve this?
marked this as an answer
Relevant Answer
I have the same problem with my two most recent videos.
marked this as an answer
Relevant Answer
Me too! this is very frustrating
marked this as an answer
Relevant Answer
I'm having the same issue this week as well.
marked this as an answer
Relevant Answer
Same problem for me today
marked this as an answer
Relevant Answer
I'm having the same issue too! They can fetch the site, but no meta data
marked this as an answer
Relevant Answer
I have the same problem :(
marked this as an answer
Relevant Answer
Same issue here.
marked this as an answer
Relevant Answer
This is a twitter issue, most likely they have block many things recently. It does make an ugly post with the generic icon, even adding a custom thumbnail does not help. The image link is valid too.
marked this as an answer
Relevant Answer
Yep...having the same issue. I think this is definitely a twitter issue.
marked this as an answer
Relevant Answer
I created two new videos last night and tried to post them on Twitter and got the exact same problem. No card / preview showing in the Tweet. The Card Validator for Twitter states that it can't find any metatags.
marked this as an answer
Relevant Answer
Same problem here, very frustrating
marked this as an answer
Relevant Answer
I'm having the same problem. No card on twitter. The card validator fails to find metatags. I've tried everything including using other browsers, and clearing the cache, but no result. I've checked and all my videos have embedding allowed. Any solutions google?
marked this as an answer
Relevant Answer
Me too - I tried to click/unclick video embedding (saving each in the process) and the twitter card still will not validate. These are the exact errors I am getting:

Unable to render Card preview
INFO:  Page fetched successfully
WARN:  No metatags found
marked this as an answer
Relevant Answer
Yeah, I'm also having the same issue... I've only noticed it beginning this week with my last two videos. It says metatags either.

Weirdly, I even tried to run an older video through the validator that worked in the past, and that is now also saying it cannot render the preview and can't find any metatags, so something has changed, either with Twitter or YouTube!

It's really annoying... but for now, I'm just posting the thumbnail along with the link as a workaround.
marked this as an answer
Relevant Answer
I'm also having this issue.
marked this as an answer
Relevant Answer
Yup - as well -
marked this as an answer
Relevant Answer
جخنهاذذتاا
marked this as an answer
Relevant Answer
Same problem here and i thought it was something i was doing wrong, i had the same problem on facebook but i think i could correct now
marked this as an answer
Relevant Answer
Eu tenho o mesmo problema
marked this as an answer
Relevant Answer
Gosh I've been driving myself mad the last 5 days trying to find out why it hasnt been working. This has got to be a twitter issue and i hope to god they fix it soon. Been grinding out daily remixes and this last week has had such poor performance due to Twitter not working.
marked this as an answer
Relevant Answer
It looks like YouTube dropped twitter proprietary meta tags but kept open graph tags which are open standard. I guess Twitter finally will be forced to fix its mess.
marked this as an answer
Relevant Answer
Same problem for me. Glad to see it's not just my channel!
marked this as an answer
Relevant Answer
Same problem as well
marked this as an answer
Relevant Answer
Twitter are looking into it. I tried to reply to this yesterday with the Twitter community forum thread URL but looks like Google don't like me doing that and have removed it. It's been a problem since the 13th apparently. They can't provide hourly / ongoing updates. So let's hope they fix it soon.
marked this as an answer
Relevant Answer
This is happening to me too
marked this as an answer
Relevant Answer
I'm having this again for the second weekly upload in a row. The validator still recognises links from old videos for me but keeps on coming up with the "no metatags found" for these last 2. It is VERY frustrating.
marked this as an answer
Relevant Answer
Just adding my voice to the chorus. I'm facing the exact same issue.
marked this as an answer
Relevant Answer
Me too. I upload videos twice a week. This first started happening on Jan 16 for me, and my workflow has not changed. Sounds like YouTube is having some issues!
marked this as an answer
Relevant Answer
Also interested in knowing the answer to this, finding the same issue. Twitter validator says no meta data аvailable, but works fine elsewhere. May be a twitter issue?
marked this as an answer
Relevant Answer
Appreciate the YT team keeping me informed on Twitter. I thought it was only me with the problem. Started all of a sudden on new uploads.
marked this as an answer
Relevant Answer
Hi every1,
Everything started 7 days ago. All of a sudden YouTube links stopped showing Card preview on Twitter. I started tweeting to get help from YouTube support team and started a thread over here:
Here's what I get with Twitter Card Validator tool:

Jan. 22nd Update, YouTube card preview is back to normal. Many Thanks to both Support Teams!
marked this as an answer
Relevant Answer
The same for me. It happened suddenly, I do everything as usual but the preview does not work on Twitter. It works on Facebook, Telegram etc. though.
marked this as an answer
Relevant Answer
I have the same problem :(
marked this as an answer
Relevant Answer
Count me in as impacted too. Really glad I found this so I know it's recent and not just me! Huge thanks to the OP.
marked this as an answer
Relevant Answer
Same here. I have some videos where it works and some where it doesn't all posted in the same timeframe. Anything under 1,000 views seems to not have a preview on twitter which is kind of counterintuitive since those are the videos that need initial promotion.
marked this as an answer
Relevant Answer
Everything works properly right now.
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/youtube/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/youtube/profile/0