/youtube/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
I copied my YouTube video link and pasted on text but no preview shows up! 1 Recommended Answer 153 Replies 724 Upvotes
1 Recommended Answer
$0 Recommended Answers
1 Relevant Answer
$0 Relevant Answers
I tried pasting the URL of my YouTube video on Whatsapp and Facebook but no meta description or thumbnail shows up for any of my videos.
Relevant Answer Relevant Answers (0)
All Replies (153)
Relevant Answer
The same here, it's either a software update bug, or Idk...very annoying. Tried all fixes suggested. Didnt work
marked this as an answer
Relevant Answer
I'm having the same issue.
When I post a YouTube link on WhatsApp the link appears but no thumbnail.
marked this as an answer
Relevant Answer
Same problem here !
How can it be fixed ?
marked this as an answer
Relevant Answer
Same here. No thumbnnail when I share a link from YouTube to WhatsApp.
marked this as an answer
Relevant Answer
I am also facing the same issue from yesterday
marked this as an answer
Relevant Answer
Facing same no meta description and preview showing when copying the link of you tube and pasti g on whatsApp., please fix the issue ASAP.
marked this as an answer
Relevant Answer
I too have same problem 😔
marked this as an answer
Relevant Answer
same issues to all our thousands of tutors as well.
marked this as an answer
Relevant Answer
The same thing happens to me for the past 2/3: days (I have a Pixel 3A) and the same happens when sharing a video from the YouTube app. Is a resolution on the cards?
marked this as an answer
Relevant Answer
I'm having the same issue.
When I post a YouTube link on WhatsApp the link appears but no thumbnail. I update all apps but it's not working
marked this as an answer
Relevant Answer
same thing happened to me
marked this as an answer
Relevant Answer
Same with me... searching solution got all of you..
marked this as an answer
Relevant Answer
I also have this problem.
marked this as an answer
Relevant Answer
Same problem here!
marked this as an answer
Relevant Answer
Issue since yesterday morning
marked this as an answer
Relevant Answer
Same here also.  The cynic in me says it's a power play by Zuck?  (I haven't sent videos because without a thumbnail, it's just a link...?)
marked this as an answer
Relevant Answer
YouTube has no relation to Facebook or WhatsApp. Ask their support why it's no shown in their apps.
marked this as an answer
Relevant Answer
If I mis-type the url, by remove the last character, it will show Youtube logo... Any valid url will not show anything... NO PREVIEW !!
Tested in Whatsapp desktop and mobile apps.
marked this as an answer
Relevant Answer
Same issue here. It is working for old videos but no preview is visible for video uploaded today (even after 4 hours).
marked this as an answer
Relevant Answer
same issue on whtasapp
marked this as an answer
Relevant Answer
Yes for me too
marked this as an answer
Relevant Answer
Same here since yesterday i guess
marked this as an answer
Relevant Answer
We too have same problem. Youtube, please fix this ASAP. This is very annoying.
marked this as an answer
Relevant Answer
I am also not able to view thumbnail on whatsapp while link is pasted
marked this as an answer
Relevant Answer
Me too. Same problem
marked this as an answer
Relevant Answer
Having the same problem.
marked this as an answer
Relevant Answer
same problem this time
marked this as an answer
Relevant Answer
same issue
marked this as an answer
Relevant Answer
Same issue.
marked this as an answer
Relevant Answer
same here... no thumbnail
marked this as an answer
Relevant Answer
Same here. First noticed it 3 days ago.
marked this as an answer
Relevant Answer
Same issue here
marked this as an answer
Relevant Answer
I thought only i was facing that
marked this as an answer
Relevant Answer
Here, too. May be a bug. Is YouTube QA team already investigating this?
marked this as an answer
Relevant Answer
hello, guys i also face same issue but you can post link through whatsapp desktop on pc so your thumbnail will show thank you temprorry this is the solution only
marked this as an answer
Relevant Answer
Hi, I'm a YouTuber. I face the same trouble since 21st July. pls solve asap.
marked this as an answer
Relevant Answer
Same problem being faced
marked this as an answer
Relevant Answer
Perhaps google restricted the preview thumnail of youtube video on whatsapp
marked this as an answer
Relevant Answer
The issue is same. Tried all methods but not working
marked this as an answer
Relevant Answer
The issue is persistent irrespective of the devices, meta tags are not being rendered.
marked this as an answer
Relevant Answer
Same... whats going on???
marked this as an answer
Relevant Answer
I have a similar problem, I tried it on WhatsApp web as well as the android app.
marked this as an answer
Relevant Answer
Same here..Any solution till now..??

Weird thing is that I have uploaded a video recently may be an hour ago and it is showing thumbnail preview but some of the videos from past 2 days  dont show it..
marked this as an answer
Relevant Answer
Yep, I have the very same problem, previews from YouTube are down for a reason, idk :( please fixx
marked this as an answer
Relevant Answer
Yip same issue, WTF - across mobile and  web/browser version perhaps update issue, not cool as YT thumbnails a crucial part of how we run out communications.

Please send any fix solutions.
marked this as an answer
Relevant Answer
Same here :(
marked this as an answer
Relevant Answer
Same here (in Argentina). No thumbnnail when I share a link from YouTube or Intagram, to WhatsApp (and WhatsappWeb)
marked this as an answer
Relevant Answer
plz fix it.. as thats the feature that works for me in terms of comm at chats...
with just a link... no body know what we are trying to say..
marked this as an answer
Relevant Answer
Problem solved...at least it disappeared now.

This is what I have done: ( Last night)
1.  Backup my Whatsapp on phone. ( Settings > Chats > Chat backup )
2.  Uninstall Whatsapp ( Google Playstore > Whatsapp > Uninstall )
3.  Reinstall Whatsapp ( Google Playstore > Whatsapp > Install )

I tested it immediately last night, it wasn't working then... I left it alone.
This morning, I found it start working on my phone.
Then my Whatsapp web version also works later.
Hope this helps someone.
marked this as an answer
Relevant Answer
Same issue.
marked this as an answer
Relevant Answer
The only thing I did is...nothing but wait till the morning when I found it to be working again.
No troubleshooting, nothing.

I guess it was a Youtube issue which they resolved by this morning(23rd July 2020).
marked this as an answer
Relevant Answer
@Bill Stachys I agree, seems to be Youtube issue......which they fixed it silently.
marked this as an answer
Relevant Answer
Okay I'm not problem
marked this as an answer
Relevant Answer
Happy to me my you tube
marked this as an answer
Relevant Answer
Perhaps this is one of YouTube's way to force us open their app and not be able to skip ads.
marked this as an answer
Relevant Answer
Im also having this problem 😔
marked this as an answer
Relevant Answer
I too have the similar issue with the Preview.
My youtube Channel link does not shows its preview in any device may be since 22.7.20.

Request Some of the expert to come up with the solution As soon as possible.

Thanks.
marked this as an answer
Relevant Answer
Issue crops up again! Duh
marked this as an answer
Relevant Answer
I am having this problem too. My account is verified and I have not had this problem in the past. No metadescription or thumbnail when sharing to Facebook. It works in Slack, though.
marked this as an answer
Relevant Answer
I'm having the same issue too.
marked this as an answer
Relevant Answer
Same problem here and still no solution. :-(
marked this as an answer
Relevant Answer
So I just encountered the same problem where I posted a video link and the preview didn't show up. Tried multiple things including the debugging thing and rebooting, but nothing. Then I tried deleting the last letter in the link, it showed the YouTube dead link preview, then I retyped in the last letter back in and the preview worked. I don't know why that happens, but it did. I tried to post the link again, same issue, deleted the last letter and retyped it and link preview worked again. Just a heads up for anyone with this issue, this may be a fix.
marked this as an answer
Relevant Answer
I had the same issue but found a workaround for my devicd. Add the start of a timestamp to the url. Adding '?t' to the end of the url enabled the preview and in-app play of the YouTube video.

No preview:

Preview works:
marked this as an answer
Relevant Answer
Thanks Andrew, this worked like a charm.


marked this as an answer
Relevant Answer
Andrew You ROCK!!! 🤗
marked this as an answer
Relevant Answer
Thank you Andrew
marked this as an answer
Relevant Answer
Thanks Andrew
marked this as an answer
Relevant Answer
Thanks a mil, Andrew! This thing had been bugging me for more than an year now.
marked this as an answer
Relevant Answer
Andrew, You the KING!! Thank you 🙌🙌👊
marked this as an answer
Relevant Answer
I adds a / by accident and that displayed the thumbnail.
marked this as an answer
Relevant Answer
Thanks, Andrew!!! You are great!
marked this as an answer
Relevant Answer
Tried it Andrew. Didn't work for me :(
marked this as an answer
Relevant Answer
I had the same problem. Adding ?t also didn't work for me but other random params than t did work. So try ?y or ?m or something else. Hope this works for others too.
marked this as an answer
Relevant Answer
Solution for me. Take away the s from http address. The thumbnail showed on whatsapp.

Https didn't work 
Http did
marked this as an answer
Relevant Answer
Http vs https Did not work for me.
marked this as an answer
Relevant Answer
Same issue here. Tried the above mentioned workarounds. Happens on Android 10 and WA web.
marked this as an answer
Relevant Answer
Yeah same problem, had them for a few days now. No workarounds mentioned worked.
marked this as an answer
Relevant Answer
Same here. Nothing works. Who is responsable for this?
marked this as an answer
Relevant Answer
Use http instead of https
marked this as an answer
Relevant Answer
Thanks Andrew ...you are awesome....
marked this as an answer
Relevant Answer
adding "/"  worked for me, thanks
marked this as an answer
Relevant Answer
first of all close all apps... then... open whatsapp.... paste link.... and then
remove "s" from "https" and add "?t" in the end of the url..... and wait for logo to appear....
eg: 
Before - https://youtu.be/ikvsphDaljA
marked this as an answer
Relevant Answer
http doesn't work for me
marked this as an answer
Relevant Answer
http ?t 

doesn't work for me.
marked this as an answer
Relevant Answer
none of the workaround works, nor ?t or http. OS - Android 10. ?t=0 for some videos not all. I think they are doing this on purpose and testing something
marked this as an answer
Relevant Answer
Thanks Andrew
marked this as an answer
Relevant Answer
Same problem im facing
marked this as an answer
Relevant Answer
I tried http and it works! but this is not practical, I cant edit every Youtube link to remove the s.   It so frustrating!
marked this as an answer
Relevant Answer
Have been having the same issue on a Pixel 3 phone for the past couple of days. It seems to happen from time to time.
marked this as an answer
Relevant Answer
Same issue, Google should rectify it ASAP
marked this as an answer
Relevant Answer
Apparently it's a problem with the most recent version of Whatsapp in the app store.

So I uninstalled Whatsapp (backed up first), and then downloaded a beta version from apk mirror: https://www.apkmirror.com/apk/whatsapp-inc/whatsapp/whatsapp-2-20-206-18-release/

That worked
marked this as an answer
Relevant Answer
same problem here when I share an youtube link on whatsapp
none of the previous suggestions has worked, I've tried them all
I will just stop sharing youtube videos because no one dare to open them without the preview...
it's very anoing...
marked this as an answer
Relevant Answer
Same issue here
marked this as an answer
Relevant Answer
SAME ISSUE here!!!
marked this as an answer
Relevant Answer
Samething happens for me too.  I installed antivirus on my mobile and suspect possibly it is blocking previews.  Did not check uninstalling antivirus though.
marked this as an answer
Relevant Answer
Same here. YouTube link preview is not working in either iPhone WhatsApp and Windows-10 WhatsApp Application, what about others.
marked this as an answer
Relevant Answer
I am facing the same issue with this link 
marked this as an answer
Relevant Answer
Yes exact same issue here
marked this as an answer
Relevant Answer
I am facing this issue rn and no, the videos that have embedding disabled show a disclaimer of that when you try sharing it on Whatsapp. But this time it doesn’t show any disclaimer, it just stopped showing previews out of nowhere.
marked this as an answer
Relevant Answer
I have the same issue for all videos, and started few weeks ago. Seems a bug.
marked this as an answer
Relevant Answer
Same issue since getting pixel 5. Buggy software!
marked this as an answer
Relevant Answer
Same issue in whole day yesterday.
trying all the know how to fix not working.
just a moment ago it back to normal, the thumbnail showed as normal.
is it a Whatsapp Glitch ?
marked this as an answer
Relevant Answer
I updated my WhatsApp in my app store and it fixed it.
marked this as an answer
Relevant Answer
Thank you it worked
marked this as an answer
Relevant Answer
Yes, updating WhatsApp worked for me.
marked this as an answer
Relevant Answer
try adding '+t'
marked this as an answer
Relevant Answer
This post was in July. It is December and I am STILL having this problem! I have tried uninstalling, reinstalling, clearing cache, etc, etc. It is mostly YouTube that gives me this problem, other links don't do this. To make matters worse, my friend has the same carrier and the SAME PHONE, same links, same WhatsApp-----and they work for him, but not for me.
marked this as an answer
Relevant Answer
Having the same problem in my Galaxy Note 8. Sometimes it's showing, but most of the time it's not. It's started couple of weeks ago wheni tried to share the videos on WhatsApp. Is there any way to sort this issue out?
marked this as an answer
Relevant Answer
Same issue. 
I thought I was the only one facing it. Whose problem is this? Youtube's or WhatsApp's?
Is YouTube purposely preventing it so that Picture-in-Picture can't be used in WhatsApp? What an evil behaviour if it's true.
marked this as an answer
Relevant Answer
I have the same issue. None of the above mentioned methods worked for me. If anyone could help that will be highly appreciated.. 🙏Looks like YouTube / WhatsApp  is not at all commenting on this issue as this was the only ongoing thread I found on internet where it mentions about it .. ☹️☹️
marked this as an answer
Relevant Answer
Same here... Even I tried all the fixes possible... But no luck...
marked this as an answer
Relevant Answer
I think It's not working for everyone, Seems to be a bug.
If you really need to send with the preview, Try with the video screen shot as a photo and the link attached to it until they fix the issue.
marked this as an answer
Relevant Answer
Same issue on android WhatsApp latest update. 
Seems to be a bug faced by many users across multiple device and os combinations
Is this issue being actively worked on?
marked this as an answer
Relevant Answer
same problem here
marked this as an answer
Relevant Answer
Same here! It's kinda annoying right now... Tried all the fixes and nothing worked, sadly :(
marked this as an answer
Relevant Answer
Just got a reply from whatsapp about this issue. It's not a Google issues.
marked this as an answer
Relevant Answer
I am facing the same issue from last 3 to 4 day.... still facing the problem
marked this as an answer
Relevant Answer
I am using latest watsapp version 2.20.131, but still having same issue where YouTube link not showing preview
marked this as an answer
Relevant Answer
Any fix? 

Thanks
marked this as an answer
Relevant Answer
I GOT DISABLED AN RE ENABLED THAN THIS PROBLEM HAPPENED
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required