/webmasters/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
Couldn't fetch sitemap(s) 6 Recommended Answers 132 Replies 151 Upvotes
1 Recommended Answer
$0 Recommended Answers
1 Relevant Answer
$0 Relevant Answers
I just migrated a website from jedrenje11.joker007.net to www.jedrenjegrckaostrva.com.
It's a WordPress website.
Sitemaps are created using Yoast plugin. They load fine. However, when submitting the sitemaps to google, I get an error: "Couldn't fetch". Submitted them yesterday. For some reason, Google won't load the sitemaps.

Made all the pages from the old address 301 redirect to the new domain matching pages.

Trying to do "URL inspection" of a sitemap link (which loads fine in browser):
https://www.jedrenjegrckaostrva.com/page-sitemap.xml

I get the option to "TEST LIVE URL". Clicking it shows:

"No: 'noindex' detected in 'X-Robots-Tag' http header"

So I checked robots.txt in website's root. There was none! :) 
Made one and uploaded it:

User-agent: *
Disallow: /wp-admin-directory/

Sitemap: https://www.jedrenjegrckaostrva.com/page-sitemap.xml
Sitemap: https://www.jedrenjegrckaostrva.com/bwg_gallery-sitemap.xml
Most Relevant Answer Most Relevant Answers (0)
All Replies (132)
Most Relevant Answer
It's a travesty. A week of couldn't fetch. Why break what worked? Is this an improvement?
They get paid (and very well) to do stuff like this and leave it broken for who knows how long. 
Ridiculous company.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I faced same problem! how to fix that?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Hey folks, I am also facing same issue on google console that sitemap couldn't fetch of my website https://a1locksmithrockvillemd.com/. Can anyone suggest me what's the problems in my website?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
My problem got sorted out, as was said, by itself within several days. No sweat since it happens only once, at the start, but doesn't seam to re-appear.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I am facing the same problem my website shows couldn't fetch it has been a week now since i submitted a sitemap. Please can someone tell me if i have done this correctly i typed sitemap_index.xml after the domain and clicked on submit.

I also find it strange that another website that I have submitted successfully within 2 minutes
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I am facing the same problem my website shows couldn't fetch it has been a week now since i submitted a sitemap. Please can someone tell me if i have done this correctly i typed sitemap_index.xml after the domain and clicked on submit.

I also find it strange that another website that I have submitted successfully within 2 minutes
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I am also facing same problems. please say what should i do?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
i'm still having the same issue for more then a month! i've even tried different Sitemaps Plugins.
still can't get it fixed ! that's a big issue ! you really should do something about it.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I can confirm.
Reading in webserver access log, the sitemaps are never read!!!
From 1st of March!!!!
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same problem from last year. Sitemap work well with Bing. But couldn't working with Google :((((((
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I have to face the same problem around one month, can anyone tell me what should I do? 
marked this as an answer
Most relevant based on info available
Most Relevant Answer
same stupid problem. impossible to fetch a ne website
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same problem is faced by me too couldn't fetch data while if i open sitemap by url like pkian.tk/sitemap.xml is works fine but it always says couldn't fetch data it has been a week now.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Mine is static html website and there is wordpress inside as blog.  The site map is in the root.  Dont know why its still showing "Couldn't Fetch".  Even though it showing this message, As its a bug in the console itself how we will make sure of all the other functionalities working fine ? what are details need to take care while waiting.  Its been more than a week in this status
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I think there is bug, I am facing the same issue, since last 4 days, not moving further.

Any help Googlers!
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Im facing the same issue
marked this as an answer
Most relevant based on info available
Most Relevant Answer
The console has been displaying 'couldnt fetch' incorrectly for over a year. Googel are in no hurry to fix it. 
marked this as an answer
Most relevant based on info available
Most Relevant Answer
marked this as an answer
Most relevant based on info available
Most Relevant Answer
The MFT chokes on the x-robots-tag: noindex header. 
 
The Rich results tester is better for testing sitemaps, in my experience. 
https://search.google.com/test/rich-results?id=wgOD6Rkb_btvPPHfoI-XXg
still uses the offical Googlebot user-agent, but happily ignores x-robots-tag
... the 'View Rendered HTML' button shows it if fetched the source (as it happens not HTML!) 
 
 
I suspect the Translate is choking on the Content-Type header instead. Ie its can see it's not a HTML page. 
 
 
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I guess you're right except for my sitemaps I don't have an X-Robots-Tag set to noindex. 

I am not experiencing any problems when submitting a sitemap, even a sitemap index created for a Wordpress site. 

This one is a simple xml sitemap, not an index, but no issue.

marked this as an answer
Most relevant based on info available
Most Relevant Answer
the X-Robots-Tag has no bearing on the sitemap bot itself (blissfully ignores it) - its just the MFT test that does take note of it. 
 
Not all sitemaps get 'stuck' in Pending. It varies by sitemap. On a single site, one can be pending, the other processing fine. For many sitemaps Pending lasts seconds or minutes. 
 
... so with that sitemap you fine. Doesnt exhibit the problem. 
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Well that's what I said: I have no sitemap pending problem. Maybe it depends on the size of the sitemap, the number of urls, etc. I don't have any big sites to test.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Yes, it all very mysterious. 
 
From experience it happens with big as well as small sitemaps. 
 
Seems more likely to happen with sites that are either new, or ironically struggling with indexing. ie where the pages mentioned in the sitemap are not already indexing organically. 
 
 
marked this as an answer
Most relevant based on info available
-
Most Relevant Answer
For what it's worth: my website's indexes got fetched after about one week.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
What did you do?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Hey guys! My problem is solved! Actually, I was facing this problem because my robot.txt file was disallowed. So when I allowed it and resubmit the sitemap in webmaster the problem solved and now my sitemap is indexed.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
"So when I allowed it and resubmit the sitemap in webmaster the problem solved and now my sitemap is indexed."

This had no effect for me.

User-Agent: *
Disallow:
marked this as an answer
Most relevant based on info available
Most Relevant Answer
THere are a number of possible issues that could prevent Google actually fetching sitemap. 
 
robots.txt is only one of them. so yes, that wont always be the problem. 
 
 
Please start a new thread, with specific details of your site, to diagnose your fetching issue. 
 
 
(provided it really is a fetch issue. Just because the console says 'couldnt fetch' - it might not be true. 
 
marked this as an answer
Most relevant based on info available
Most Relevant Answer
"provided it really is a fetch issue. Just because the console says 'couldnt fetch' - it might not be true."

Can't verify it can fetch ... the old console no longer supports 'Fetch as Google' or sitemap submit.

I've seen messages about this issue dating from Oct 20, 2018 ... so ... is it not a bug? ... where is the Google response to this problem?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
You can submit a sitemap in the New Search Console, just enter its name at the top of the screen after the property name.

Fetch as Google is the same as Inspect URL.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
THe new console has 'Live Test' built into 'URL Inspection' tool, which is pretty similar. Can use 'View Tested Page' to to confirm it did fetch (ie has the XML source visible!) 
 
Well yes, there is a bug that shows 'Pending' as 'couldnt fetch'. Not seen a responce from Googel. But that doesnt mean there isnt a fetching issue!
marked this as an answer
Most relevant based on info available
Most Relevant Answer
After one submits the sitemap it says "Sitemap submitted successfully." (oh!)

URL Inspection says "This page is not in the index, but not because of an error." (well that's fair ... it's a meta page ... and it means URL Inspection is not the same as Fetch as Google, if that good fetch xlm files, I don't know).

sitemap.xml shows in a browser and W3C validator says it's fine. 

So what does one do if it doesn't submit in say two weeks?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Note its the 'Live Test' function within URL Inspection that is most like 'Fetch as Google'. 
Fetch as Google only shows you 'live' status. URL Inspection in theory can show status in index and/or the live status. 
 
... it's the Live Test function using to test Fetchability of Sitemap. Dont care what it says about Indexability not existing indexation.
 
 
You've already 'submitted' the sitemap. That is not the problem. It doubtful that Fetching is the issue, either. 
 
It's the 'processing' that is doubt. Alas there is no specific timeline. Some sitemaps may process relatively quickly, like days. Others can take months. 
 
 
 
marked this as an answer
Most relevant based on info available
Most Relevant Answer
How does one ask Google for an answer?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Can send feedback to Google with the 'Feedback' function in the cnsole itself. 
 
Rare to see them reply tho. 
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Thank you for feedback about feedback.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I have similar problem with https://www.ambar.bydgoszcz.pl/
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I have the same problem
marked this as an answer
Most relevant based on info available
Most Relevant Answer
It's been months now that this issue has been reported. Why hasn't it been fixed yet, and why hasn't there been an official announcement for this bug? It also took several weeks to get any reply from them about a reconsideration request. I've never had so many issues with the search console until after this "upgrade."
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Imagine, it case of having bigger fish to fry. In the grand scheme this a pretty minor (but still annoying) issue
marked this as an answer
Most relevant based on info available
-
Most Relevant Answer
Return info:

I see this being discussed as a bug and a problem. From my experience, like the first few replies suggested: it takes less than one week for it to get sorted out. 

And that's happened only with websites newly introduced to webmaster tools. The old ones work with no problems.

Submit a sitemap. If it doesn't work, wait a few days then try again. It has worked for me so far.

I don't see a (legit, no a black hat SEO) use scenario where waiting for a few days could be a major problem - correct me if I'm wrong, or missing something.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Sure, it may not be a priority problem, but it would be nice to at least have an official acknowledgement and to know that a fix is being worked on. When you manage websites for 50+ clients, it does become somewhat of a problem. Having to test the live URL for the sitemap, which takes 1-2 minutes just to ensure that Google can in fact fetch it, truthfully gets annoying.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
It's minor to not be able to submit your client's site to Google?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
You can try this solution https://support.google.com/webmasters/thread/3280971?hl=en&msgid=33569617

At first it will not indexing any page and start with 0 for a few days. After thst, it start to indexing. I've tried this and worked. CMIIW.
marked this as an answer
Most relevant based on info available
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/webmasters/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/webmasters/profile/0?hl=en