/webmasters/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
Couldn't fetch sitemap(s) 6 Recommended Answers 132 Replies 155 Upvotes
1 Recommended Answer
$0 Recommended Answers
1 Relevant Answer
$0 Relevant Answers
I just migrated a website from jedrenje11.joker007.net to www.jedrenjegrckaostrva.com.
It's a WordPress website.
Sitemaps are created using Yoast plugin. They load fine. However, when submitting the sitemaps to google, I get an error: "Couldn't fetch". Submitted them yesterday. For some reason, Google won't load the sitemaps.

Made all the pages from the old address 301 redirect to the new domain matching pages.

Trying to do "URL inspection" of a sitemap link (which loads fine in browser):
https://www.jedrenjegrckaostrva.com/page-sitemap.xml

I get the option to "TEST LIVE URL". Clicking it shows:

"No: 'noindex' detected in 'X-Robots-Tag' http header"

So I checked robots.txt in website's root. There was none! :) 
Made one and uploaded it:

User-agent: *
Disallow: /wp-admin-directory/

Sitemap: https://www.jedrenjegrckaostrva.com/page-sitemap.xml
Sitemap: https://www.jedrenjegrckaostrva.com/bwg_gallery-sitemap.xml
Relevant Answer Relevant Answers (0)
All Replies (132)
Relevant Answer
It's a travesty. A week of couldn't fetch. Why break what worked? Is this an improvement?
They get paid (and very well) to do stuff like this and leave it broken for who knows how long. 
Ridiculous company.
marked this as an answer
Relevant Answer
I faced same problem! how to fix that?
marked this as an answer
Relevant Answer
Hey folks, I am also facing same issue on google console that sitemap couldn't fetch of my website https://a1locksmithrockvillemd.com/. Can anyone suggest me what's the problems in my website?
marked this as an answer
Relevant Answer
My problem got sorted out, as was said, by itself within several days. No sweat since it happens only once, at the start, but doesn't seam to re-appear.
marked this as an answer
Relevant Answer
I am facing the same problem my website shows couldn't fetch it has been a week now since i submitted a sitemap. Please can someone tell me if i have done this correctly i typed sitemap_index.xml after the domain and clicked on submit.

I also find it strange that another website that I have submitted successfully within 2 minutes
marked this as an answer
Relevant Answer
I am facing the same problem my website shows couldn't fetch it has been a week now since i submitted a sitemap. Please can someone tell me if i have done this correctly i typed sitemap_index.xml after the domain and clicked on submit.

I also find it strange that another website that I have submitted successfully within 2 minutes
marked this as an answer
Relevant Answer
I am also facing same problems. please say what should i do?
marked this as an answer
Relevant Answer
i'm still having the same issue for more then a month! i've even tried different Sitemaps Plugins.
still can't get it fixed ! that's a big issue ! you really should do something about it.
marked this as an answer
Relevant Answer
I can confirm.
Reading in webserver access log, the sitemaps are never read!!!
From 1st of March!!!!
marked this as an answer
Relevant Answer
Same problem from last year. Sitemap work well with Bing. But couldn't working with Google :((((((
marked this as an answer
Relevant Answer
I have to face the same problem around one month, can anyone tell me what should I do? 
marked this as an answer
Relevant Answer
same stupid problem. impossible to fetch a ne website
marked this as an answer
Relevant Answer
Same problem is faced by me too couldn't fetch data while if i open sitemap by url like pkian.tk/sitemap.xml is works fine but it always says couldn't fetch data it has been a week now.
marked this as an answer
Relevant Answer
Mine is static html website and there is wordpress inside as blog.  The site map is in the root.  Dont know why its still showing "Couldn't Fetch".  Even though it showing this message, As its a bug in the console itself how we will make sure of all the other functionalities working fine ? what are details need to take care while waiting.  Its been more than a week in this status
marked this as an answer
Relevant Answer
I think there is bug, I am facing the same issue, since last 4 days, not moving further.

Any help Googlers!
marked this as an answer
Relevant Answer
Im facing the same issue
marked this as an answer
Relevant Answer
The console has been displaying 'couldnt fetch' incorrectly for over a year. Googel are in no hurry to fix it. 
marked this as an answer
Relevant Answer
marked this as an answer
Relevant Answer
The MFT chokes on the x-robots-tag: noindex header. 
 
The Rich results tester is better for testing sitemaps, in my experience. 
https://search.google.com/test/rich-results?id=wgOD6Rkb_btvPPHfoI-XXg
still uses the offical Googlebot user-agent, but happily ignores x-robots-tag
... the 'View Rendered HTML' button shows it if fetched the source (as it happens not HTML!) 
 
 
I suspect the Translate is choking on the Content-Type header instead. Ie its can see it's not a HTML page. 
 
 
marked this as an answer
Relevant Answer
I guess you're right except for my sitemaps I don't have an X-Robots-Tag set to noindex. 

I am not experiencing any problems when submitting a sitemap, even a sitemap index created for a Wordpress site. 

This one is a simple xml sitemap, not an index, but no issue.

marked this as an answer
Relevant Answer
the X-Robots-Tag has no bearing on the sitemap bot itself (blissfully ignores it) - its just the MFT test that does take note of it. 
 
Not all sitemaps get 'stuck' in Pending. It varies by sitemap. On a single site, one can be pending, the other processing fine. For many sitemaps Pending lasts seconds or minutes. 
 
... so with that sitemap you fine. Doesnt exhibit the problem. 
marked this as an answer
Relevant Answer
Well that's what I said: I have no sitemap pending problem. Maybe it depends on the size of the sitemap, the number of urls, etc. I don't have any big sites to test.
marked this as an answer
Relevant Answer
Yes, it all very mysterious. 
 
From experience it happens with big as well as small sitemaps. 
 
Seems more likely to happen with sites that are either new, or ironically struggling with indexing. ie where the pages mentioned in the sitemap are not already indexing organically. 
 
 
marked this as an answer
Relevant Answer
For what it's worth: my website's indexes got fetched after about one week.
marked this as an answer
Relevant Answer
What did you do?
marked this as an answer
Relevant Answer
You can try this solution https://support.google.com/webmasters/thread/3280971?hl=en&msgid=33569617

At first it will not indexing any page and start with 0 for a few days. After thst, it start to indexing. I've tried this and worked. CMIIW.
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/webmasters/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/webmasters/profile/0