Работа с настройками

Настройки Google Web Designer можно задать, выбрав в верхнем меню пункт Правка > Настройки. Чтобы переключаться между группами настроек, нажимайте соответствующие вкладки слева.

Чтобы вернуть значения по умолчанию для любой группы настроек, необходимо нажать кнопку Восстановить настройки по умолчанию.

Общие настройки

Общие

Настройка Описание

При запуске открывать последний файл

Если этот флажок установлен, при запуске Google Web Designer будет пропускать окно приветствия и открывать последний документ, который вы недавно использовали.

Запускать приложение с сохраненными настройками инструмента выделения Если этот флажок установлен, настройки инструмента выделения будут сохраняться при каждом перезапуске Google Web Designer.

Мои шаблоны

Настройка Описание

Расположение

Нажав кнопку Обзор , можно выбрать на компьютере папку, в которой будут сохраняться файлы пользовательских шаблонов. Папка должна находиться на подключенном диске (быть доступной через файловую систему компьютера).

Если изменить этот путь, существующие пользовательские шаблоны пропадут со вкладки "Мои шаблоны" в галерее. Чтобы восстановить их, необходимо вручную переместить файлы в новую папку.

Использовать путь по умолчанию

Нажав кнопку Использовать расположение по умолчанию Refresh icon, можно изменить расположение на исходный путь.

Настройки по умолчанию при создании файла

Настройка Описание

Тип объявления

Позволяет выбрать тип объявления по умолчанию для новых документов.

Рекламная платформа

Позволяет выбрать рекламную платформу объявления по умолчанию для новых документов. Доступные варианты зависят от выбранного типа объявления по умолчанию.

Настройки режима просмотра макета

В настройках режима просмотра макета можно задать значения по умолчанию для параметров меню "Вид", которые применяются к новым документам. В некоторых перечисленных ниже случаях эти значения изменяют настройки текущего документа.

Режим просмотра макета

Настройка Описание

Контур

Позволяет выбрать значение для контуров элементов в рабочей области документа:

  • Ярлык. Для всех невыбранных элементов будут отображаться пунктирные границы с ярлыками, которые содержат типы и идентификаторы элементов.
  • Только контуры. Для всех невыбранных элементов будут отображаться пунктирные границы.
  • Отключить. Невыбранные элементы будут отображаться без границ и ярлыков.
Это универсальная настройка, которая применяется как к новым, так и к открытым документам Google Web Designer. Она соответствует значениям, выбранным в меню "Вид".

Показать линейки

Если этот флажок установлен, по умолчанию будут отображаться горизонтальная и вертикальная линейки.

Эта настройка по умолчанию применяется к новым документам и к документам, для которых не заданы соответствующие настройки. Она не переопределяет значения, выбранные в меню "Вид" для отдельных документов.

Сетка и привязка

Настройка Описание

Привязка

Если этот флажок установлен, объекты будут располагаться вдоль одних и тех же горизонтальных или вертикальных линий. Можно выбрать элементы, относительно которых выполнять привязку:

  • Привязать к сетке: привязка к 3D-сетке.
  • Привязывать к объектам: привязка к краям, углам и центральным точкам других объектов, расположенных в рабочей области.
  • Выравнивание с привязкой: выравнивание выбранного объекта относительно других.
  • Выравнивание по направляющим: выравнивание объекта относительно направляющих.
Это универсальная настройка, которая применяется как к новым, так и к открытым документам Google Web Designer. Она соответствует значениям, выбранным в меню "Вид".

3D-сетка

Если этот флажок установлен, отобразится сетка для плоскости, которая ближе всего к параллельной плоскости относительно направления взгляда.

Эта настройка по умолчанию применяется к новым документам и к документам, для которых не заданы соответствующие настройки. Она не переопределяет значения, выбранные в меню "Вид" для отдельных документов.

  • Шаг сетки. Позволяет задать расстояние между линиями сетки (от 10 до 1000 пикселей). Значение по умолчанию – 50 пикселей. Указанный шаг применяется ко всем документам, в которых отображается 3D-сетка.

Структура

Настройка Описание

Упорядочить элементы в порядке DOM

Если этот флажок установлен, элементы в структурном редакторе отображаются в порядке DOM (объектная модель документа). Если флажок снят, элементы отображаются в том же порядке, что и слои в расширенном режиме временной шкалы.

Направляющие

Настройка Описание

Цвет

Позволяет установить цвет направляющих.

Настройки режима просмотра кода

С помощью этих настроек можно управлять поведением и внешним видом режима просмотра кода.

Настройка Описание

Цветовая тема

Позволяет выбрать цветовую тему для рабочей области и выделения синтаксиса в режиме просмотра кода. Для каждой темы доступен предварительный просмотр.

Параметры форматирования

Параметры форматирования кода применяются, когда вы открываете файл или переходите в режим просмотра кода, внеся изменения в режиме просмотра макета. Вы можете просмотреть эти параметры в примере кода, который отображается выше в диалоговом окне "Настройки".

Настройка Описание

Отделять скобки

Если этот флажок установлен, текст в скобках отделяется пробелами.

Добавлять пустую строку в конце файла

Если этот флажок установлен, в конце файла добавляется символ новой строки.

Каждый селектор CSS с новой строки

Если этот флажок установлен и для правила CSS указано несколько селекторов, между ними добавляется символ новой строки.

Каждое правило CSS с новой строки

Если этот флажок установлен, между правилами CSS добавляется символ новой строки.

Размер отступа

Позволяет установить количество пробелов и знаков табуляции в одном отступе.

Стиль фигурных скобок

Выберите способ форматирования фигурных скобок в JavaScript.

  • Сворачивать: скобки отображаются на той же строке.
  • Разворачивать: скобки отображаются с новой строки.
  • Разворачивать в конце: закрывающие скобки отображаются с новой строки.

Отступы для тегов скриптов и стилей

Позволяет выбрать, как делать отступы для кода внутри тегов <script> и <style>.

  • Обычные: отступы для кода начинаются на один уровень ниже тегов.
  • Сохранять: отступы для кода начинаются на уровне тегов.
  • Разделять: код начинается без отступов.

Стиль переносимых атрибутов

Позволяет выбрать, когда переносить атрибуты в тегах HTML на новую строку.

  • Автоматический: атрибуты автоматически переносятся на новую строку, когда длина текста превышает длину строки.
  • Принудительно: каждый атрибут отображается с новой строки.

Принудительный перенос строк

Если этот флажок установлен, строки, которые превышают указанную длину, будут принудительно переноситься.

Настройки редактора

Настройки редактора в режиме просмотра кода вступают в силу сразу после сохранения.

Настройка Описание

Привязка клавиш

Позволяет выбрать привязку клавиш, чтобы использовать соответствующие функции текстового редактора.

  • По умолчанию
  • Emacs
  • Sublime
  • Vim

Показывать пробелы в конце строк

Если этот флажок установлен, будут видны пробелы в конце строк.

Выделять совпадения с выбранным текстом

Если этот флажок установлен, будет выделяться код, совпадающий с текстом, который выделен или на который наведен курсор.

Отступы

Если этот флажок установлен, новые строки вставляются автоматически.

Закрывать скобки и кавычки автоматически

Если этот флажок установлен, при вводе открывающей скобки автоматически вставляется закрывающая.

Автоматически закрывать теги

Если этот флажок установлен, при вводе открывающего HTML-тега автоматически вставляется закрывающий.

Автозаполнение Если этот флажок установлен, при вводе автоматически отображаются подсказки автозаполнения.

Использовать пробелы вместо символа табуляции

Если этот флажок установлен, символы табуляции автоматически преобразуются в пробелы.

Показать мини-карту Если этот флажок установлен, будет отображаться мини-карта документа.

Рекламная платформа

Настройка Описание
Запомнить масштаб Если этот флажок установлен, масштаб режима просмотра кода сохраняется при перезапуске Google Web Designer.

Расширенные настройки

Расширенные настройки применяются ко всему приложению. Некоторые из них вступают в силу только после перезапуска Google Web Designer.

Ведение журналов

Настройка Описание

Включить ведение подробного журнала

Если этот флажок установлен, будут создаваться подробные журналы в следующих папках на компьютере:

  • Windows: C:\Users\<username>\AppData\Local\Google\Google Web Designer\logs
  • Mac: /Users/<username>/Library/Application Support/Google/Web Designer/logs
  • Linux: ~/.local/share/google-web-designer/logs/

Включайте эту настройку на время, только чтобы устранить неполадки.

Эти изменения вступают в силу после перезапуска Google Web Designer.

Масштаб приложения

Настройка Описание

Переопределить масштаб по умолчанию

Если этот флажок установлен, можно вручную изменять масштаб, автоматически определенный Google Web Designer для вашего монитора.

  • Процент масштаба: задайте процентное значение от 70% до 200%.

Эти изменения вступают в силу после перезапуска Google Web Designer.

Эта информация оказалась полезной?
Как можно улучшить эту статью?