/wearos/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
4/8/19
Google Maps on my new TicWatch Pro is not showing the map 1 Recommended Answer 115 Replies 114 Upvotes
1 Recommended Answer
$0 Recommended Answers
Last edited 4/8/19
The map is not showing in Google Maps apps. I can see '+', '-', 'Around here' button and compass arrow but nothing else. In the Navigation mode I can see green round bar with the street name but again no map. 
I tried resetting and pairing my watch 3 times. I cleared all data of 'Google Wear OS' app, 'Google Play' and 'Play services' and rebooted my phone. I also reinstalled 'Google Maps' multiple time. Still no luck. At the time I start 'Google Maps' I do have wi-fi connected and my watch launches the 'Maps' app on the phone. All permissions configured correctly or at least I accepted all permission requests.

What else can I try to get it working?

All Replies (115)
4/8/19
Hi Ron,
 
Does it make any difference if you disable Wi-Fi on your watch? That should force the watch to pull in data from your phone's internet connection. 
 
Is the watch otherwise able to do internet-based things (like displaying information about the weather)?
 
Cheers,
John
marked this as an answer
Helpful?
-
4/8/19
Hi John, to test, I enabled the Airplane mode and re-enabled Bluetooth. Verified that Wi-Fi is 'off' in the settings. I tested that I could get to the Internet (I guess through the phone) by asking Google Assistant to get some info for which it would need to go to the internet and it worked. Then I launched 'Maps' and still map is not showing. Normally, my watch is connected to my home internet and so far it got re-connected every time it needed to get online.
marked this as an answer
Helpful?
4/8/19
Hey Ron,

Thanks for checking. Just curious - what phone are you using?

Any change if you instead disable Bluetooth on your phone (thus forcing the watch to get to the internet over its Wi-Fi connection)?

Also, can you tell me what version of the Maps app you have on your watch as well as on your phone?

Thanks!
John
marked this as an answer
Helpful?
-
4/8/19
Hi John, to try what you asked I disabled Bluetooth and connected my watch to the guest Wi-Fi at work. I verified that I could get to the internet by replying to a text message. The map is still not showing but "Around here" tab is as previously showing the places around where I am. 

The "Google maps" app on the watch is  v10.13.1 updated on Mar 31. The version on the phone is the same. 

My phone is Moto X4 running Android 9 build PPW29.69-39-1. 

Thank you for helping me with the issue.

Ron
marked this as an answer
Helpful?
5/25/19
Same here with ticwatch E and a nexus 6 on android pie . Sadly adding this issue to delayed calls notification and and missed calls notification that clears the one on phone , I feel like I bought a dumb watch more than a smart . My g watch on wear 1.5 was great for maps , I remember I was getting a vibration and a notification when I had to turn. Google s testing on updates start to feel embrassing , they add 1 feature and broke 5 ... Great
marked this as an answer
Helpful?
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/wearos/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/wearos/profile/0?hl=en