/wearos/community
This content is likely not relevant anymore. Try searching or browse recent questions.
-
9/5/17
Cannot add my google account to my watch - occurred after the 2.0 update 0 Recommended Answers 47 Replies 36 Me Too's
1 Recommended Answer
$0 Recommended Answers
My watch is new (ordered Aug 18) and was working fine until the 2.0 update (I'm assuming). I cannot get my google account on my watch.
 
When I go to accounts - add google account, I'm asked to add a google account to my watch and in order to do that, I have to copy an account from my phone. Thus lies the problem. When I tap add (account) from phone, the colorful circle turns and turns and never finds my google account. The error on my phone is "account not available at this time." I've restarted both phone and watch, reset the watch more times than I'd like to remember, disconnected the watch, unpaired the Bluetooth, uninstalled android wear, cleared cache and data, taken down all security, and even tried turning off WiFi. This issue has not been resolved for 2.5 weeks.
All Replies (47)
9/8/17
I suggest you Factory Data Reset the watch.

let us know

best,
f
marked this as an answer
Helpful?
9/9/17
This was a known bug that was supposed to have been fixed.  Try Frank's suggestion, but if your problem persists let us know.
marked this as an answer
Helpful?
10/3/17
I have the exact same problem and have reset the watch countless times. As a first time AW user, this is beyond frustrating and not the best for roping in new people.
marked this as an answer
Helpful?
10/3/17
Agreed.  This is definitely a big issue.  You can try the following steps, but there is no guarantee that it will help.

On the watch:
Settings, Unpair with phone. 
Do not set up the watch yet.

On the phone:
In Android Wear use the Disconnect... option.
In Android Wear, use Settings, Device settings and touch the watch name, Touch FORGET WATCH.
Settings, Bluetooth. If you still see the watch, touch Forget... the watch so it no longer appears in the list of paired devices.
Settings, Device, Apps, select Google Play Services. Clear cache and Clear data. Uninstall updates.
Settings, Device, Apps, select Google App. Clear cache and Clear data. Also Uninstall updates.
Settings, Device, Apps, select Android Wear. Clear cache and Clear data. Also Uninstall updates.
Play Store, Apps, My apps, touch the Update all button. 

Let all updates complete. This may take several hours. The best thing to do is to put your phone on its charger overnight, with the phone having a steady WiFi Internet connection. Double check the next morning by going to My Apps again.
Reboot.

Now set up the watch as if you had just unboxed it.
marked this as an answer
Helpful?
10/3/17
Nishad
marked this as an answer
Helpful?
10/4/17
Having the exact same problem, I did some testing. My wife has the exact same phone (LG_G5). We sync our Google accounts so our calendars match. That being said I was able to add my Google account to my watch from her phone perfectly but not from my phone. The ONLY difference between our phones is that mine is rooted and hers is not. Is yours?
marked this as an answer
Helpful?
-
10/4/17
Do not factory reset, do not forget watch, do not clear data or anything else because it won't help. After digging, the only thing fixes this is adding the developer menu to the watch then enable ADB debugging. To add developer menu - settings, about, tap build number 7 times. Then go back out to find the developer menu. I can only speak for the Asus Zenwatch 2, 1.63.
marked this as an answer
Helpful?
Be sure that your watch is connected to the same WiFi network that your phone before you try to add a Google account
marked this as an answer
Helpful?
10/25/17
I tried doing all the above. nothing works. I feel like the watch is A dummy without google store.
What else can I do?
marked this as an answer
Helpful?
In my particular case, I've never even been interested in how to root the phone. I do not even install the application facilities outside of Google play. Google play is the only store of applications that I have installed on my phone. I do not even have games installed on my phone because it is a very important tool to put at risk.
Last edited 2 days ago
marked this as an answer
Helpful?
This question is locked and replying has been disabled.
Create Reply
Discard post? You will lose what you have written so far.
Write a reply
Minimum 10 characters
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/wearos/threads
false
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update me-too.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/wearos/profile/0?hl=en