Eligible devices for use with Google Wallet

Non-NFC devices

The Google Wallet app is available to US users on devices that meet the following system requirements:

  • Android 2.3 (Gingerbread) or higher.
  • iOS 6 or higher.

 

NFC devices

Tap and pay functionality is available in the US, and requires an NFC-enabled Android device running 4.4 (KitKat) or higher on any carrier network. Not all devices running KitKat will support tap and pay. Here is a list of devices running KitKat that cannot be used for tap and pay:

  • Samsung Galaxy Note III
  • Evo 4G LTE
  • Nexus 7 (2012)

At this time, tap and pay functionality is only supported on US-based devices. For example, a Samsung Galaxy Note II that uses an international SIM card will not work with Google Wallet tap and pay.

Beginning on April 14, 2014, devices with Android versions older than Android 4.4 (KitKat) will no longer be supported for tap and pay.