This content is likely not relevant anymore. Try searching or browse recent questions.
Why can't Google Voice access my microphone? All permissions are on. 0 Recommended Answers 28 Replies 83 Upvotes
1 Recommended Answer
$0 Recommended Answers
Last edited 7/15/19
Allowed access to mic, logged-in and out, restarted comp,  Microphone works for ALL other applications: Skype, Viber, etc...Each time I make a call in Google voice, I am asked to allow permissions and I do. See screenshot, there is not option to test. Why won't this work!!!???
All Replies (28)
Hi Eric Siegel
Did you check your Chrome permissions?
Using Chrome, go to https://voice.google.com
To the left of the URL, you should see a lock
Click on it.
Make sure you allow Microphone.
The setting should then appear under:  chrome://settings/content/microphone
You should see under the "Allow" list: https://voice.google.com:443
marked this as an answer
Hi, thank you for your support.Yes, chrome permissions allow microphone. I followed the steps you explained, and it still does not work. Please see screenshot 1 attached. Additionally, confirming "https://voice.google.com:443" is under the "Allow" list in chrome settings://settings/content/microphone (Please see screenshot 2). What else could it be? Thanks again. 
Last edited 12/28/18
marked this as an answer
I have reinstalled Google voice, checked permissions 100 times. What is going on!!!!!???? Thank you for your help.
marked this as an answer
Hi Eric:
First:  I'm sorry you're having difficulties, but this is a volunteer-run, user-to-user help forum.  We're volunteers, not Google Employees, so we can't necessarily answer questions immediately.  There's no direct customer support from Google for Google Voice.
Now:  my best guess is that you have some sort of ad-blocking, javascript blocking, cookie blocking or an extension that is interfering.  Note that you must NOT block WebRTC, nor block cookies from Google.
If you are using Google Chrome Browser, go to Settings-->Advanced-->Content Settings-->Cookies.  There should be sections to block cookies from specific sites or domains, and to allow cookies from same.
Scroll down to the "Allow" section, and click the Add button.  Add this:  [*.]google.com
Clear your browser's cache, cookies and history.  Close and re-open the browser
DISable all privacy-related extensions, toolbars, etc.  Try going back to the Google Voice settings page and repeat the test of your audio devices.  If you have more than one audio device for the microphone and/or speaker (i.e. you have the internal speaker and mic on a laptop, and you have a Bluetooth or hardwired headset), then click the triangle to reveal the drop-down list and select the correct device(s).
Does it work now?  If so, and if you did have any privacy-related extensions, etc, then you can enable them one at a time, to find the culprit.
marked this as an answer
Hi Bluescat,
Grateful for your support, and happy 2019!
Thank you also for explaining this is a volunteer-run help forum – I was not aware.
I followed your instructions:
1) Adding [*.]google.com to the “Allow” section within Settings-->Advanced-->Content Settings-->Cookies.
2) Cleared browser cache, cookies and history
3) Close and re-opened browser
4) DISable all privacy-related extensions, toolbars, etc. (I ensured I have none).
5) Go back to the Google Voice settings page and repeat the test of your audio devices.
*Note: Each time I pull-up G Voice settings, I grant permission to access my microphone (please see screenshot 1). However, I am not allowed the option to “test for audio device” (please see screenshot 2).  
Thus, concluding a solution is not yet evident. I tried these processes numerous times. Does you have more ideas? Again, I am able to make calls, and hear the other person. Who can solve this puzzle?

With respect, Eric
marked this as an answer
Hi Eric Siegel
There is no test button, when on that screen it automatically enables and should pick up any sound.
  • To test your microphone, start talking. No audio More changes to Audio Audio and indicates the volume of sound produced.
marked this as an answer
Hi baldybeardedguy,
Thank you for the support. I am on the settings screen. When I speak, the audio does not change from   to   Again, all permissions are granted; and Skype, Viber, other applications that use my microphone work.
Any ideas? Is there a way to reset? Maybe download and reinstall G Voice?
Grateful for your support,
marked this as an answer
Hi Eric Siegel
What version of Chrome are you using?
I am on Macbook 10.14.2 running Chrome Version 71.0.3578.98 (Official Build) (64-bit) and it is working.
Chrome should only ever ask you once to allow use for your Microphone.  If it asks each time, then something is not allowing the permissions to persist.
Here are my settings that may effect Microphone.
Under Cookies: chrome://settings/content/cookies
Allow sites to save and read cookie data (recommended) is ON
Keep local data only until you quit your browser is OFF
Block third-party cookies - Prevent third-party websites from saving and reading cookie data is ON
Under Microphone: chrome://settings/content/microphone
Ask before accessing (recommended) is ON
and https://voice.google.com:443is listed as allowed
Go to chrome://extensions/ , disable all of them (for testing, can enable once it works)
Go to chrome://flags/ and reset to default.
Also, what happens when you go to https://test.webrtc.org/
marked this as an answer
I'm with Baldy.  This is being caused by something on your computer that is wiping out the cookies and/or disabling HTML5 or WebRTC.  It's not being caused by anything wrong with Google Voice.

You must see a red dot with a red circle around it, when you are on the Google Voice settings page, https://voice.google.com/settings  This indicates that there is an active audio session running, and your microphone is enabled.

If you don't see it, you have a browser-realated issue as listed above.

marked this as an answer
This reply is no longer available.
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Unable to lock
Unable to unlock
Unable to pin
Unable to unpin
Unable to mark
Reported as off topic