This content is likely not relevant anymore. Try searching or browse recent questions.
"Always use my phone to place calls" option not visible 0 Recommended Answers 11 Replies 0 Upvotes
1 Recommended Answer
$0 Recommended Answers
Last edited 10/14/19

I recently got a new Google Voice number for a G Suite Account, and I am having issues getting my PC to call my phone for outgoing calls. I have reinstalled GV on my iphone and linked/unlinked my cell number with the account, selecting/unselecting Do not Disturb etc. I just don't get the option "Always use my phone to place calls" that I usually see. When I make calls on the web client it only tries to do it on my pc's microphone. On IOS once I turned off the WIFI calling option it will use my phones dialer instead of GV's which is nice but I mostly initiate my calls on PC and have it call my cell phone. I took screenshots of my device to show that I dont have the option to edit anything involving outgoing calls. 

I can make an outgoing call on the iOS app but thats much slower than having my PC call my phone. What can I do?

All Replies (11)
Hi Richard Pawly:  thanks for posting in the Google Voice Community forum.
There is no option to "always use my phone to place calls" on a PC or on the iOS app. It only applies to Android phones.
Aside from that, your described use case doesn't make sense.  Why would you call your own mobile phone number from a PC?
The calling methods that Google Voice is designed to use are:
  1. From a desktop/laptop computer's web browser, either directly, using the browser's built-in VoIP client with a microphone and speaker or headset.
  2. From a desktop/laptop computer's web browser, having it first call one of your linked phone numbers, then bridging the call to your desired party's number.
  3. From the iOS or Android Google Voice apps, using VoIP over WiFi or LTE data
  4. From the iOS or Android Google Voice apps, having it call through the phone's mobile carrier number.
Since you don't have any linked phone numbers, you have no carrier number to use for calling.  Add your mobile phone as a linked number.
For more information, please read the help pages:  https://support.google.com/voice/#topic=1708123
marked this as an answer
HI Bluescat,

I look at data on my PC before I call a client but I don't need to be stuck to my pc so I like being able to take the call on my mobile device and walk around. Its absolutely faster to do it on the web app then it is to search for the contact on my app and call from there. The option has always shown on PC for me until today. I have been using GV for over 3 years so I would definitely know if the option was there or not previously. There are tons of web client screenshots from other unrelated questions that show it just fine.

I have a linked number on the account as I get incoming calls on it just fine. It is weird that it doesn't show as a linked number. If I remove the ios app as a device then it shows as a linked number. On the iOS app itself it shows as a linked number all the time. Attached a couple more screenshots as options. 

What is strange is the difference between my G suite account vs a regular gmail account when it comes to the outgoing call options. I dont have a 2nd linked number to play around with but notice the 
difference in help/directions.

This screenshot is from a regular gmail account on the web client.

This screenshot is from a my current gsuite account on the web client

In either case the text underneath Outgoing calls clearly implies the ability to have it call my phone instead of using my microphone and its definitely a tool I have been using daily for the past three years on both G Suite and non G Suite GV accounts...
Last edited 10/15/19
marked this as an answer
I forgot to add, in my first reply (which I probably confused you with, since you said you were using G Suite, and so that's what I addressed), that the original consumer version of Google Voice, and the new G Suite version, have different features and settings on their desktop user interfaces (UIs).

There is an option on the desktop consumer Google Voice UI, to "Always use my phone to place calls", but it may not appear on the G Suite (paid) version of Google Voice.  The screenshot below is from the consumer (free) version:

Also note, to answer your other issue in your original post's screenshot:  when you link a smartphone, running the mobile Google Voice app, the device will be listed in the "My devices" section, but it will not be redundantly listed in the "Linked numbers" section.  The latter section only displays dumb phones (landlines and mobile phones with out the app).  However, this does not prevent you from using that number in the "call my phone" method (but again, only on the consumer offering).

I suggest a better approach:  use your computer to make calls over VoIP, and for your "walk and talk" preference (which I often do, myself), use a headset.   You can use either a Bluetooth headset or a professional-quality DECT cordless headset.  These calls will have excellent call quality, and you won't be holding your cell phone up to your head for long periods of time, which isn't a very healthy thing to do.

I use Plantronics Bluetooth headsets, and Jabra DECT headsets.  For example, see:

They are relatively expensive, but "you get what you pay for", in terms of professional-sounding audio, and superior wireless range.

Another alternative is to use a Poly VVX-x50 series IP phone, which is certified to work with Google Voice for G Suite, and has Poly's best-in-class speakerphone technology.
marked this as an answer
Yeah I tested my linked number back on my regular consumer account and was able to. For reference I was using this G Suite account until July or so but it ended up with restrictions because it wasnt a paid license. My company just paid for a bunch of licenses so I switched back to my G Suite to have added functionality... and now im here more restricted then I was previously. 

I already use a bluetooth headset for my phone, the issue is having to be in bluetooth range of my PC. And just period this has been a workflow I have been using for years now on. It seems ridiculous that they removed that option for G Suite accounts recently. Its not like I can't use my mobile carrier when I call via the iOS app so why would that be an option for the free version only???
marked this as an answer
I don't know what Bluetooth headset you use, but the one I linked will work up to about 100 meters from the Bluetooth adapter in the computer, and the DECT models will work up to about a half a block away.

Sorry, but this forum supports only the consumer version of Google Voice.  If there is a feature you wish was included on the G Suite version, please provide feedback to G Suite.
marked this as an answer
Yeah I use a Voyager but thanks. Clearly im looking to restore functionality I have had in both versions for years and dont have access to. Also since the text under Outgoing Calls is the same for the G Suite it was never intended to not have the ability to place calls on your phone instead of the web but they removed it for whatever technicality made it not work.

I am sure you know it obvious that a paid product should have all the options of a free product and then additional products. Very frustrating to switch back to my G Suite account and tell 300+ contacts a new number just to make my workflow worse with no real benefit. Thanks for troubleshooting with me so I could realize it was just Google downscaling Voice again and nothing I did
marked this as an answer
Sorry, but I just have to point out that the mindset of "I always did it this way, and I insist on continuing to do it that way" is understandable, since people are resistant to change.  But PSTN telephony is rapidly becoming obsolete, and Google's emphasis in the G Suite offering is VoIP-centric.  The new infrastructure is optimized for high-quality VoIP calling, and that is where the industry is focusing its investments.

Google Voice for G Suite's business-focused demographic is assumed to have sufficient budget to invest in business-class equipment.  Sooner or later, it'll be time to get on board with current technology.
marked this as an answer
You actually dont "just have" to, but I can see its a compulsion you cant afford to resist in most of your community posts. I use VOIP plenty but I am available on call for hundreds of clients 60 hours a week. If you dont understand the utility involved in the features lost that I am frustrated with, then you can just kindly ignore that and focus on the actual support. Your superior attitude is very annoying to read and I was already expecting it when I saw it was you responding. Some food for thought.
marked this as an answer
Hi Richard! If it makes you feel any better, I understand  completely.  I was searching high and low today to see if anyone else was having the same issue and you spelled it out precisely.  Unfortunately, looks like it is not an option in G-Suite (to choose "always have your phone place calls").  The good news is that I can finally stop looking for what I thought I was doing wrong (or was missing)!
marked this as an answer
Hello Richard I too was looking for the convenience of dialing from the computer--not out of compunction or a resistance to change--but because it is my call record--and when I dial from the phone, the record does not show in the computer log that I use for accountability and records. 
I do not like that without the head-set the caller would hear any background noise in the room. (Not professional) I also dislike the restriction of the headset. I would like to see the G suit include all the options of the free version that I had just 3 days ago with the free version.
marked this as an answer
I agree as well. Personally I am finding that half of the people I am calling "through the computer" are not being able to hear me because of static. That is why I always sent them to my phone. It is taking way longer to search the contact list on my phone now and is very frustrating. The paid version should absolutely include the option to "always ring my phone"
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Unable to lock
Unable to unlock
Unable to pin
Unable to unpin
Unable to mark
Reported as off topic