Starting September 1, 2021, classic Sites will not be viewable by others. Learn how to convert to new Sites today.

/sites/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
Can't get site to show up in any web search engine
0
I have seen all the other posts that can't get their google site to show up in any of the search engines.  I am having the same frustrating problem.  This is my website:

I've tried all the suggestions in those posts (setup analytics, requesting search console crawl, checked publish settings, and references to my site on other websites).  I've waited more than a few weeks after requesting a crawl.  My website has been public for more than 6 months and has a lot of non-embedded content.  It was recreated from my old google site never had a problem showing up when I do a web search (and still does).  I suspect that it is a google site problem since this google site doesn't show up in any web search engine.  I don't know what else to do to fix this problem.  I hope someone can help me.
Details
Pinned
Locked
Latest Update Latest Updates (0)
Relevant Answer Relevant Answers (0)
All Replies (23)
Relevant Answer
We’ll have an article on that topic soon. In the meantime, browse other articles on Support Center - YSSF.ML
marked this as an answer
Relevant Answer
The same problem as Mr. Kenneth. New URLs of my Google site after changing to new Site form can not be indexed despite submitting many times for months. 
Moreover, my new Google Site: https://sites.google.com/view/industrialparks-vn/home after submitting URLs for many times weeks to weeks, it is not indexed and appeared on Google search.
Could you please share us how to fix it.
We appreciate your help.
marked this as an answer
Relevant Answer
Although this is the help forum for Google Sites, in order to contact the best experts relating to Google indexing and search issues, I recommend that you ask this question in the Google Webmasters help forum where the indexing and search experts hang out

In the meantime, if you haven't already, try this:

Add to Search Console  - new Google Sites

Once you get your site added/verified in the Search Console, you can Ask Google to Recrawl Your Site using the "Use the URL Inspection tool" option.
marked this as an answer
Relevant Answer
marked this as an answer
Relevant Answer
As i have mentioned, I've seen and tried all of these suggestions already and they have not fixed this problem.  I am not a novice at this stuff so I'm sure I followed them as described.  Evidently I am not the only one who has this problem so I'm thinking this is a legitimate issue.
marked this as an answer
Relevant Answer
Yes this is the same problem I am having.

There is no adequate explanation that publishing a site from classic to new sites requires custom domain resetting.

The implication is that if you select use existing domains to publish to new sites that means the custom domain of the old site.

Also what happens to all the google search results that were directed to the classic site that no longer works.
marked this as an answer
Relevant Answer
@Ade Norton 1931
Yes this is the same problem I am having.
You've posted this on about 4 threads now and you're not having an issue: your custom domain is working!  See: https://support.google.com/sites/thread/123637753
marked this as an answer
Relevant Answer
It started working about an hour ago.
marked this as an answer
Relevant Answer
@Ade Norton 1931:
I don't believe I have the same issue as you are.  I'm using different URL's for my old site vs my new site.  My old site is found when doing a web search as opposed to my new site which is not.
marked this as an answer
Relevant Answer
Removing the page from the navigation will do nothing to help remove the page from search. The only way to remove a page from search is to delete it or set the entire site to not be indexed. When you converted to new Sites you made a new duplicate site, you didn't replace the old site (my suggestion of publishing to the original address would have done exactly that). Since you published to a new address you didn't do anything to remove the old content and it still exists and Google Search knows it's still there and will continue to index it.

Clearly you didn't remove all duplicate content from the old site as I found it in Google Search. 

It appears that you won't accept this is why it's happening, which is fine, but what will happen is Google is beginning the process of deleting all classic Sites then your site really well be gone and unavailable to search and will be removed from the index. Maybe after December when all classic Sites are deleted then tool start to see better indexing of your new Site. Even if you deleted your old site now (or simply restrict it from being indexed) it may still take weeks/months for Google Search to remove it from the index.
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/sites/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Removed from Updates
Marked as Recommended Answer
Marked as Update
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
Known Issue
Fixed
Marked Fixed
Unmarked Fixed
Unable to mark fixed
Unable to unmark fixed
/profile/0
false
Search
Clear search
Close search
Google apps
Main menu
Search Help Center
true
70
false