/pixelphone/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
4/11/19
my pixel 2 xl suddenly stopped charging using the original charger. only charges when i use a USBC-USBA cable. Tried cleaning the USB C port but no luck. 2 Recommended Answers 178 Replies 277 Upvotes
1 Recommended Answer
$0 Recommended Answers
Last edited 4/12/19
  • I tried cleaning using the business card solution shared in this forum but it still does not work. 
  • When i connect it to my laptop using a usbc to usbA cable, the phone auto powers down then continues charging.
  • the original charger works fine with other phones
  • I bought the phone from an authorized distributor of Google in Europe so the phone was never sold retail by google directly
  • it is still under warranty given it is just a few months since i bought it
All Replies (178)
4/12/19
Hi Evans. If you have no access to another Google charger/cable, it would be best to contact Google Support to report this problem and discuss your options.

There's a Reddit thread HERE on this subject.

Penny
Last edited 4/12/19
marked this as an answer
Helpful?
5/2/19
My year-old Pixel 2 XL just did this same thing last night. Would not charge via the original OEM charger, and when I plugged in an aftermarket charger, the phone turned off on its own but seemed to charge. After a restart, all chargers are working again, so it seems like it's a software-related issue?
marked this as an answer
Helpful?
5/2/19
Hi Debbie. I've seen nothing to suggest that the issue is software-related but please leave on-device feedback (settings > about 'phone) to draw it to the attention of the development team. You won't receive a personal response unless the team requires further information but all such feedback is noted, appreciated and used to improve performance.
 
Thank you.
 
Penny
marked this as an answer
Helpful?
5/2/19
My phone has been doing literally the exact same thing for a day now. Even worse because this phone was an RMA after my previous pixel's rear camera died. Really hope this is just software related
marked this as an answer
Helpful?
1 day
Same issue here. Pixel 2 XL purchased in April 2018. OEM charger not being recognized. Phone powers off when plugging in 3rd party A to C charger, but does accept charge. I just have to power it back on each time. USB-C google earbuds also not being recognized, and they have also powered off the device a few times when plugged in. Lol what a mess.
marked this as an answer
Helpful?
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/pixelphone/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/pixelphone/profile/0?hl=en