This content is likely not relevant anymore. Try searching or browse recent questions.
Camera has non-linear temporal image distortion and focus instability 1 Recommended Answer 16 Replies 27 Upvotes
1 Recommended Answer
$0 Recommended Answers
Starting a few months after purchase (and continuing now for a couple of months), my pixel 3 rear-facing camera has shown non-linear distortions in the image that flicker in and out, along with very poor focus stability.  Pictures are worth a thousand words:

The first is a still image which needs to be viewed with Motion On.  Notice that the image is generally still, but on the left side there is a non-linear distortion of the image that comes and goes.  I see this effect quite frequently in my photos and on the screen while framing a photo.

The second is a video where I am panning back and forth a bit.  You can see the focus jumping in and out at high frequency and hints of the image non-linear distortion.

I don't see these problems with the front-facing camera.
All Replies (16)
I'm seeing the same sort of behaviour, as shown in these motion photos: https://photos.app.goo.gl/Kx5T7cBXdbgVETLQ9

I thought it started after the February or March updates. I purchased the Pixel 3 in November and had no such issues for the first few months.
marked this as an answer
The same here. I bought my phone in december '18 and it worked like a charm. However, after the february update it messes with the camera stability when filming something. Also, it keeps focussing when taking pictures and especially the left side of pictures are always blurry. (Yes, I did wipe clean the camera ;))

I checked the front facing camera and that camera doesn't give any problems.
marked this as an answer
Hi,  I'm noticing same issue. It appeared after I quit beta program with Android Q Beta 2 and restored official Android version. Since that moment my rear camera is shaking in video and photo mode. I tried safe boot, clear cache and reboot the device twice. Don't you have still fix for that ?
Last edited 4/25/19
marked this as an answer
Update to my other post... If I switch the UI from "Small" to "Default" and clear the camera's data, the issue is pretty much eliminated, it only occurs periodically on QPP6.
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Unable to lock
Unable to unlock
Unable to pin
Unable to unpin
Unable to mark
Reported as off topic