/pixelphone/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
Pixel XL 1 - Bluetooth LE not working on Android Pie 9 2 Recommended Answers 21 Replies 23 Upvotes
1 Update
$0 Updates
1 Recommended Answer
$0 Recommended Answers
1 Relevant Answer
$0 Relevant Answers
2
Ever since the update to Android Pie 9, I have not been able to sync my Fitbit Versa or use my Bluetooth Media Button. These are the only two Bluetooth LE devices I currently have. Every other Bluetooth device I have works fine, car, headphones, speakers, gamepads, mice and keyboards.

Is there anything being done to fix this? I am worried since I can't upgrade for a while yet and need my Pixel 1 to keep working fine for a while.

Steps I've taken:

1- Remove and reinstall Fitbit App. 
2- Remove both the Versa and Media button from Bluetooth
3- Reset Bluetooth and Wifi settings
4- Wipe phone through factory reset settings
5- Wipe phone and flash latest factory image via adb

Currently, my Pixel 1 is on the latest official build but these two Bluetooth LE devices still do not work.
Relevant Answer Relevant Answers (0)
All Replies (21)
Relevant Answer
Thanks for your reply. No sorry I haven't tried to downgrade to Oreo. I don't think I would want to as it would put me pretty far back on security updates.

Having said that, there is some evidence that this works for others over on Reddit. Just don't want to be stuck on Oreo. Other than the Bluetooth LE issues, Android Pie is awesome.
marked this as an answer
Relevant Answer
Yeah, I wouldn't want to to run on 8.1 permanently - I just mentioned it as an additional troubleshooting step. If we can confirm that Bluetooth LE works fine after rolling back to 8.1 but breaks (again) after upgrading to 9 then we can perhaps escalate this for the developers to look into. 

On that note, if you could share links to the Reddit threads I can pass those up the chain as well.
marked this as an answer
Relevant Answer
Sorry for the long wait but my Fitbit still isn't syncing reliably. But I think this is a Fitbit problem now since my other Bluetooth LE Device the Satchi Media Button is working fine and reliably now ever since the April Build.
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/pixelphone/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Removed from Updates
Marked as Recommended Answer
Marked as Update
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
Known Issue
Fixed
Marked Fixed
Unmarked Fixed
Unable to mark fixed
Unable to unmark fixed
/pixelphone/profile/0