/pixelphone/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
9/5/19
Android 10 update on Pixel 2 XL breaks WiFi 2 Recommended Answers 421 Replies 591 Upvotes
1 Recommended Answer
$0 Recommended Answers
Android 10 update on Pixel 2 XL caused a WiFi issue where all wifi networks report "Connected, no internet access."

Tried to connect in Safe Mode to eliminate apps and antivirus (NOD32 ESET) from being a culprit...no change. I'm on Google Fiber with a google fiber router and I wondered if that had something to do with it. Reset router twice. Rebooted phone multiple times. Wiped network settings and restarted.  Tried an alternate router (but same WAN). Set MAC to fixed device mode. Toggled airplane mode on and off. Flushed DNS.

Resolution:  Factory Reset  :(

Further discussion: I am wondering if ESET had something to do with it as it had no permissions for device location and was flagging all my home networks as an "open" or "public" wifi hotspot. This error occurred immediately after update to Android 10, and after factory wipe. Changing location permission to allow fixed it. Consider uninstalling it BEFORE updating the OS....
All Replies (421)
9/6/19
Hi.
Same problem here. After almost a year with Pie with no issues at all with wifi, I keep losing connection with my router after being marked as "wifi with no internet connection" for a while. Sometimes I do have internet connection, but it breaks eventually after some time.
I have no antivirus installed (no ESET either) and I have uninstalled any wifi managing aplication. Any other ideas?
marked this as an answer
Helpful?
9/6/19
similar issues Bluetooth playback is choppy and my WiFi keeps dropping to no signal even though I'm sitting next to my router. everything worked perfect on 9, ten is so broken that I'm using up my Google fi data... please fix
Last edited 9/6/19
marked this as an answer
Helpful?
9/6/19
I am having similar issues with my Pixel 2 XL since I upgraded to Android 10. It's the only device in the house that's having WiFi issues. It keeps switching between WiFi and LTE. At times it's showing that I am connected but no internet connection. It's really annoying. Am literally 2 meters away from the modem.
marked this as an answer
Helpful?
2 hr
I've never been able to specify 2.4ghz vs 5ghz on my Pixel 2 XL. It just sees my network and won't differentiate between channels.
marked this as an answer
Helpful?
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/pixelphone/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/pixelphone/profile/0?hl=en