Expert - Google Employee
Orrin - Community Manager

Bluetooth issues on Android 8.0 Oreo

Hey All,

Some of you have been reporting Bluetooth issues after accepting the latest OTA update, Android 8.0 Oreo. We'd like to get some additional information so we can look into this more.

If you are experiencing issues since the 8.0 update, please include the following info (depending on where your particular issue falls):

  • Year/make/model of your car 
  • Issue/symptoms
  • Brand of headphones
  • Issue/symptoms
Bluetooth Speakers
  • Speaker brand
  • Issue/symptoms
Feel free to include any other relevant information as well. I am going to start compiling patterns and I'll be reaching out to many of you privately for bug reports.

EDIT 11/3 - Please only post an update here if you are on the Android 8.1 beta. For those of you still on 8.0, please see the "Best Answer" post below, as it is still applicable. Thanks!


Community content may not be verified or up-to-date.
Recommended Answer
Was this answer helpful?
How can we improve it?
All Replies (974)
Gerald Mauser
Gerald Mauser
Have a 2017 Toyota Tacoma, media content is not properly displaying/not displaying at all on the display of the vehicle. It displayed properly before updating to 8.0. Trying to fast forward works then stops the music. Worked perfect on Nougat... Using a Verizon Pixel XL..
Jim Vastola
Jim Vastola
I have a 2014 BMW i3.  BT working fine for both phone and music/nav,  all stopped after O upgrade.  Shows paired, no audio passes.
BT did not work before and does not work with Oreo. It wont turn on and in the few cases that it turns on, it shut down inmediatly Its not an issue of specific devices.
Peter Kuterna
Peter Kuterna
I have a BMW 3GT from 2014.

Bluetooth audio streaming used to work with my Nexus 6P and Android N. From the first developer preview this broke and I was hoping that the final release would have solved this. But it didn't.

In most of the cases it didn't show anything on the display without any audio, but the song was actually playing on the phone as the time in the progress bar was moving on. The scenario to have it working for a few seconds was: unpair device from car audio, reboot phone, start car audio, pair again and play some music with e.g. Play Music. You could then hear audio for a few seconds and then it stopped. I had the impression that it was rather the connection that was failing as my device disappeared from the car's display. It then came back, but without any audio.

Now, this morning I got it working when pairing again with my car audio. But in developer options I selected the 44.1kHz sample rate. I don't know it this setting is preserved when connecting again, because when I check again in developer options the system default is again selected.
Google user
Google user
Pixel Oreo Final

2017 BMW M140 - Phone pairs ok.  Launch spotify or google play music and select Pixel on the cars media source setting.  Nothing appears on the screen (no track listing).  Track select skip back and forward works as I see the tracks changing on the phone.  No audio playing from cars speakers.  If I make a phone call using the cars handsfree the person on the other end can hear me ok, but I can't hear them from the cars speaker.  It's using the phones speaker instead.  If they call me, everything is fine.  I can hear them through the cars speakers and their name comes up on the display

Bose QC35 Wireless headphones - Phone pairs ok.  Play music from spotify or google play music.  Audio stops randomly every 5-20 seconds.  The audio is like lost for a millisecond and then comes back.

This all worked ok on 7 nougat but not on 8 oreo.  These problems were present on all of the 8 betas.
968 MORE
Rahul Tiwari
Rahul Tiwari
Updated to 8.1 on 5 dec
On 14 dec car bluetooth stopped working. unpaired/forgot/re-added done and still issue
Car bluetooth is not working. Songs/google map audio not working but..but...incoming call audio is working fine.
double checked the music app/google map audio is one.


Some community members might have badges that indicate their identity or level of participation in a community.

Expert - Google Employee — Googler guides and community managers
Expert - Community Specialist — Google partners who share their expertise
Expert - Top Contributor — Some of the most knowledgeable and active forum participants
Expert - Top Contributor (Mentor) — Experienced Top Contributors who provide help and advice to Rising Stars, help forum newbies, and anyone interested in learning more about the Top Contributor Program
Expert - Top Contributor (Alumni) — Past Top Contributors
Expert - Rising Star — Up-and-comers who are newer to the forums and/or developing their product knowledge
Community content may not be verified or up-to-date.


Member levels indicate a user's level of participation in a forum. The greater the participation, the higher the level. Everyone starts at level 1 and can rise to level 10. These activities can increase your level in a forum:

  • Post an answer.
  • Having your answer selected as the best answer.
  • Having your post rated as helpful.
  • Vote up a post.
  • Correctly mark a topic or post as abuse.

Having a post marked and removed as abuse will slow a user's advance in levels.

View profile in forum?

To view this member's profile, you need to leave the current Help page.

Report abuse in forum?

This comment originated in the Google Product Forum. To report abuse, you need to leave the current Help page.

Reply in forum?

This comment originated in the Google Product Forum. To reply, you need to leave the current Help page.