/pixelphone/community?hl=en
/pixelphone/community?hl=en
5/10/18
Original Poster
Andrey H.

All system backups are lost after upgrading to Android P Beta and back to Oreo

Hi, I'm using Google Pixel 2 XL and this is the scenario how I lost all my Android backups (yes, it's that terrible):

1. I was on Oreo 8.1 latest patch from May.
2. I had all Backup options enabled under Settings -> Backup (the right place to do it). "Backup to Google drive" switch was ON. Backups were staying enabled for several weeks prior to upgrade to Android P and I swear all items were backed up recently. However, I did not check the Backup folder on my Google Drive before the upgrade to Android P.
3. I opted-in for Android P Beta, installed it, played for one day, and then opted-out and reverted to Oreo 8.1, thus all phone data was wiped out. I did not change anything related to Backups in Android P.
4. During initial setup of Oreo 8.1 I logged in into my account and, shockingly, I was notified that there are no backups for my account!
5. I double checked the Backup folder on my Google Drive and indeed, it was empty, except a single WhatsApp backup which I did manually from the app itself. No Pixel phone backups there!

So, what happened, where is my backup made from Oreo 8.1 before I upgraded to Android P?
Did I hit some terrible bug?

Thanks in advance!


Community content may not be verified or up-to-date. Learn more.
Recommended Answer
Was this answer helpful?
How can we improve it?
All Replies (39)
Brian Fitzpatrick.
5/10/18
Brian Fitzpatrick.
Hi Andrey,

This is purely speculation on my behalf, but I'm thinking that this might be what happened. Your older backups might have expired. When you upgraded to Android P, your current backup upgrades along with your device. Backups from a higher version of Android cannot be used to restore a phone running a lower version of Android so therefore your backup was not compatible.

Checking my own account just now, I have a single backup listed for my Pixel running Android P Beta dated after I installed the beta. If I was to downgrade to 8.1, that backup would not be usable and therefore I would have no available backups for this device.
5/10/18
Original Poster
Andrey H.
Hi Brian,

I was thinking about the same, but Android P Beta instructions put it clearly "Be sure to back up your Android phone before installing beta software". What's the reason for this backup then?
From the other side, why don't I see any backup files on Google Drive created by Android P?

I actually have another hypothesis which I need to double check - what if backup file is silently erased if during phone initial setup user selects "Setup phone as new"?. This is actually what I did when installing Oreo after Android P, because I just wanted to restore from backup later.
Dmitry Ishutinov
5/10/18
Dmitry Ishutinov
I have some problems with lose backup in my Google Pixel 2. I lose my backup when i am install android P and after downgrade to last OS Android Oreo 8.1... Now in my phone not working ALL backups, i see one message "Waiting to backup". Maybe need make report with this CRITICAL BUG. How to restore my lose backup to my Pixel 2?
5/10/18
Original Poster
Andrey H.
Hi Dmitry,

     It's a different issue that "Waiting to backup" message is shown for a long time and phone doesn't start the backup. I'm currently experiencing the same issue with first backup taking long time to happen. Just need to wait a couple of hours, maybe a day. And make sure phone is plugged into charged for a longer time.
Dmitry Ishutinov
5/10/18
Dmitry Ishutinov

Hi, Andrey. I am waiting already 18 hours, but my pixel 2 not create new backup in Google Drive, and i see only message "Waiting to backup".
33 MORE
Sacha Obado
8/1/18
Sacha Obado
This happened to me as well after unlocking my boot loader on Oreo 8.1.0 the phone was reset. So after it booting and bringing up the initial setup i proceeded to log in to my account and low and be hold it said there were no backups found. I check my google drive backup folder and there were no backups yet a few weeks earlier i was able to do the same after a factory reset and login and restore my backup. What could have happened in between then and now? This is really puzzling. I am using an Android One Device running Oreo 8.1.o the Xiaomi Mi A1
 
This question is locked and replying has been disabled. Still have questions? Ask the Help Community.

Badges

Some community members might have badges that indicate their identity or level of participation in a community.

 
Google Employee — Google product team members and community managers
 
Community Specialist — Google partners who help ensure the quality of community content
 
Platinum Product Expert — Community members with advanced product knowledge who help other Google users and Product Experts
 
Gold Product Expert — Community members with in-depth product knowledge who help other Google users by answering questions
 
Silver Product Expert — Community members with intermediate product knowledge who help other Google users by answering questions
 
Product Expert Alumni — Former Product Experts who are no longer members of the program
Community content may not be verified or up-to-date. Learn more.

Levels

Member levels indicate a user's level of participation in a forum. The greater the participation, the higher the level. Everyone starts at level 1 and can rise to level 10. These activities can increase your level in a forum:

  • Post an answer.
  • Having your answer selected as the best answer.
  • Having your post rated as helpful.
  • Vote up a post.
  • Correctly mark a topic or post as abuse.

Having a post marked and removed as abuse will slow a user's advance in levels.

View profile in forum?

To view this member's profile, you need to leave the current Help page.

Report abuse in forum?

This comment originated in the Google Product Forum. To report abuse, you need to leave the current Help page.

Reply in forum?

This comment originated in the Google Product Forum. To reply, you need to leave the current Help page.