/pixelbook/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
4/13/19
Pixelbook won't power on 1 Recommended Answer 13 Replies 19 Upvotes
1 Recommended Answer
$0 Recommended Answers
Last edited 4/13/19
My Pixelbook prompted me to restart for an update. I did and now it won't turn on. Refresh + Power and Escape + Refresh + Power don't do anything. The LEDs by the USB ports don't light up when the charger is plugged in - and the charger works, tried with a different charger, too. It's out of warranty and Google support is telling me to take it to uBreakIFix. Looks like it's bricked, but I thought I'd ask here.
All Replies (13)
4/13/19
What did Support have you try before telling you to bring it to uBreakIFix?
 
The detailed history of your Pixelbook is critically important, if anyone is expected to try to help you.
 
Was your Pixelbook in Developer mode, or had you attempted to modify it in any way before the failure? Has anything happened like spilling liquid on it, or dropping it? Details like that are critical before wasting time suggesting things to try.
marked this as an answer
Helpful?
-
4/13/19
The device was/is in developer mode. I've installed both Android and Linux apps on it. I was asked to try Power + Refresh and Power + Escape + Refresh. I was also asked to try a different charger and leave it plugged in for 10+ minutes, and then try the start routines again. I've kept it plugged in for more than 24 hours - same result. I was asked to provide serial number verification and invoices - my current Pixelbook is a replacement device (refurb) for my original one, which developed a screen issue and had to be replaced. No liquid has been spilled on the device, nor has it been dropped or otherwise abused or misused.
Last edited 4/13/19
marked this as an answer
Helpful?
4/13/19
That's unfortunate about developer mode. Things can be done, or happen, there that make normal troubleshooting steps ineffective. Linux and Android runs fine in Protected mode.
 
Sounds like the Support Agent went through all the normal steps.
 
Please let us know what UbreakIFix does.
marked this as an answer
Helpful?
-
4/13/19
"Things happen in developer mode" - you say that in your capacity of? Could you elaborate? Let's say I didn't say it's in dev mode - what would you have suggested? Whatever happens in dev mode, it can hardly be blamed for not even charging.
marked this as an answer
Helpful?
18 hr
The pixel Chromebook is a piece of crap. Get a black screen and nothing makes it come back.
marked this as an answer
Helpful?
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/pixelbook/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/pixelbook/profile/0?hl=en