Edit photos in Picasa

Picasa provides a variety of fixes and effects so that you can improve photos or create something unique.

Basic fixes

To make simple edits, click Basic fixes .

  • Crop: Frames or cuts parts of a photo.
  • Straighten: Straightens photos taken with an off-kilter camera.
  • Red eye: Corrects red eyes.
  • Auto-contrast: Sets brightness and contrast to optimal levels.
  • Auto-colour: Removes colour cast and restores balance.
  • Text: Adds or edits text.
  • Fill light: Adds light to the foreground of photos.
  • Undo and redo: Deletes or restores changes.
  • Retouch: Removes blemishes and improves photo quality.
  • I'm feeling lucky: Adjusts the photo's colour and contrast.

Use the sliders to adjust the colour and lighting aspects of your photo. To use this tool, click Tuning .

Basic and advanced effects

To sharpen, tint and do more with your photos, click Basic effects .

Use the next two tabs to add more filters and effects.

Rotate or flip images

Rotate images

Use "Rotate" to turn your photos by 90 degree increments. To use, click Rotate or.

Flip images

To flip an image, use these keyboard shortcuts:

  • Horizontally: Ctrl+Shift-H
  • Vertically: Ctrl +Shift-V
Resize photos

There are several different ways of resizing photos.

Resize by exporting

  1. Select the photos to be resized.
  2. Click Export.
  3. In "Resize to", adjust the size slider.

Resize by emailing

If you're sending pictures by email, you can reduce the size so that they won't be too large. To change the size of photos emailed from Picasa:

  1. Click Tools > Options (Windows) or Picasa > Preferences (Mac).
  2. Select Email.
  3. Use the slider and button to set the size for emailing single and multiple photos.
  4. Click OK.

Resize by uploading to Picasa Web Albums

You can resize your images when you upload images from Picasa.

Add watermarks to photos

You can protect your images by adding a watermark to your photos. To add a watermark:

During export

  1. Select the photos to be exported.
  2. In the photo tray, click Export.
  3. Tick Add a watermark.
  4. In the watermark box, enter your watermark text.
  5. Click OK.

While uploading

  1. Before you upload, click Tools > Options (Windows) or Picasa > Preferences (Mac).
  2. Select Google Photos.
  3. Tick "Add a watermark for all uploads".
  4. In the watermark box, enter your watermark text.
  5. Click OK.

Picasa preserves your original photo. When you save your edits, Picasa creates a new version of the photo with your edits.

Selecting multiple photos

You can apply an action to selected photos at the same time as you add them to the photo tray.

  • Press and hold Ctrl (Command on Mac) while selecting multiple photos.
  • To select all photos in a folder or album, click Edit > Select all or Ctrl+A (Command+A on Mac).
  • To keep your selected photos in the photo tray, use Hold.
  • To remove all photos from the photo tray, click Clear.

Side-by-side editing

To compare 2 photos side by side:

  1. Double-click a photo.
  2. Above the photo, choose how you want to compare photos:
    • A|B: Compare two different photos. To select the photo to be compared, click the second photo and choose from the carousel at the top.
    • A|A: Compare edits to the same photo or view the original as you apply edits.
  3. To edit, click the photo.

You can also swap your view from side by side to above and below.

Saving photos

When you save your photo, its location on your hard drive may change.

Find your original photo

Picasa creates a copy of your photo with all edits and moves the original to a hidden subfolder called '.picasaoriginals'.

  • Use Save to disk when you edit multiple photos included in an album.
  • Use File > Save for individual pictures (or for a group of pictures that you've selected).
Keep your original photo in its current folder

You can make a copy of a photo and save it wherever you want.

  • To create edited copies of a large number of pictures, export your photos.
  • Use File > Save a copy to export a copy of the photo with all edits into the same folder. The new version will have "-1" added to its original name.
  • To specify the filename and location, use File > Save as.

Photos are saved as JPEG files.

Was this article helpful?