Plug-ins do not appear in Lightroom after installing

My plug-ins do not appear in Lightroom after installing. How do I fix this?

Occasionally, after running a Nik Collection installer, the software may not be installed correctly in Adobe Lightroom 3 or Lightroom 4. This seems to occur because the “Store Presets with Catalog” option in Lightroom's Preferences is checked. This option is in Edit > Preferences > Presets OR Lightroom > Preferences > Presets. Un-checking this box will make all of the plug-ins appear in the Photo > Edit In menu.

If the filters do not appear in Lightroom then a manual installation may be necessary. To manually install one of the Nik Collection products after the installer has been run, please do the following:

1. Ensure all image editing applications such as Photoshop and Lightroom are closed.
2. Re-run the Nik Collection product for Lightroom installer again, making sure that you've uninstalled all previous versions, and ensure the default install location is used (C:\Program Files\Google\Nik Collection OR Macintosh HD | Applications | Nik Collection).
3. Open Lightroom again and look to see if the Nik Collection product is now installed under Photo > Edit In> [name of product]. If it does not appear to be installed,please continue to step 4.
4. While Lightroom is still open, click Edit> Preferences OR Lightroom > Preferences.
5. Click on the "External Editing" tab at the top of preferences.
6. Midway down on the right click on the "Choose" button and locate the Nik Collection application file for your product. Typically it can be found at either, C:\Program Files\Google\Nik Collection\Viveza 2\Viveza 2.exe, OR Macintosh HD |Applications | Nik Collection | Viveza 2 | Viveza 2. For other products, replace Viveza 2 with the appropriate product.
7. Once located, select the program or application file as indicated above and click "Choose".
8. Set the file format to "TIFF", Color Space to sRGB (or the one of your choice), Bit Depth to 16-bit, Resolution to 240, and Compress to None.
9. Under Preset click the drop down selector and choose, "Save Current Settings as New Preset" from the list.
10. Type in the name of the plug-in such as"Viveza 2" and click Create.

You may add another plug-in by going back and following steps 6 - 10 again, otherwise close preferences by clicking OK. The plug-in(s) you added should now be accessible.

Please note, you do NOT want to do this with HDR Efex Pro 2. It is handled a different way than the other plug-ins. HDR Efex Pro 2 is accessible in Lightroom under File>Export with Preset.