/nexus/?hl=en
1/7/15
Original Poster
ramesh1986

Nexus 7 2013 - Fastboot stuck on Erase Userdata while restoring Factory Image



Hello Experts,

Problem: My Nexus 7 (2013) recently got cranky and wouldn't boot up properly. ..sometimes hanged on screen lock or once screen password is unlocked, the homepage was stuck, really slow and finally it went to erasing screen -- infinitely for 2 days (yea... 2 days I kept the charge up...under the impression its going to reboot with factory reset). Something was definitely wrong :( all of a sudden (clueless)

Note: My 1yr warranty just expired in Nov end.


1st Hickup: I decided to do the conventional Recovery to Factory Settings via the inbuilt bootloader screen (Power + Volume Down) > once I select the Recovery mode from 4 options - It was STUCK on the GOOGLE logo.. the 'Android logo with No Commond' screen never popped up.

Thats, when I came across this post "/nexus/forum/AAAANseOu18K76e41v__HE". - where people had similar booting issues and stuck on Google screen.
Was following the instructions on "How To Flash Your Nexus With A Factory Image" pdf... and had everything setup -- including the android studio ... sdk - platform tools ... usb drivers were upto date ... factory image was ready !


2nd Hickup: While following the fastboot - the device with exact serial number was detected successfully... was able to reboot to bootloader via command prompt.
while trying to unlock oem via fastboot -- I am stuck on the "<bootloader> erasing userdata...." for about more than 30 mins... (seems like back to the same problem -- unable to erase)

<enclosed the screenshot of my tab and the command prompt -- where they were stuck>
.
Can I unplug the tab from PC ... don't want to interrupt the flash process ... btw haven't flashed or done anything yet !

What do I do now ??? Really need the expert advice here to get me back on track -- am NOT willing to give up on my Nexus (which is a beauty).
Please guide me through - at the earliest !

Thanks,
Ramesh
Community content may not be verified or up-to-date. Learn more.
Recommended Answer
Was this answer helpful?
How can we improve it?
All Replies (682)
Daniel_S.
1/7/15
Daniel_S.
Yes, the N7-2013 is great when it works correctly. I was not so lucky in my attempts to own one when it came out and gave up on it.

When I factory-imaged my N7-2012 from 4.4.4 to 5.0.2 this afternoon, I had to do so completely manually because the loose USB port lost connection at some point during the system image update.

I would reboot the bootloader, then do "fastboot erase userdata" and all of the other steps individually, partition by partition, image by image. If erasing still fails, then I have no idea what else to try.
Techno Bill
1/7/15
Techno Bill
Ramesh: On your N7 screen picture where it asks if you want to unlock the bootloader with YES highlighted. Did you in fact tap yes to allow it to proceed?
 
If ypu don't the fastboot oem unlock command on the pc will hang waiting for you to either say yes or no.
 
Cheers
Bill
1/7/15
Original Poster
ramesh1986
Bill,

I did hit the power button upon pointing the selection to 'YES' on unlock bootloader -- only then the unlocking bootloader & erasing userdata scripts started running !
But both the nexus unlock confirmation screen & command prompt.

Will try to execute the erase userdata command separately (as pointed out by Daniel in the previous post) ... hopefully that turns out well !

Thanks for your observations btw !

1/8/15
Original Poster
ramesh1986
Hello Daniel

I tried the process again -- but still the same. Its stuck on unlock bootloader screen ...even the individual commands -- fastboot erase userdata ain't responding :(

Is there still hope to get it up and running again ??? Is this what people call as bricked ?
Please help !
Gringo Zorro
1/8/15
Gringo Zorro
Looks like you have to try your luck with Asus service. There have been many similar reports.
676 MORE
Penelope R
12/28/16
Penelope R
Hi eddie, there never was a petition of any note and now that the Nexus 7s are no longer supported, there's little to be done other than to take the tablet to a local repairer or, as you have done, acquire spare parts and tackle the job yourself.

I'm lucky that I do still have two working Nexus 7s and wish you lots of luck in your endeavours.

Best,

Penny
N7 '12 & '13; Pixel-C
Factory images flashed at device owners risk
For all things Android & Nexus click HERE

 

Badges

Some community members might have badges that indicate their identity or level of participation in a community.

 
Google Employee — Google product team members and community managers
 
Community Specialist — Google partners who help ensure the quality of community content
 
Platinum Product Expert — Community members with advanced product knowledge who help other Google users and Product Experts
 
Gold Product Expert — Community members with in-depth product knowledge who help other Google users by answering questions
 
Silver Product Expert — Community members with intermediate product knowledge who help other Google users by answering questions
 
Product Expert Alumni — Former Product Experts who are no longer members of the program
Community content may not be verified or up-to-date. Learn more.

Levels

Member levels indicate a user's level of participation in a forum. The greater the participation, the higher the level. Everyone starts at level 1 and can rise to level 10. These activities can increase your level in a forum:

  • Post an answer.
  • Having your answer selected as the best answer.
  • Having your post rated as helpful.
  • Vote up a post.
  • Correctly mark a topic or post as abuse.

Having a post marked and removed as abuse will slow a user's advance in levels.

View profile in forum?

To view this member's profile, you need to leave the current Help page.

Report abuse in forum?

This comment originated in the Google Product Forum. To report abuse, you need to leave the current Help page.

Reply in forum?

This comment originated in the Google Product Forum. To reply, you need to leave the current Help page.