/meet/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
Can't connect, message "getting ready... you'll be able to join in just a moment" 1 Recommended Answer 97 Replies 717 Upvotes
1 Recommended Answer
$0 Recommended Answers
1 Relevant Answer
$0 Relevant Answers
Can't connect videocalls, message ''you'll be able to join in just a moment'' same problem with crhome, firefox... in some networks, home and working, i restore chrome, disable hardware acceleration, etc, i need your help
Details
Relevant Answer Relevant Answers (0)
All Replies (97)
Relevant Answer
I having the same problem. คาสิโน
marked this as an answer
Relevant Answer
same issue. tried the following
- clear cache & history
- incognito mode
- disable extensions
- reboot
- external camera.

none is working. frustrating when we are WFH and we cant connect.
help, please!
marked this as an answer
Relevant Answer
Same here, with Meet in Firefox Linux Mint 19.

marked this as an answer
Relevant Answer
same problem plz help someone
marked this as an answer
Relevant Answer
Hi everyone,
I simply restarted my computer and then everything was fixed!
(also had to log back into my google accounts after that).
Hope this works,
:)
marked this as an answer
Relevant Answer
same problem :( tried all of the tips you guys listed here, nothing works :(
marked this as an answer
Relevant Answer
Same issue - this is a real pain because meets doesn't work all that well in Safari
marked this as an answer
Relevant Answer
Any update on this? Thanks
marked this as an answer
Relevant Answer
I am also facing this. Please update with solution. tried restarting computer and did not work
marked this as an answer
Relevant Answer
Hi David and all, is this happening in Classic Hangouts (hangouts.google.com) or Meet (meet.google.com)?
 
Have you tried disabling all extensions and add-ons?
And have you tried different web browsers (sounds like yes)?
 
marked this as an answer
Relevant Answer
No, same problem, finally I can solve it upgrading Windows 10 to the last version.
marked this as an answer
Relevant Answer
Hi thanks for your attention. 
It happens on meet.google.com.
I tried in Safari and it works, with my another google account though. So not sure if it's a browser or user account problem. But then I tried android meet and it works just fine, with the same account that didn't work on Chrome. So I guess it's not an account issue, but rather chrome issue?  Tried disabling extensions, didnt work.Thanks
marked this as an answer
Relevant Answer
David: thank you for sharing your solution, that upgrading Windows 10 to the latest version works. 
 
Oliver: It sounds like you are probably using a Mac.Is that correct?
 
Meet needs permission to use your camera and microphone in Chrome. Although you are asked to allow access the first time you join a Meet video call, you can change the setting to allow Meet to use your camera and microphone.
For example, if Meet can’t access your camera, click the camera icon  in the address bar and select the Always allow option. 
See if that helps.
 
marked this as an answer
Relevant Answer
Hi Thanks for quick reply. Yes I'm using Mac. Both Mic and Cam are enabled..I can see myself and hear the test sound fine. Still "getting ready" forever.
marked this as an answer
Relevant Answer
Same issue for me:(
marked this as an answer
Relevant Answer
Same issus. Still getting ready. I am using Chrome on a Mac. I was able to get on one time and then the next meeting shortly after, it did not.
marked this as an answer
Relevant Answer
Those of you using Chrome on a Mac, do you have the same issue if you switch to Firefox or Safari? 
 
And have you tried temporarily disabling all extensions and add-ons?
marked this as an answer
Relevant Answer
Hey guys. I disabled all extensions and re-enabled them...Seems to be fine now. don't know why, but you can try disable one by one to see which one might be interfering.
marked this as an answer
Relevant Answer
The other days resolved with a Chrome update, today resolved with a Windows restart..
marked this as an answer
Relevant Answer
HI, I have no add ons and the "camera getting ready" keeps happening at different times.  AND without touching anything, as I am in the meet without camera on because I keep seeing "camera getting ready" - then by itself, like someone has remote control over my computer and in the meet, the icon which was white (but no actual video camera working) goes red.   ANd then it goes back to white (still not actual camera working) -BY ITSELF.  I am not making a joke or kidding.  It happens on it's own.  THe camera NEVER ends up working.  I leave the meet and rejoin.  I get out of the email from whence I launched (I have to launch within our uni email) and rejoin but the camera doesn't work.  I finish the meet and leave the meeting.  Start another google meet and the camera works.. Back and forth.  Works doesn't work.  DId all the checks in settings - on this page https://support.google.com/meet/answer/7380413  and still this problem occurs.  
The green light is on indicating the facetime camera is working sometimes STAYS on after I leave the Google Meet and close out the tab.  I have shut down chrome, log out to get the facetime camera to turn off.  Something isn't right.  There must be hacking of some sort going on.  PLEASE can you fix this.  

I am on a mac. 10.1.3.6 High Sierra   Chrome is updated, no add ons ..  please give a fix for this.
marked this as an answer
Relevant Answer
Hi Katherine Kirby, since your issue is with Google Meet not Google Hangouts, please post your issue in the Meet help community here: 
 
 
marked this as an answer
Relevant Answer
Oyi.  Seems like the identical issue anyhow.
marked this as an answer
Relevant Answer
even i am facing same problem......no updates
marked this as an answer
Relevant Answer
just download the latest updates of windows.i have resolved my issue.
marked this as an answer
Relevant Answer
Had the same problem.. I used to have my phone connected to my system through USB for file transfer.
But when I changed to" charging only" it was solved. I think the site thinks the phone is a USB camera and was trying to connect to it, and changing the option seemed to fix the problem.
marked this as an answer
Relevant Answer
- I know its a temporary fix but open Firefox in "new       private window"  remove extensions
- Then go to Google meet 
-Type in the meet id
-Firefox asks for camera microphone and webcam permission. Allow for all three.  Yes "thrice"
And your good to go
marked this as an answer
Relevant Answer
I have found a solution. The problem is your browser is blocking WebRTC and meet cannot verify you. To solve this google 'How to enable WebRTC in {Your Browser Name}' or add an Extention that can enable and disable WebRTC on a click.

*Disabling extensions won't enable WebRTC until you do it manually or by a extention.*
marked this as an answer
Relevant Answer
Guys, disabling the WebRTC works for me. You should try that, too. Thanks to this guy above me.

marked this as an answer
Relevant Answer
Hello Everyone,I just found a great solution..
Instead of searching for (google meet) in your browser search bar just try searching for (google hangouts)
and when it shows all the related search results simple find and click on Join a meeting... and then follow all the required procedures and congratulations you are done.
If still you can't get it click on the link:
marked this as an answer
Relevant Answer
I restart my computer, log out my account and did network switching but it did not help
marked this as an answer
Relevant Answer
same been happening for a couple days
marked this as an answer
Relevant Answer
affecting me as well.
marked this as an answer
Relevant Answer
Also having this issue still
marked this as an answer
Relevant Answer
same really frustrating i downloaded a visual effects plugin and when i once joined with it my external camera is misbehaving and stuck at getting ready
marked this as an answer
Relevant Answer
Hey, people. In my case it was this plugin called WebRTC Leak Shield who was preventing Meet from working. I've disabled it and now it works! I hope this helps somebody
https://addons.mozilla.org/es/firefox/addon/webrtc-leak-shield/
marked this as an answer
Relevant Answer
simply restart the computer its more than enough to fix the problrm
marked this as an answer
Relevant Answer
This seems to be an issue with WebRTC.

WebRTC is a project that provides a simple API for web developers to allow audio and video communication to work through peer-to-peer connections, eliminating any sort of dependency as in a plugin or native app.

Before we begin, WebRTC does not work on any browser version less than:
  1. Microsoft Edge 12
  2. Google Chrome 28 (28 on Android, but must be enabled for 28 in specifics. 29+ is enabled by default)
  3. Mozilla Firefox 22 (24 on Android)
  4. Safari 11
  5. Opera 18 (12 on Android)
  6. Vivaldi 1.9
  7. Safari on iOS 11
If you're using one of these browsers, WebRTC will not work and thereby Google Meet or Google Hangouts. If you aren't, WebRTC depends upon several JavaScript APIs:

  1. getUserMedia, which acquires the audio and video of your device (which is simple enough and is not the issue here.
  2. RTCPeerConnection, which enables the communication between peers.
  3. RTCDataChannel, which allows for the "real-time" communication of two peers.
  4. There's also getStats for data collection but that's not the issue.
The issue is RTCPeerConnection, which you might have disabled in your browser because of a flaw in Firefox 69+ which allows for the internal IP address of your device to be listed.

First, try enabling JavaScript on Google Meets. You can find this in your browser's settings.

If that doesn't work, you'll need to enable WebRTC manually.

Chrome for Desktop

Chrome does not offer any sort of WebRTC preventage on desktop. You might have an extension that disables WebRTC, however.

Chrome for Mobile

Type in the following URL to your address bar:

chrome://flags/#disable-webrtc, and scroll down where it says "WebRTC STUN origin header". Enable it.

Firefox for Desktop/Android

Type in the following URL to your address bar:

about:config.

Accept the risk (don't worry, 99% of the stuff here won't cause damage to your computer) and enable "media.peerconnection.enabled".

Microsoft Edge for Desktop/Mobile

There's no way to enable/disable WebRTC but you can try the following tip.

Type in the following URL to your address bar:

about:flags, and uncheck the "Anonymize local IP addresses over WebRTC connections".

Safari for Desktop

Open Safari and go into Safari > Preferences. Go into the Advanced tab and check the box at the bottom to show develop menu. Close the preferences window and navigate to the Develop tab, then "Experimental features". Look for the option named "Remove Legacy WebRTC API and uncheck it.

Safari for iOS/iPadOS

Go into the Settings app and scroll down to Safari > Advanced > Experimental features. Look for the option named "Remove Legacy WebRTC API and uncheck it.

Brave Browser for Desktop/Mobile

Open Brave and go to Preferences > Shields > Fingerprinting Protection and uncheck "Block all fingerprinting". Next, go to Preferences > Security > WebRTC IP Handling Policy and enable Non-Proxied UDP.

Vivaldi for Desktop/Mobile

Open the configuration screen and open the "Privacy" tab and check the option under WebRTC IP Handling called "Broadcast IP for best WebRTC Performance".

If none of these work, restart your computer and try again.
marked this as an answer
Relevant Answer
As an addendum to my comment, also check your hosts file/firewall and see if you're blocking any Google Meet URLs that are used to connect to Google Meet. The primary one is https://hangouts.clients6.google.com.
marked this as an answer
Relevant Answer
Once I disabled the extension to work offline on Docs, Sheets, & Slides it started working again.
marked this as an answer
Relevant Answer
So I sat down and tried to come up with the solution. So here it is. Before starting any meeting if you change the settings from Allow to Ask(default) for Microphone and Camera the ready to join option is displayed but when you start a new meeting the next time, its the same problem again. So like you need to change the settings for Camera and Microphone to Ask everytime before you start or join a meeting. But we need a better solution. Is anyone seeing this from Google Meet team or somethin. 
BTW I use chrome from my windows 10.
marked this as an answer
Relevant Answer
Getting the same error!!
Only opens on non chromium based browsers, i.e. Firefox
marked this as an answer
Relevant Answer
Thank you for the reports. Does this happen if you disable all extensions?
 
And are you running any security or anti-virus software that might be interfering with Meet scripts loading? IF so, can you whitelist Meet?
marked this as an answer
Relevant Answer
It's usually caused by a WebRTC blocking plugin, check if you have one installed in your browser
marked this as an answer
Relevant Answer
wow!  thank you for the reply.  I have no extensions.  It happens even though I have not changed any of the parameters with which I use Google meet. I have only been able to "fix" the issue by using firefox for awhile and the after about two weeks or so restarting with google meet.  I have read through and googled a lot about this issue and it seems it is NOT uncommon and there seems to be very little understanding of the problem.  I stopped using google meets over the summer but will have to start using google meet again in a few weeks as that is what our school uses in a G suite.  Please fix this because it is integral to getting high quality work done consistently.  Thank you.
marked this as an answer
Relevant Answer
Got the reason. Chrome has its "Utility: Video Capture" Which is glitching out I think. Opening up the chrome task manager and ending its tasks resolves the issue but then you are stuck with no video. I think this is a bug in Meet, as it is only affecting chromium based browser which use that utility. Firefox on the other hand handles cameras differently so it is not affected.

Hope you find this useful,
Raunak
marked this as an answer
Relevant Answer
No while doing this I don't think that my chrome extensions where disable also I don't use any third party anti-virus software.
marked this as an answer
Relevant Answer
The only solution for this is to wait for sometime.
marked this as an answer
Relevant Answer
I have the same probleme
marked this as an answer
Relevant Answer
I still haven the same problem i can't reply massage
marked this as an answer
Relevant Answer
I solved it when I disabled all extension, specially those related to VPN or Proxy
marked this as an answer
Relevant Answer
It was working few days back for me. Then suddenly I faced the same issue. Then realized that few days back I have installed some extension in chrome. I removed those and now working fine.
marked this as an answer
Relevant Answer
I installed  virtual backgrounds extension and it didn’t work I removed it and it still didn’t work please help me
marked this as an answer
Relevant Answer
Hello David,

This can be a result of slow network connection or almost complete disconnection. Just be patient, if it still loads for 5 minutes restart the computer.

Thank you,
Tudor Ion
marked this as an answer
Relevant Answer
When you turn your computer on, click the arrow near your account and click "Remove user from this computer" or something. Then just re-enter your info, and bam.
marked this as an answer
Relevant Answer
Faced it quite a few times with no specific reason. However when tried after signing out of gmail and signing in back, it worked.
marked this as an answer
Relevant Answer
why  icant send a message on hangouts its said faailed
marked this as an answer
Relevant Answer
I've got the same issue on only one chromebook and it does not resolve by restarting or even powerwashing the chromebook.
marked this as an answer
Relevant Answer
same issue here. tried the following
-restarting chromebook
-closing all tabs and opening chrome again
-reloading
-reloading the page i got the link from
i cant participate in class unless i use a mac or my windows pc.
marked this as an answer
Relevant Answer
Our students are having the same issue.  They click link to join classroom meet and it goes to the Getting ready screen and then sits and spins.  Our students are using chromebooks.
marked this as an answer
Relevant Answer
If they are experiencing this issue, please have them try temporarily disabling all extensions and add-ons. That's especially important to disable any extensions designed to modify Meet. 
 
Also, security and anti-virus software might interfere with Meet, so it should be configured to allow the meet page to load fully and not block any scripts.
marked this as an answer
Relevant Answer
I have probleme to coneected in hangout in my the gmail (jamalelmadyny@gmail.com)
marked this as an answer
Relevant Answer
من فضلكم ساعدوني مازلت أواجه مشكلة في الإتصال بالخادم  أو الإميل ( jamalelmadyny@gmail.com)
marked this as an answer
Relevant Answer
Same but mine just doesn't work at all on this device so I have to use another.
marked this as an answer
Relevant Answer
I found a fix that works for me. What i had wrong was just meet not recognizing the right device for my webcam. I had a kind of software called "Chromacam", just to put cool backgrounds on my webcam, and meet recognized it as a webcam, so it only worked when i started it. Therefore when the software wasn't started meet wouldn't connect or do anything. What i advice is to check for any software that you have that may change your default webcam device and therefore not start meet.
marked this as an answer
Relevant Answer
How can I solve that
marked this as an answer
Relevant Answer
It tells me I have a error it keeps me from calling my friends
marked this as an answer
Relevant Answer
i reseted my chromebook and its still not working
marked this as an answer
Relevant Answer
My computer has been doing the same thing for a week now I can't join any video calls. Hangout, zoom, camera, google meets, etc.I need help
marked this as an answer
Relevant Answer
we have the same problem
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/meet/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/meet/profile/0