Meet system requirements on your computer

To use Meet, your computer must follow these requirements:

Supported operating systems

Meet supports the current version and the 2 previous major releases of these operating systems: 

  • macOS®
  • Windows®
  • Chrome
  • Ubuntu® and other Debian-based Linux® distributions
Supported web browsers

Meet works with the current version and 1 previous major release of the browsers listed below:

Camera and microphone access
When you start a video call for the first time, you need to let Meet use your camera and microphone.
System requirements
  • Broadband connection to the Internet. Learn more
  • A built-in web camera or external USB camera.
    Note: Other devices, such as virtual cameras, may not work with Meet.
  • 2.2 GHz Intel 2nd-generation i3/i5/i7, AMD equivalent, or better is required to support HD video.

If your computer meets the requirements, but you're still experiencing trouble with video calls, try these troubleshooting steps.

Specifications

Video calls can have a maximum number of participants depending on the G Suite edition for your organization. Learn more​ 

Was this article helpful?
How can we improve it?