/maps/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
7/18/19
Images on Google My Maps aren't loading 0 Recommended Answers 113 Replies 225 Upvotes
1 Recommended Answer
$0 Recommended Answers
When I was working on my custom map on Google My Maps, I checked the markers that had images previously and it doesn't load. I checked the other markers to make sure it isn't just that pin alone and it's affecting almost all of them. It even happens when I try to add an image to a marker.

Could someone please fix this issue?
All Replies (113)
7/18/19
Hi there,
 
Can you check if uploading the image to My Maps through drive/google photos works.
marked this as an answer
7/18/19
Doesn't work
marked this as an answer
-
7/19/19
I uploaded the image through Google Drive and it still didn't work
marked this as an answer
7/19/19
Mayb e  I  haven't correctly understood your  issue.
But I just tried successfully uploading  two  different  images  to the first  two  points of the first  Layer  in one of myMaps here 

the image of the first  point  I uploaded to the MyMaps  from my computer  and the image of the  second point I  uploaded  via  GoogleDrive:
Sorry  for  eventually  being  off your topic
marked this as an answer
7/20/19
It's also not working for me. I'm part of a huge collaborative map (20,000+ points) and the images currently being uploaded aren't working; they upload correctly but show up as a black screen in Edit Point View. Additionally, some of our newer images for the last few months uploaded both via links and direct from desktop are also blacked out. Older images still show up fine.
marked this as an answer
7/21/19
I'm having a similar issue. I want to add a Photo to my Marker but Google Maps is not recognizing the photos that I've uploaded to Drive.
marked this as an answer
7/22/19
This has just recently happened to me as well, was working fine last week and now all images on my maps that I have uploaded are blacked out. Is this a glitch? I have a lot of data points that all have photos and I don't to have to go through and re-upload them all... Has anyone found a solution?
marked this as an answer
7/22/19
I have created a map this week and not one of the photos I have tried to add to a marker comes up. I just get a black square. The couple videos that I added are fine, but not one photo I have tried to add comes up. I have used My Photos, My Drive, Photobucket, links from Wikipedia and from my device. Nothing works. This started as a side project to see if I could map out a book series, but it is now something that I need to get completed to include the photos.

Helmut Geissler: I just checked your link and neither photo shows. When you click where the photo should be it shows a broken picture icon.
marked this as an answer
7/22/19
This is really frustrating. When I go to the view to edit and add things to my maps, I cannot see the picture, it is a black square. I just went to the regular view and all the pictures show up. I guess I am just going to have faith that the pictures I add are going to be on the map until I go back and check the map out of Edit mode.
marked this as an answer
2/21/20
You are all correct it is impossible to load Google earth for free yet it claims the process is easy. I believe Google wishes you to use a pay site where it will be entitled to a large percentage of the revenue .Bastard yanks
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/maps/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/maps/profile/0?hl=en