System requirements and issues

In order for the fully-enabled Google Maps to run on your computer (with 3D Imagery), your system needs to meet the following requirements:

  1. The latest version of one of the following browsers:
    • Google Chrome
    • Firefox
  2. One of the following operating systems:
    • Mac OS 10.8.3+
    • Windows 7 or 8
    • Chrome OS*
  3. Up to date video card hardware and drivers.
For Lite mode, you must have either Safari 6+, IE 10, or IE 11. Other combinations may work, but are not officially supported. Lite mode will also work for Windows XP, Windows Vista, or Mac OSX lower than 10.8.3.

*You can use the fully-enabled Maps on your Chrome OS computer if it has an Intel CPU.

There is no support for mobile browsers at this time.