About Map Maker

System requirements

If your machine and internet connection provide a good experience on Google Maps, then Google Map Maker will work similarly well on your system. We recommend using one of the following browsers for the best experience:

  • Microsoft Internet Explorer (IE) 9.0 and later (for Windows) Download
  • Firefox 3.6 and later (for Windows, Mac, and Linux) Download
  • Safari 3.1 and later (for Mac and Windows) Download
  • Google Chrome (for Windows and Mac) Download

How helpful is this article:

Feedback recorded. Thanks!
  • Not at all helpful
  • Not very helpful
  • Somewhat helpful
  • Very helpful
  • Extremely helpful